Debian Chroot unter DSM 6.2

Creadle

Benutzer
Mitglied seit
23. Okt 2010
Beiträge
243
Punkte für Reaktionen
0
Punkte
16
Hallo, hatte bis dato ein Debian Chroot was immer funktioniert hat, blöderweiße schon seit einer Geraumen Zeit nicht mehr verwendet. Heute wollte ich es wieder, allerdings bei so Ziemlich allen kommt "Segmentation fault"

Code:
./serverstart.sh: line 1: 6988 Segmentation fault chroot --userspec=server /volume2/@appstore/debian-chroot/var/chroottarget/ /home/server/server/start-lfd2.sh start

Daher mal richtig ins Chroot gewechselt

Code:
root@DS2413:/#
root@DS2413:/# login
DS2413 login: server
Password:
Last login: Wed Nov 8 18:33:56 CET 2017 on pts/4
run-parts: /etc/update-motd.d/10-uname exited because of uncaught signal 11
Linux DS2413 3.10.102 #15152 SMP Fri Oct 6 18:13:48 CST 2017 x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
/var/packages/debian-chroot/scripts/start-stop-status: line 52: 7396 Segmentati on fault chroot ${CHROOTTARGET}/ /bin/bash

Nun, wollte dann mal Pakete aktualisieren, selbe Fehler

Dachte, bevor ich lange herummache, einfach deinstallieren und neu machen.

Jetzt kommt das verzwickte, das Paket Debian chroot gibts wohl nicht mehr, zumindest fürs DSM 6.2.

Habe daher das alte Paket von https://synocommunity.com/package/debian-chroot genommen und die INFO angepasst, hab es installieren können. Dann die Workarounds durch. Nur scheint es so das das Chroot trozt Meldung das es "läuft" eben nicht aktiv ist, ich kann zwar hinein wechseln und Programme installieren und Anpassungen vornehmen, aber das eigentliche läuft nicht. Zumindest denke ich das, weil eben Steamcmd diesen Fehler wirft

server@DS2413:~/server$ ./steamcmd.sh
Redirecting stderr to '/home/server/Steam/logs/stderr.txt'
threadtools.cpp (3409) : Assertion Failed: Failed to create thread (error 0x16)

Dieser Fehler deutet doch meines erachtens darauf hin, das chroot eben nicht "läuft" Also lügt der Status, da dieser sagt es würde laufen.

Bin gerade etwas verzweifelt
 
Zuletzt bearbeitet:

arphex

Benutzer
Mitglied seit
17. Nov 2011
Beiträge
164
Punkte für Reaktionen
0
Punkte
22
Scheint so, dass es das debian Chroot nicht mehr gibt, bzw. seit DSM 6.x zu viele Fehler auftraten.

Ein schmerzlicher Verlust für die Synology Community. Ich kann mich nur insoweit besänftigen, das es die apollolake Arch noch nicht unterstützt hat: https://synocommunity.com/package/debian-chroot
 

Creadle

Benutzer
Mitglied seit
23. Okt 2010
Beiträge
243
Punkte für Reaktionen
0
Punkte
16
Ja, habe in dem Chroot meine Server gehostet (paar Dedizierte Server, zb L4D2, GarrysMod etc.) Hat die Rechenpower dicke gereicht. Und da wir nur Gelegenheitsspieler sind,war es die perfekte Lösung.
 
NAS-Central - Ihr Partner für NAS Lösungen
NAS-Central - The Home of NAS

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat