DDNS Updater 2 dynv6 wird nicht aktualisiert

gente

Benutzer
Mitglied seit
07. Mrz 2016
Beiträge
249
Punkte für Reaktionen
0
Punkte
22
...dynv6 wird über DDNS Updater 2 seit Tagen nicht mehr aktualisiert auf der Homepage schon (IP4 und IP6). Einstellungen alles korrekt wie schon als alle noch funktionierte!
"keine Aktualisierung erforderlich..."
LG Thomas
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.338
Punkte für Reaktionen
1
Punkte
84
Ist denn die ermittelte IP vom DDNS Updater abweichend von der, die beim manuellen Update auf der HP verwendet wurde? Kontakt zum Anbieter scheint noch zu bestehen, sonst würde er keine Rückmeldung "keine Aktualisierung erforderlich..." erhalten.
 

gente

Benutzer
Mitglied seit
07. Mrz 2016
Beiträge
249
Punkte für Reaktionen
0
Punkte
22
...dynv6 zeigt die IP welche schon vor einigen Tagen vergeben wurde, aber auf der Homepage die aktuelle. Alle anderen DDNS werden korrekt aktualisiert.
LG Thomas
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.338
Punkte für Reaktionen
1
Punkte
84
Ich möchte wissen, welche IP der DDNS Updater ermittelt hat bzw. er an dynv6 übermittelt. Rechts oben im DDNS Updater werden die ermittelten IP's angezeigt, die übermittelte IP ist im debug.log zu finden.
 

raggax

Benutzer
Mitglied seit
29. Jan 2013
Beiträge
69
Punkte für Reaktionen
0
Punkte
6
Hallo,

ich habe ein ähnliches Problem, er meldet das es keine Änderung der IP Adresse gibt und er deshalb nicht aktualisiert. Das Problem ist aber, dass der DDNS2 nur google verwendet um die IP Adresse festzustellen und da stimmt was nicht:

2016/10/08 07:53:36 WARNING : https://domains.google.com/checkip returned no valid ipv4 ip (2003:61:ce4e:ae5............), trying next server

Er tried aber keinen next server und google respondet leider nur eine ipv6 Adresse, das klappt natürlich nicht, ich habe jetzt den google Dienst mal raus aus der IP Feststellungsserverliste (oder wie das heisst) und werde es weiter beobachten.

Gruß René
 

gente

Benutzer
Mitglied seit
07. Mrz 2016
Beiträge
249
Punkte für Reaktionen
0
Punkte
22
die ermittelten IP's IP4 und IP6 sind OK (rechts oben)
...nur beim übermitteln tritt laut log ein Fehler auf, TwoDNS (siehe Log) und andere Anbieter funktionieren!

Auf der Original Homepage hat der Host die richtigen Adressen übermittelt 7:30 Uhr nach Start Synology NAS.

debug:
2016/10/08 07:57:16 SUCCESS : updating gente.diskstation.eu, status: good, IP set to 84.56.8.???
2016/10/08 07:57:16 INFO : Force update of gente.diskstation.eu by user!
2016/10/08 07:57:16 WARNING : Please wait at least until 08:00:11 (175s) to update gente.dynv6.net from 0 to 84.56.8.???!
2016/10/08 07:57:16 WARNING : Last successful update of gente.dynv6.net was never, but last try 2016-10-08 07:55:11 failed!
2016/10/08 07:57:16 WARNING : Please wait at least until 08:00:15 (179s) to update bettho.dynv6.net from 0 to 84.56.8.???!
2016/10/08 07:57:16 WARNING : Last successful update of bettho.dynv6.net was never, but last try 2016-10-08 07:55:15 failed!
2016/10/08 07:57:15 INFO : Debug mode: on
2016/10/08 07:57:15 INFO : Daemon reloads config
2016/10/08 07:55:15 WARNING : Use of uninitialized value in concatenation (.) or string at /volume1/@appstore/ddnsupdater2/sbin/../lib/DDNSUpdater/Tools.pm line 434.
2016/10/08 07:55:15 FAILED : updating bettho.dynv6.net, status: addresses unchanged
2016/10/08 07:55:11 WARNING : Use of uninitialized value in concatenation (.) or string at /volume1/@appstore/ddnsupdater2/sbin/../lib/DDNSUpdater/Tools.pm line 434.
2016/10/08 07:55:11 FAILED : updating gente.dynv6.net, status: addresses unchanged
2016/10/08 07:55:10 INFO : Force update of gente.dynv6.net by user!
2016/10/08 07:55:09 INFO : Debug mode: on
2016/10/08 07:55:08 INFO : Daemon reloads config

LG Thomas
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.338
Punkte für Reaktionen
1
Punkte
84
@raggax: Hat sich dein Anschluss von IPv4 in IPv6 geändert? https://domains.google.com/checkip liefert bei mir eine IPv4 zurück. Wieso er aber nicht den nächsten Server versucht, kann ich im Moment nicht sagen. Für weitere Analysen bräuchte ich das debug.log.

@gente: Also kennt der DDNS Updater die richtige IP und hat sie auch aktualisiert, nur hat er beim Eintragen der Rückmeldung ein Problem und bricht ab. Wenn du das debug.log die ganze Zeit aktiviert hattest (also schon beim 1. Post), dann deaktviere mal bitte das debug.log testweise. (ein bestehendes debug.log wird beim späteren Reaktivieren gelöscht!!!). Grund: In der Zeile wo die Fehlermeldung im Log auftritt befindet sich nur die Ausgabe eines Teils für das debug.log, weiss nur noch nicht welche Variable da ein Problem hat.
 

gente

Benutzer
Mitglied seit
07. Mrz 2016
Beiträge
249
Punkte für Reaktionen
0
Punkte
22
...bei mir wird da nichts gelöscht, selbst das Anhalten des Pakets bringt keine Besserung, steht alles noch so im Log wie zuvor!
LG Thomas
 

raggax

Benutzer
Mitglied seit
29. Jan 2013
Beiträge
69
Punkte für Reaktionen
0
Punkte
6
Screen Shot 2016-10-08 at 19.45.47.jpg

google bringt beim mir manchmal ip6 und manchmal ip4, nach dem Screenshot habe ich den Reload Knopf gedrückt und es gab ne ip4 Adresse...

Hab nen Telekom Anschluss der sich, zumindest meinem Kenntnisstand nach nicht geändert hat, eventuell hat die Telekom ja das IPV6 Problem in ihren Speedports gelöst und jetzt....
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.338
Punkte für Reaktionen
1
Punkte
84
...bei mir wird da nichts gelöscht, selbst das Anhalten des Pakets bringt keine Besserung, steht alles noch so im Log wie zuvor!
LG Thomas
Das debug.log wird beim Erneuten Aktivieren und Sichern der Einstellung gelöscht. Das Paket bitte mit deaktiviertem debug.log starten und erneut versuchen die IP zu aktualisieren.
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.338
Punkte für Reaktionen
1
Punkte
84
@raggax: evtl. ist dies nur bei google so, du hattest es ja schon deaktiviert. Bitte weiter beobachten, ob dies bei anderen Seiten ebenfalls auftritt.
 

gente

Benutzer
Mitglied seit
07. Mrz 2016
Beiträge
249
Punkte für Reaktionen
0
Punkte
22
...keine Besserung alles wie es war!
Die Debug Log hat trotzdem noch alle Einträge seit Installation derselben.
Trotzdem erstmal Danke für die Tipps.

LG Thomas
 

Frogman

Benutzer
Mitglied seit
01. Sep 2012
Beiträge
17.485
Punkte für Reaktionen
2
Punkte
414
Ich habe mir jetzt bei dynv6.com eine DDNS-Adresse geholt und versuche die mit dem Updater zu aktualisieren - habe damit auch die Probleme. Obwohl IPv4 und IPv6 über DSM korrekt erkannt werden, wird nur die IPv4 aktualisiert. Allerdings bleibt im Fenster 'n/a' stehen, sowohl bei der IP als auch dem Zeitstempel:

dynv6.jpg

Nach Ablauf von jeweils 3 Minuten gibt's dann im DSM Fehlermeldungen:

ddns.jpg

Debug-Log:

Code:
2016-10-09 17:24:07    DEBUG    : ===============================
2016-10-09 17:24:07    DEBUG    : ***Debug start***
2016-10-09 17:24:08    DEBUG    : x.x.x.x- ipv4
2016-10-09 17:24:08    DEBUG    : using dsm internal method to get current external ipv4 ip
2016-10-09 17:24:08    DEBUG    : x:x:x:x:x:x:x:x- ipv6
2016-10-09 17:24:08    DEBUG    : using dsm internal method to get current external ipv6 ip
2016-10-09 17:24:08    DEBUG    : --------------
2016-10-09 17:24:08    DEBUG    : Update of xxx.dynv6.net, because ip changed from 0 to x.x.x.x!
2016-10-09 17:24:08    DEBUG    : computed vars:
2016-10-09 17:24:08    DEBUG    : host: xxx.dynv6.net - id: 0, last  update: never, ip-system: ipv4, ip-set method: auto, offline: no,  offline method: customip, offline shutdown: no, offline script: no,  script after update: no, fake-ip-workaround: no, update: 0 ->  x.x.x.x, wait time: 0s, force-update: no
2016-10-09 17:24:08    DEBUG    : --------------
2016-10-09 17:24:08    DEBUG    : Build updatevars:
2016-10-09 17:24:08    DEBUG    : protocol: dynv6
2016-10-09 17:24:08    DEBUG    : module: default
2016-10-09 17:24:08    DEBUG    : mxfields: 0
2016-10-09 17:24:08    DEBUG    : authmethod: url
2016-10-09 17:24:08    DEBUG    : offline_ip: x.x.x.x
2016-10-09 17:24:08    DEBUG    : static_params: 
2016-10-09 17:24:08    DEBUG    : ips: 
2016-10-09 17:24:08    DEBUG    :     ipv6: x:x:x:x:x:x:x:x
2016-10-09 17:24:08    DEBUG    :     ipv4: x.x.x.x
2016-10-09 17:24:08    DEBUG    : logintag:  
2016-10-09 17:24:08    DEBUG    : tags: 
2016-10-09 17:24:08    DEBUG    :     hostname: xxx.dynv6.net
2016-10-09 17:24:08    DEBUG    :     ipv4: x.x.x.x
2016-10-09 17:24:08    DEBUG    :     token: xxx
2016-10-09 17:24:08    DEBUG    : server: http://ipv4.dynv6.com
2016-10-09 17:24:08    DEBUG    : ssl: 0
2016-10-09 17:24:08    DEBUG    : ipsystem: ipv46
2016-10-09 17:24:08    DEBUG    : ipv6: auto
2016-10-09 17:24:08    DEBUG    : iptag: ipv4
2016-10-09 17:24:08    DEBUG    : req_method: GET
2016-10-09 17:24:08    DEBUG    : passtag: token
2016-10-09 17:24:08    DEBUG    : ipv6tag: ipv6
2016-10-09 17:24:08    DEBUG    : id: 0
2016-10-09 17:24:08    DEBUG    : hostgroupby: 
2016-10-09 17:24:08    DEBUG    : script: /api/update
2016-10-09 17:24:08    DEBUG    : shutdown: 0
2016-10-09 17:24:08    DEBUG    : --------------
2016-10-09 17:24:08    DEBUG    : Execute update call:
2016-10-09 17:24:08    DEBUG    : http://ipv4.dynv6.com/api/update?hostname=xxx.dynv6.net&ipv4=x.x.x.x&token=xxx
2016-10-09 17:24:09    DEBUG    : return: 'addresses updated'
2016-10-09 17:24:09    DEBUG    : 0 - http:200
2016-10-09 17:24:09    DEBUG    : 0: 
2016-10-09 17:24:09    DEBUG    :     code: addresses updated
2016-10-09 17:24:09    DEBUG    :     host: xxx.dynv6.net
2016-10-09 17:24:09    DEBUG    : --------------
2016-10-09 17:24:09    DEBUG    : Check result:
2016-10-09 17:24:09    DEBUG    : --------------
2016-10-09 17:24:09    DEBUG    : xxx.dynv6.net: status found: addresses  updated, ip set: , last successful update: never, wait time: 0s, next  update attempt: 2016-10-09 17:29:09
2016-10-09 17:24:10    DEBUG    : ***Debug end***
2016-10-09 17:24:10    DEBUG    : ===============================
2016-10-09 17:27:10    DEBUG    : ===============================
2016-10-09 17:27:10    DEBUG    : ***Debug start***
2016-10-09 17:27:11    DEBUG    : x.x.x.x - ipv4
2016-10-09 17:27:11    DEBUG    : using dsm internal method to get current external ipv4 ip
2016-10-09 17:27:12    DEBUG    : x:x:x:x:x:x:x:x - ipv6
2016-10-09 17:27:12    DEBUG    : using dsm internal method to get current external ipv6 ip
2016-10-09 17:27:12    DEBUG    : --------------
2016-10-09 17:27:12    DEBUG    : [WARNING] Last successful update of  xxx.dynv6.net was never, but last try 2016-10-09 17:24:09 failed!
2016-10-09 17:27:12    DEBUG    : [WARNING] Please wait at least until  17:29:09 (117s) to update xxx.dynv6.net from 0 to x.x.x.x!
2016-10-09 17:27:12    DEBUG    : --------------
2016-10-09 17:27:12    DEBUG    : ***Debug end***
2016-10-09 17:27:12    DEBUG    : ===============================
2016-10-09 17:29:39    DEBUG    : ===============================
2016-10-09 17:29:39    DEBUG    : ***Debug start***
2016-10-09 17:29:39    DEBUG    : x.x.x.x - ipv4
2016-10-09 17:29:39    DEBUG    : using dsm internal method to get current external ipv4 ip
2016-10-09 17:29:39    DEBUG    : x:x:x:x:x:x:x:x - ipv6
2016-10-09 17:29:39    DEBUG    : using dsm internal method to get current external ipv6 ip
2016-10-09 17:29:39    DEBUG    : --------------
2016-10-09 17:29:39    DEBUG    : Update of xxx.dynv6.net, because ip changed from 0 to x.x.x.x!
2016-10-09 17:29:39    DEBUG    : computed vars:
2016-10-09 17:29:39    DEBUG    : host: xxx.dynv6.net - id: 0, last  update: never, ip-system: ipv4, ip-set method: auto, offline: no,  offline method: customip, offline shutdown: no, offline script: no,  script after update: no, fake-ip-workaround: no, update: 0 ->  x.x.x.x, wait time: 0s, force-update: no
2016-10-09 17:29:39    DEBUG    : --------------
2016-10-09 17:29:39    DEBUG    : Build updatevars:
2016-10-09 17:29:39    DEBUG    : protocol: dynv6
2016-10-09 17:29:39    DEBUG    : module: default
2016-10-09 17:29:39    DEBUG    : mxfields: 0
2016-10-09 17:29:39    DEBUG    : authmethod: url
2016-10-09 17:29:39    DEBUG    : static_params: 
2016-10-09 17:29:39    DEBUG    : offline_ip: x.x.x.x
2016-10-09 17:29:39    DEBUG    : ssl: 0
2016-10-09 17:29:39    DEBUG    : server: http://ipv4.dynv6.com
2016-10-09 17:29:39    DEBUG    : ipsystem: ipv46
2016-10-09 17:29:39    DEBUG    : tags: 
2016-10-09 17:29:39    DEBUG    :     hostname: xxx.dynv6.net
2016-10-09 17:29:39    DEBUG    :     ipv4: x.x.x.x
2016-10-09 17:29:39    DEBUG    : logintag:  
2016-10-09 17:29:39    DEBUG    : ips: 
2016-10-09 17:29:39    DEBUG    :     ipv6: x:x:x:x:x:x:x:x
2016-10-09 17:29:39    DEBUG    :     ipv4: x.x.x.x
2016-10-09 17:29:39    DEBUG    : passtag: token
2016-10-09 17:29:39    DEBUG    : id: 0
2016-10-09 17:29:39    DEBUG    : ipv6tag: ipv6
2016-10-09 17:29:39    DEBUG    : req_method: GET
2016-10-09 17:29:39    DEBUG    : iptag: ipv4
2016-10-09 17:29:39    DEBUG    : ipv6: auto
2016-10-09 17:29:39    DEBUG    : shutdown: 0
2016-10-09 17:29:39    DEBUG    : script: /api/update
2016-10-09 17:29:39    DEBUG    : hostgroupby: 
2016-10-09 17:29:39    DEBUG    : --------------
2016-10-09 17:29:39    DEBUG    : Execute update call:
2016-10-09 17:29:39    DEBUG    : http://ipv4.dynv6.com/api/update?hostname=xxx.dynv6.net&token=xxxx&ipv4=x.x.x.x
2016-10-09 17:29:40    DEBUG    : return: 'addresses unchanged'
2016-10-09 17:29:40    DEBUG    : 0 - http:200
2016-10-09 17:29:40    DEBUG    : 0: 
2016-10-09 17:29:40    DEBUG    :     host: xxx.dynv6.net
2016-10-09 17:29:40    DEBUG    :     code: addresses unchanged
2016-10-09 17:29:40    DEBUG    : --------------
2016-10-09 17:29:40    DEBUG    : Check result:
2016-10-09 17:29:40    DEBUG    : --------------
2016-10-09 17:29:40    DEBUG    : xxx.dynv6.net: status found: addresses  unchanged, ip set: , last successful update: never, wait time: 0s, next  update attempt: 2016-10-09 17:34:40
2016-10-09 17:29:40    DEBUG    : ***Debug end***
2016-10-09 17:29:40    DEBUG    : ===============================
2016-10-09 17:29:40    DEBUG    : ===============================
2016-10-09 17:29:40    DEBUG    : ***Debug start***
2016-10-09 17:29:41    DEBUG    : x.x.x.x - ipv4
2016-10-09 17:29:41    DEBUG    : using dsm internal method to get current external ipv4 ip
2016-10-09 17:29:41    DEBUG    : x:x:x:x:x:x:x:x - ipv6
2016-10-09 17:29:41    DEBUG    : using dsm internal method to get current external ipv6 ip
2016-10-09 17:29:41    DEBUG    : --------------
2016-10-09 17:29:41    DEBUG    : [WARNING] Last successful update of  xxx.dynv6.net was never, but last try 2016-10-09 17:29:40 failed!
2016-10-09 17:29:41    DEBUG    : [WARNING] Please wait at least until  17:34:40 (299s) to update xxx.dynv6.net from 0 to x.x.x.x!
2016-10-09 17:29:41    DEBUG    : --------------
2016-10-09 17:29:41    DEBUG    : ***Debug end***
2016-10-09 17:29:41    DEBUG    : ===============================
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.338
Punkte für Reaktionen
1
Punkte
84
Lt. deinem Log wird eh nur die IPv4 versucht zu aktualisieren. Hast du denn einen zusätzlichen Eintrag für IPv6 erstellt, beide gleichzeitig Aktualisieren funktioniert nicht?
 

Frogman

Benutzer
Mitglied seit
01. Sep 2012
Beiträge
17.485
Punkte für Reaktionen
2
Punkte
414
Beide gleichzeitig geht nicht, obwohl das unterstützt würde.
Habe es jetzt mal mit einem zweiten Eintrag probiert, dann geht's - aber die 'n/a' bleiben.
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.338
Punkte für Reaktionen
1
Punkte
84
Beide IP's gleichzeitig funktioniert? Bei den meisten Anbietern wird dies nicht unterstützt, deswegen wurde es von meiner Seite nicht weiter beachtet. Vielleicht fällt mir noch eine Möglichkeit ein, das mit der vorhandenen Struktur umzusetzen.
An dem anderen Fehler/Problem bin ich noch dran.
 

Frogman

Benutzer
Mitglied seit
01. Sep 2012
Beiträge
17.485
Punkte für Reaktionen
2
Punkte
414

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.338
Punkte für Reaktionen
1
Punkte
84
Ok, Fritzbox Konfiguration hatte ich mir nicht angeschaut.
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.338
Punkte für Reaktionen
1
Punkte
84
Das Problem mit dynv6.com konnte ich nachstellen, es lag an unbekannten Rückgabecodes. Zur Zeit wird ein unbekannter Rückgabecode vom Backend als Fehler gewertet, obwohl die GUI dies evtl. korrekt auswertet.
Habe nun vorerst die beiden fehlenden Rückgabecodes "addresses updated" und "addresses unchanged" hinzugefügt, bitte im DDNS Updater 2 die Aktualisierung über den Button oben rechts durchführen. Des Weiteren wurde in der Anbieterverwaltung lt. API "nur SSL" aktiviert, der IPv6_Server auf "ipv6.dynv6.com" gesetzt und die API-Url ergänzt.

Mit dem nächsten Paketaktualisierung kommt noch ein besseres Abfangen von unbekannten Rückgabecodes hinzu.
 

gente

Benutzer
Mitglied seit
07. Mrz 2016
Beiträge
249
Punkte für Reaktionen
0
Punkte
22
...ok funktioniert wieder korrekte IP4 und IP6 wird wieder angezeigt, aber obwohl erfolgreich aktualisiert mit richtiger Uhrzeit steht im Status immer noch "keine Aktualisierung notwendig..." anstatt "Aktualisierung erfolgreich"
Danke
LG Thomas
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.