Achtung! Owncloud Update 5.0.9-2 (SynoCommuntity) Update löscht alle Daten!

h2uJ

Benutzer
Mitglied seit
01. Dez 2012
Beiträge
18
Punkte für Reaktionen
0
Punkte
0
Bei mir ist nach dem jüngsten Update aus dem Paketzentrum (SynoCommuntity) 5.0.9-2 kommentarlos alles gelöscht!

Data-Ordner leer, bis auf dortige owncloud.db (null Bytes) und folgender owncloud.log in der sich folgender Fehler wiederholt (sonst steht nichts mehr drin):
{"app":"core","message":"setting locale to en_US.UTF-8\/en_US.UTF8 failed. Support is probably not installed on your system","level":3,"time":1376177986}
{"app":"PHP","message":"SQLSTATE[HY000]: General error: 1 no such table: oc_appconfig at \/volume1\/web\/owncloud\/lib\/db.php#391","level":4,"time":1376177986}

Toll! :(


DS213+
DSM 4.2-3211

Gruß,
H.-W.
 

Frogman

Benutzer
Mitglied seit
01. Sep 2012
Beiträge
17.485
Punkte für Reaktionen
7
Punkte
414
Bei mir hat das Update problemlos geklappt.
Das einzige, was mir aufgefallen war, ist die drollige Meldung unter "Adminstrator"...

screen.jpg
 

h2uJ

Benutzer
Mitglied seit
01. Dez 2012
Beiträge
18
Punkte für Reaktionen
0
Punkte
0
Oh, die owncloud-Daten sind erreichbar, bemerkenswert ... :D
 

raymond

Benutzer
Mitglied seit
10. Sep 2009
Beiträge
4.704
Punkte für Reaktionen
21
Punkte
118
Schlagt einfach vor, dass endlich ownCloud als Paket angeboten wird. Wird ja von vielen hier scheinbar eingesetzt.
 

nachon

Benutzer
Mitglied seit
21. Aug 2011
Beiträge
2.625
Punkte für Reaktionen
0
Punkte
76
Bei mir hat das Update problemlos geklappt.
Das einzige, was mir aufgefallen war, ist die drollige Meldung unter "Adminstrator"...

Anhang anzeigen 13296

Hab gerade hier vom Update gelesen. Gleich mal durchgeführt und hat 1a funktioniert. Meldung habe ich ebenfalls unter Administration.

Cool. Wollte schon versuchen selbst zu aktualisieren. Aber nun .... :)
 

h2uJ

Benutzer
Mitglied seit
01. Dez 2012
Beiträge
18
Punkte für Reaktionen
0
Punkte
0
Schlagt einfach vor, dass endlich ownCloud als Paket angeboten wird. Wird ja von vielen hier scheinbar eingesetzt.

Paket ist es schon, halt von SynoCommuntity.
Ich hab ja nicht manuell upgedatet (sonst hätte das geklappt ;) ) , sondern über das Paket.
 

h2uJ

Benutzer
Mitglied seit
01. Dez 2012
Beiträge
18
Punkte für Reaktionen
0
Punkte
0
Kann mir auch vorstellen, warum das nicht geklappt hat.
Evtl. sollte der Paket-Ersteller mal eine zusätzliche Verifikation einbauen, ob die definierte DB überhaupt existent ist. Evtl. gibt es eine Unstimmigkeit bei der Berücksichtigung der Definition einer evtl. MySQL-DB und der Definition der üblichen Standard-DB. Nur eine Vermutung...
 

raymond

Benutzer
Mitglied seit
10. Sep 2009
Beiträge
4.704
Punkte für Reaktionen
21
Punkte
118
klar, ich meine natürlich im Paket Zentrum, direkt von Synology bereitgestellt. Da gehe ich davon aus, dass das installieren und updaten dann funktioniert.
 

Joesix

Benutzer
Mitglied seit
08. Feb 2012
Beiträge
137
Punkte für Reaktionen
0
Punkte
0
Hi, auch bei mir hat das Update von Owncloud 5.0.7 auf 5.0.9 via DSM (SynoCommunity) die gesamte Installation zerschossen. Gut das ich vorher ein Backup erstellt hatte.

Danke für die Warnung!
 

alexserikow

Benutzer
Mitglied seit
23. Feb 2011
Beiträge
877
Punkte für Reaktionen
0
Punkte
36
wie kann ich denn sehen von welcher Quelle ich es aktualiseren kann? mir wird das Update auch angezeigt, weiß aber nicht aus welcher Quelle (habe mehrere im Einsatz, u.a. auch die SynoCommunity)
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. Nov 2008
Beiträge
13.222
Punkte für Reaktionen
86
Punkte
344
wie kann ich denn sehen von welcher Quelle ich es aktualiseren kann? mir wird das Update auch angezeigt, weiß aber nicht aus welcher Quelle (habe mehrere im Einsatz, u.a. auch die SynoCommunity)
Ich weiß nicht wie es bei SynoCommunity drin steht, aber das Paket vom CPH hat unter "Entwickler" den Zusatz "maintained at eg-blog.de".

EDIT: Allerdings weiß ich nicht, ob das die installierte oder die "herunterzuladende" Version bezeichnet ...

MfG Matthieu
 
Zuletzt bearbeitet:

alexserikow

Benutzer
Mitglied seit
23. Feb 2011
Beiträge
877
Punkte für Reaktionen
0
Punkte
36
Ich weiß nicht wie es bei SynoCommunity drin steht, aber das Paket vom CPH hat unter "Entwickler" den Zusatz "maintained at eg-blog.de".

MfG Matthieu
OK, genau das steht bei mir drin... dann lasse ich das Update mal lieber.
Wird an einer Lösung gearbeitet?
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. Nov 2008
Beiträge
13.222
Punkte für Reaktionen
86
Punkte
344
Wird an einer Lösung gearbeitet?
Das musst du die Entwickler direkt fragen. Die meisten sind aus dem französischen Forum (nas-forum.com), einige sind auch im offiziellen, englischen Forum aktiv. Am schnellsten dürfte es aber über deren github-Projekt gehen.

MfG Matthieu
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. Nov 2008
Beiträge
13.222
Punkte für Reaktionen
86
Punkte
344
@h2uJ: Kann es sein, dass du das Paket über den Community Package Hub (cphub.net) installiert, aber über synocommunity aktualisiert hast?

MfG Matthieu
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. Nov 2008
Beiträge
13.222
Punkte für Reaktionen
86
Punkte
344
Das Problem ist, dass synocommunity sein Paket identisch mit dem zu CPH* genannt hat, obwohl ihr Paket erst in den letzten Tagen veröffentlicht wurde. Da die DS Pakete ausschließlich anhand eines bestimmten Namens identifiziert, hat es beide Pakete für den identischen "Zweig" gehalten. Da synocommunity aber eine höhere Versionsnummer eingetragen hat, überschreibt es folglich das CPH-Paket. Offensichtlich kommen aber unterschiedliche Datensicherungsmechanismen zum Einsatz. Ich mache da auch keinem User einen Vorwurf - sowas mitzubekommen ist fast unmöglich.

MfG Matthieu

*Mit CPH ist jeweils das über CPH verbreitete, von Eric (eg-blog.de) gewartete Paket gemeint.
 

Joesix

Benutzer
Mitglied seit
08. Feb 2012
Beiträge
137
Punkte für Reaktionen
0
Punkte
0
Im Paket-Zentrum package.png
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. Sep 2008
Beiträge
2.341
Punkte für Reaktionen
9
Punkte
84
Ich weiß nicht wie es bei SynoCommunity drin steht, aber das Paket vom CPH hat unter "Entwickler" den Zusatz "maintained at eg-blog.de".

EDIT: Allerdings weiß ich nicht, ob das die installierte oder die "herunterzuladende" Version bezeichnet ...

MfG Matthieu
Das Problem ist, dass im Paket-Zentrum unter "Aktualisieren" der alte Maintainer steht und man dann natürlich denkt, das es sich um ein Update für sein installiertes Paket handelt. Im Paket-Zentrum unter "Installiert" oder "Community" erkennt man aber den richtigen Maintainer. Im Paket-Zentrum kann pro Paketname (package) nur 1 Paket existieren, bei mehreren gleichen Paketnamen von verschiedenen Servern immer nur das mit der höchsten Versionsnummer.
Das Problem mit der Datenbank resultiert aus der unterschiedlichen Ordnerstruktur zwischen den Paketen. Beim Update wird die DB deswegen nicht gesichert (das neue Paket kennt den Ort der alten DB nicht) und ist anschließend nicht mehr vorhanden.

Ein Update sollte bis zur Klärung bzw. Korrektur nicht durchgeführt werden!!!
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. Nov 2008
Beiträge
13.222
Punkte für Reaktionen
86
Punkte
344
Gibt es hier unter den "Lesenden" einen User mit Github-Account, der bei "spksrc" einen Bug-Report aufmachen kann? Vielleicht geht es so am schnellsten. Die Macher müssten den Namen des Paketes ändern, dann wäre alles wieder in Ordnung ...

MfG Matthieu
 
NAS-Central - Ihr Partner für NAS Lösungen
NAS-Central - The Home of NAS

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat 

Hosted by netcup