Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 29
  1. #1
    Anwender
    Registriert seit
    18.05.2018
    Beiträge
    16

    Standard SABnzbd kann nicht installiert werden - python Paket fehlt

    Guten Tag, ich versuche schon seit einigen Tagen auf meinem neuen NAS (DS-118) SABnzbd zu installieren. Ich fügte also die Source von SynoCommunity hinzu und drückte auf "Installieren". Jedoch gab es die unten angebene Fehlermeldung aus. Daraufhin habe ich Python 3 und das Pythonmodul heruntergeladen (brachte nichts). Auch versuchte ich von MertyMade das .spk herunterzuladen und zu installieren.

    All dies ohne Erfolg.

    Hat irgendjemand eine Ahnung was der Fehler ist?

    Der Synology Support hat mich abgewiesen weil sie mit SynoCommunity "nichts zu tun" haben.


    Fehlermeldung:

    Die folgenden Pakete fehlen auf dem Paket-Server. Bitte wenden Sie sich an den Synology-Kundendienst, um Hilfe zu erhalten. python

    Bildschirmfoto 2018-05-18 um 20.30.22.jpg

  2. #2

    Standard

    So geht es mir auch. Selbe Problem bei mir. Ich vermute mal das man das SABnzbd nicht mehr auf den Geräten haben will weil die Downloadstation hierzu in direkter Konkurenz steht.
    Die kann ja auch solche z.B. *.nzb Downloads durchführen. Leider muss man hier immer per Hand das Passwort nachtragen. Entweder direkt im Download oder in einer Passwort Datei.
    Das konnte SABnzbd selbst erkennen wenn es im Link mit drin stand. Ist aber nur eine Vermutung.
    FRITZ!Box 7490 + AzboxPremium(openATV-Image)
    DS 918+II(12GB)[DSM 6.2-23648]phpMyAdmin|SABnzbd|Teamspeak 3|MyBB-1.8.15|Mailstation|VideoStation|PhotoStation|Bukkit Server1.12.2|VirtualMaschineManager|SPK Repository

  3. #3
    Anwender
    Registriert seit
    18.05.2018
    Beiträge
    16

    Standard

    Ich habe noch ein zweites Forum in Englisch eröffnet, in der Hoffnung dass jemand weiss wie man dies beheben kann.

    Englischer Blog:
    https://forums.sabnzbd.org/viewtopic...115913#p115913

    Wahrscheinlich gibt es schon eine Möglichkeit, bei anderen NAS von Synology funktioniert SABnzbd ja trotzdem noch.
    Und ja klar, SABnzbd ist um einiges besser als die Downloadstation, man kann so auch Serien sortieren und ein gutes Web Interface haben, bis anhin benutze ich NZBget, dies kann fast soviel wie SABnzbd.

    Hoffen wir das beste...

  4. #4

    Standard

    Hab es jetzt selbst installiert und am laufen.

    01. Installation Easy BootStrapInstaller
    02. Installation iPKGui
    ...
    Hier sei angemerkt das der Fehler mit

    ipkg_download: ERROR: Command failed with return value 127: `wget
    .. weg ist wenn man zuerst wget-ssl installiert (hierbei wird wget deinstalliert) und anschließend wieder wget. Zumindet hat mir das geholfen.
    Dann konnte ich auch normal ipkg in der SSH Konsole benutzen, was für die Punkte 06-9 nötig war.
    ...
    03. Installation von erforderlichen SABnzbd Paketen nach http://cytec.us/forum/index.php?page...d&threadID=155
    ...
    Folgende hab ich u.a. benutzt:
    - 'ipkg install git'.................. -- installiert GIT inkl. aller Abhängigkeiten
    - 'ipkg install coreutils'........ -- installiert CoreUtilities
    - 'ipkg install textutils'.......... -- installiert TextUtilities
    - 'ipkg install gcc'................ -- installiert GNU C-Compiler inkl. aller Abhängigkeiten
    - 'ipkg install py27'.............. -- setuptools' installiert Python 2.7 Tools
    - 'ipkg install python27' ...... -- Interpreter
    - 'ipkg install par2cmdline' .. -- installiert PAR2 zur Reparatur defekter .par-Dateien

    ... nun Konsole öffnen, wechseln in das Verzeichnis "cd /volume1/@appstore"

    04. - 'git clone https://github.com/sabnzbd/sabnzbd.git' -- download von abnzbd
    05. Inhalt mit neuer Version von https://github.com/sabnzbd/sabnzbd/r...3.3-src.tar.gz ausgetauscht.

    Folgende Pakete nachinstalliert ..

    06. /opt/bin/python2.7 -m pip install --upgrade pip
    07. /opt/bin/python2.7 -m pip install sabyenc
    08. /opt/bin/python2.7 -m pip install cheetah
    09. /opt/bin/python2.7 -m pip install yEnc
    10. /opt/bin/python2.7 /volume1/@appstore/sabnzbd/tools/make_mo.py -- Einmalig gestartet wegen Spracheinstellung.
    11. /opt/bin/python2.7 /volume1/@appstore/sabnzbd/SABnzbd.py -s 192.168.1.12:9090 & -- Erster Start von Sabnzbd.. eingeloggt festgestellt das diverse Pakete noch fehlen. Diese mussten noch nachinstalliert werden. Sind aber die meisten in 06-09 enthalten. Dann zweiter Start .. eingestellt für Remotezugriff mit Passwort, Konfig angepasst. Fertig.
    12. Mein Aufruf.. http://source.synology.me:9090/sabnzbd/

    Vielleich hilft es ja dem ein oder anderen ;-)

    Gruß - inkaman
    Geändert von inkaman (20.05.2018 um 23:17 Uhr) Grund: Nachtrag
    FRITZ!Box 7490 + AzboxPremium(openATV-Image)
    DS 918+II(12GB)[DSM 6.2-23648]phpMyAdmin|SABnzbd|Teamspeak 3|MyBB-1.8.15|Mailstation|VideoStation|PhotoStation|Bukkit Server1.12.2|VirtualMaschineManager|SPK Repository

  5. #5
    Anwender
    Registriert seit
    18.05.2018
    Beiträge
    16

    Standard

    Danke für die ausführliche Antwort. Ich konnte alles installieren, jedoch habe ich jetzt das problem, dass ich SABnzbd nicht auf http://(ip-adresse-von-NAS):9090 oder :8080 oder :9200 erreichen kann.

  6. #6

    Standard

    Guck mal ob es überhaupt gestarte ist:

    Gib mal in der Konsole folgendes ein:

    ps -efa | grep sabnzbd
    Da muss sowas wie

    /opt/bin/python2.7 /volume1/@appstore/sabnzbd/SABnzbd.py -s 192.168.1.12:9090
    stehen. Ist dem so?
    FRITZ!Box 7490 + AzboxPremium(openATV-Image)
    DS 918+II(12GB)[DSM 6.2-23648]phpMyAdmin|SABnzbd|Teamspeak 3|MyBB-1.8.15|Mailstation|VideoStation|PhotoStation|Bukkit Server1.12.2|VirtualMaschineManager|SPK Repository

  7. #7
    Anwender
    Registriert seit
    18.05.2018
    Beiträge
    16

    Standard

    Ich krieg da dies raus:
    SilvanM@SilvansNAS:~$ ps -efa | grep sabnzbd
    root 12072 1 0 00:41 ? 00:00:02 python sabnzbd/SABnzbd.py --daemon
    SilvanM 14464 14456 0 01:02 pts/2 00:00:00 grep --color=auto sabnzbd
    SilvanM@SilvansNAS:~$

  8. #8

    Standard

    Kill mal den Prozess mit

    kill 12072
    dann ruf sabnzbd mal so auf wenn due python2.7 installiert hast:

    /opt/bin/python2.7 /volume1/@appstore/sabnzbd/SABnzbd.py -s IP_der Synology:9090 &
    Bei python2.5 natürlich so:

    /opt/bin/python2.5 /volume1/@appstore/sabnzbd/SABnzbd.py -s IP_der Synology:9090 &
    FRITZ!Box 7490 + AzboxPremium(openATV-Image)
    DS 918+II(12GB)[DSM 6.2-23648]phpMyAdmin|SABnzbd|Teamspeak 3|MyBB-1.8.15|Mailstation|VideoStation|PhotoStation|Bukkit Server1.12.2|VirtualMaschineManager|SPK Repository

  9. #9
    Anwender
    Registriert seit
    18.05.2018
    Beiträge
    16

    Standard

    Danke. Es hat funktioniert! Ich habe jetzt sicher schon 5 Stunden herumgetüftelt...

  10. #10

    Standard

    Erfreulich. Dann viel Spaß beim benutzen ;-)

    Das "&" am Ende ist übrigens erforderlich weil der Aufruf dann in sich gekapselt läuft und man die Konsole dann einfach schließen kann.
    Erst nach einem Neustart oder Update ist ein erneuter Start des Scripts wieder erforderlich. Sicherlich kann man das auch noch so einstellen
    das es beim Starten der Maschiene mitgestartet wird.

    Gruß - inkaman
    FRITZ!Box 7490 + AzboxPremium(openATV-Image)
    DS 918+II(12GB)[DSM 6.2-23648]phpMyAdmin|SABnzbd|Teamspeak 3|MyBB-1.8.15|Mailstation|VideoStation|PhotoStation|Bukkit Server1.12.2|VirtualMaschineManager|SPK Repository

Seite 1 von 3 123 LetzteLetzte

Ähnliche Themen

  1. Joomla: das Paket konnte nicht installiert werden
    Von master123 im Forum Webserver
    Antworten: 3
    Letzter Beitrag: 29.10.2017, 01:21
  2. Antworten: 0
    Letzter Beitrag: 12.02.2015, 10:03
  3. Surveillance Station: Das Paket konnte nicht installiert werden
    Von Ralines im Forum Surveillance Station
    Antworten: 19
    Letzter Beitrag: 22.10.2013, 14:28
  4. Sabnzbd kann nicht installiert werden
    Von Südtiroler im Forum Sonstiges
    Antworten: 3
    Letzter Beitrag: 03.02.2011, 13:56
  5. sabnzbd 0.5.0 - spk kann nicht installiert werden
    Von saeschu im Forum Andere 3rd Party Anwendungen
    Antworten: 4
    Letzter Beitrag: 24.06.2010, 12:15

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •