Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 29 von 29
  1. #21

    Standard

    Hallo Stef, und willkommen hier im Forum.

    Ich würde dir eine saubere IPKG-Installtion, wie oben beschrieben, empfehlen. So sollte das mit Rechten und dem PATH auch passen.

    Du kannst auch die Medienindizierung manuell anstoßen:
    Code:
    synoindex -A "/volume1/pfad/zu/Mediendateien"
    Weitere Infos hier: http://www.synology-wiki.de/index.ph...Server_(Index)
    Gruß Stephan
    ________________________________________
    DS716+ DSM 6.2 - 2 x 4TB WD red (Btrfs RAID-1)
    DX213 1 x Samsung EVO 860 500 GB SSD (Btrfs Basis)
    APC - Back-UPS ES 550G
    AVM Fritz!BOX 7590
    macOS 10.14

  2. #22
    Anwender
    Registriert seit
    27.02.2017
    Beiträge
    6

    Standard

    Hallo Stephan,

    danke für deine Antwort

    Das manuelle Anstoßen der Medienindizierung ist soweit ich rausgefunden habe nicht das Problem. Die Medienindizierung erfasst wohl keine Dateien deren Besitzer root ist. Obwohl ich als normaler User darauf zugreifen kann. Sobald ich im Dateimanager den Besitzer ändere, werden die Dateien brav erfasst.

    Werde noch versuchen mich ein bisschen einzulesen, bevor ich alles nochmal neu installiere.
    Vermute den Fehler im Startup-Skript unter usr/local/etc/rc.d

    Ansonsten funktioniert es ja erstmal so wie es ist.

    Gruß Stef

  3. #23
    Anwender
    Registriert seit
    27.02.2017
    Beiträge
    6

    Standard

    Hallo Stephan,

    also ich hab das jetzt doch hinbekommen. Lag aber mit meiner Einschätzung trotzdem daneben. Dein Hinweis mit PATH war genau richtig.
    Ich hab in der /etc/profile beim PATH-Eintrag noch die /opt/bin und /opt/sbin hinzugefügt. Jetzt funktioniert auch alles wie es soll.

    Die per Streamripper aufgezeichneten Dateien werden jetzt auch brav von der Medienindizierung erkannt.
    Komischerweise aber nicht automatisch. Wenn ich eine Datei von Hand erneut reinkopiere klappts wunderbar, nur nicht nach Abschluss der Aufzeichnung.

    Macht aber auch nichts. Verwende im Anschluss an streamripper einfach noch den synoindex-Befehl.
    Somit klappt jetzt alles wunderbar.

    Gruß Stef
    Synology DS214SE - DSM 6.1.5-15254 Update 1
    macOS 10.13.3
    Windows 10

  4. #24
    Anwender
    Registriert seit
    27.02.2017
    Beiträge
    6

    Standard

    Hallo liebe Foristen,

    streamripper hat jetzt gut ein Jahr lang tadellos seinen Dienst verrichtet. Vorletzte Woche hat es allerdings plötzlich seinen Dienst eingestellt. Fehlermeldung im log:
    Segmentation fault.

    Aus der Fehlermeldung werde ich allerdings überhaupt nicht schlau.
    Als Problemlösung hab ich mich bisher an einer Neuinstallation des Easy Bootstrap Installer und Streamripper versucht. Hat aber nichts gebracht.

    Anbei noch mal zwei Fehlermeldungen aus dem log:
    sh: line 1: 4498 Segmentation fault /opt/bin/streamripper http://www.xyz-radio.de/stream -d /volume2/music/podcast/ -a "`date +%Y-%m-%d`_radiosender" -l 30 -L "`date +%Y-%m-%d`_radiosender"

    Connecting...
    sh: line 1: 14558 Segmentation fault /opt/bin/streamripper http://www.xyz-radio.de/stream -d /volume2/music/podcast/ -a "`date +%Y-%m-%d`_radiosender" -l 30 -L "`date +%Y-%m-%d`_radiosender"

    Wenn ich streamripper händisch via ssh aufrufe kommt folgendes:
    /opt/bin/streamripper http://www.xyz-radio.de/stream -d /volume2/music/podcast/ -a -l 10
    Connecting...

    Time to stop is here, bailing
    shutting down
    Segmentation fault

    Die Fehlermeldung erhalte ich auch, wenn ich streamripper als User root ausführe.
    Mit meinen bescheidenen Kenntnissen komme ich jetzt jedenfalls nicht mehr weiter.

    Gruß Stef
    Synology DS214SE - DSM 6.1.5-15254 Update 1
    macOS 10.13.3
    Windows 10

  5. #25
    Anwender
    Registriert seit
    27.02.2017
    Beiträge
    6

    Standard

    Nach ein wenig Recherche hab ich nun rausgefunden, dass das Problem doch nicht am streamripper lag, oder am Easy Bootstrap Installer.

    Mein Internetradioempfänger an der Stereoanlage konnte nämlich auch nicht auf den Stream zugreifen. Bei der Kontrolle über vlc und Safari ist mir dann aufgefallen, dass der Stream auf einen anderen weiterleitet. Wenn ich nun diesen Stream eingebe, dann funktioniert streamripper wieder wie gewohnt. Der Radiosender hat da wohl was umgestellt..

    Gruß Stef
    Synology DS214SE - DSM 6.1.5-15254 Update 1
    macOS 10.13.3
    Windows 10

  6. #26
    Anwender
    Registriert seit
    05.01.2017
    Beiträge
    1

    Standard

    ich bekomme leider folgende fehlermeldung
    #>/opt/bin/ipkg install faad2 gettext glib libffi libintl libmad libogg libunistring libvorbis ncurses ncurses-base streamripper zlib
    Installing faad2 (2.6-4) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-..._2.6-4_arm.ipk.
    Installing gettext (0.19.8.1-5) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-....8.1-5_arm.ipk.
    Installing glib (2.47.3-2) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-...47.3-2_arm.ipk.
    Installing libffi (3.2.1-1) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-....2.1-1_arm.ipk.
    Installing libintl (0.19.8.1-5) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-....8.1-5_arm.ipk.
    Installing libmad (0.15.1b-4) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-...5.1b-4_arm.ipk.
    Installing libogg (1.3.3-1) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-....3.3-1_arm.ipk.
    Installing libunistring (0.9.4-2) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-....9.4-2_arm.ipk.
    Installing libvorbis (1.3.5-2) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-....3.5-2_arm.ipk.
    Installing ncurses (5.7-7) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-..._5.7-7_arm.ipk.
    Installing ncurses-base (5.7-7) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-..._5.7-7_arm.ipk.
    Installing streamripper (1.64.6-2) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-...64.6-2_arm.ipk.
    Installing zlib (1.2.8-2) on /opt/.
    Downloading http://ipkg.nslu2-linux.org/optware-....2.8-2_arm.ipk.
    Collected errors:
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-..._2.6-4_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download faad2. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package faad2.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-....8.1-5_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download gettext. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package gettext.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-...47.3-2_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download glib. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package glib.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-....2.1-1_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download libffi. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package libffi.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-....8.1-5_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download libintl. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package libintl.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-...5.1b-4_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download libmad. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package libmad.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-....3.3-1_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download libogg. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package libogg.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-....9.4-2_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download libunistring. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package libunistring.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-....3.5-2_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download libvorbis. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package libvorbis.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-..._5.7-7_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download ncurses. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package ncurses.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-..._5.7-7_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download ncurses-base. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package ncurses-base.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-...64.6-2_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download streamripper. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package streamripper.
    * opkg_download: Failed to download http://ipkg.nslu2-linux.org/optware-....2.8-2_arm.ipk, wget returned 127.
    * opkg_install_pkg: Failed to download zlib. Perhaps you need to run 'ipkg update'?
    * opkg_install_cmd: Cannot install package zlib.

    kann mir jemand weiterhelfen?

  7. #27

    Standard

    Hallo liebes Forum,

    ich bin ebenfalls dabei den Streamripper zu benutzen, scheitere aber bei der Festlegung meines Wahlspeicherortes für die aufgezeichnete Datei.

    Streamripper an sich funktioniert, das habe ich mit folgendem Befehl über SSH getestet:

    Der Stream wird dann unter "/volume1/homes/turmblitzstange/Streamripper_rips" abgelegt, den Task hab ich dann Testweise über Strg+C gekillt, die Datei kann ich auch mit VLC abspielen.

    Nun möchte ich die Datei aber ungern in meinem persönlichen HOME-Verzeichnis (turmblitzstange) liegen haben, sondern Streamripper sollte direkt auf meine Netzwerkfreigabe, wie z.B. "/volume1/Gemeinsame Dateien/99-jDownloads" (der Ordner existiert bereits) schreiben. Testweise würde ich dies über SSH so lösen wollen, wie in den Beitragen zuvor auch schon beschrieben wurde:
    /opt/bin/streamripper http://13983.live.streamtheworld.com/KMGNFMAAC.aac -d /volume1/Gemeinsame Dateien/99-jDownloads
    Leider erhalte ich dann diese Fehlermeldung:
    "error -36 [SR_ERROR_CANT_CREATE_FILE]"

    Als Hintergrundangaben kann ich noch sagen, dass mein Benutzer Adminrechte hat, deswegen bin ich verwundert das Streamripper nicht schreiben kann. Weiß jemand eine Lösung?

  8. #28
    Moderator
    Registriert seit
    18.03.2009
    Beiträge
    13.259

    Standard

    Hallo,
    beim Leerzeichen hinter Gemeinsame ist Schluss mit der Pfadangabe auf der Konsole.
    Probiere
    Code:
    /opt/bin/streamripper http://13983.live.streamtheworld.com/KMGNFMAAC.aac -d "/volume1/Gemeinsame Dateien/99-jDownloads"
    oder
    Code:
    /opt/bin/streamripper http://13983.live.streamtheworld.com/KMGNFMAAC.aac -d /volume1/Gemeinsame\ Dateien/99-jDownloads
    Gruß Götz
    DS1513+ / DSM 6.2 / 3x 2TB Samsung HD204UI
    DS916+ / DSM 6.1.7 / 3x 4TB HGST MegaScale DC 4000.B
    DS213+ / DSM 6.2 / 2x 2TB Seagate Constellation ES
    eTrayZ / Samsung HD103SI
    APC SMT750I+AP9631

  9. #29

    Standard

    Danke für die Antwort, das wars! Funktioniert nun einwandfrei.

Seite 3 von 3 ErsteErste 123

Ähnliche Themen

  1. Antivirus Essentials auf DS216J unbrauchbar
    Von hjo_123 im Forum Antivirus
    Antworten: 5
    Letzter Beitrag: 27.01.2017, 13:25
  2. Mumble Server auf DS216j
    Von nuker im Forum Sonstiges
    Antworten: 0
    Letzter Beitrag: 02.10.2016, 18:29
  3. Von DS216J auf 5 Bay aufrüsten
    Von wombat_ger im Forum Sonstiges
    Antworten: 2
    Letzter Beitrag: 02.09.2016, 22:09
  4. Teil-Migration DS415play auf DS216j
    Von shadowrunner im Forum Installation und Konfiguration allgemein
    Antworten: 4
    Letzter Beitrag: 19.05.2016, 11:09
  5. TVHeadend auf DS216j?
    Von Klassikfan im Forum Andere 3rd Party Anwendungen
    Antworten: 0
    Letzter Beitrag: 28.03.2016, 16:07

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •