Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15
  1. #1
    Anwender
    Registriert seit
    02.01.2009
    Beiträge
    451

    Frage OpneVPN geht nicht mehr (Config prüfen - leer)

    Hi,

    heute geht der OpneVPN auf der DS214 (DMS6 update2) seit heute nicht mehr, gestern ging noch alles.
    Habe dann heute gesehen das es schon Update7 gibt und diese eingespielt, aber auch danach geht kein OpenVPN mehr. Habe restartet, deaktivieert, neu installiert den VPN, alles hilft nicht.

    Hat einer das selbe Probelm? Woran kann es liegen? Brauche den VPN täglich...

    Ach so, wenn ich das Konfigfile exportiere, ist es leer???

    Fehlermeldung
    2017-01-04 21_29_20-DS214 - Synology DiskStation.jpg

    VPN-Packet Info
    2017-01-04 21_27_00-DS214 - Synology DiskStation.jpg
    Geändert von linuxdep (04.01.2017 um 21:32 Uhr)
    MfG
    linuxdep(endent)

    DS414 mit 3x 4TB ST4000DM000-1F2168 im Raid5, DSM5.2 (letzter Stand)
    new - DS918+ mit 3x 4TB im Raid5, aktuelle DMS Software soll die DS414 ablösen wegen Dockernutzung


    (zu Verkaufen) DS410 (RAM Upgrade auf 1GB) und DS-207+

  2. #2
    Anwender Avatar von Frogman
    Registriert seit
    01.09.2012
    Beiträge
    17.477

    Standard

    Warum lädst Du Screenshots nicht hier im Forum hoch? Sehr unschön, wenn irgendwann externe Verlinkungen weg sind..
    DS713+ | 2x 1TB Crucial M500 SSD # 4GB RAM # be quiet! Shadow Wings | DSM 6.1.7-15284-U3
    DS212+ | Backup-DS: 2x 4TB HGST Deskstar NAS | DSM 6.1.7-15284-U3
    Extras: fail2ban 0.11.0 - Java 1.8.0.212 - Nextcloud 16.0.3 - Roundcube 1.3.8 - HumHub 1.3.14 - tt-rss 19.02
    Synology-Support-Portal | DSM-Hilfe online | Synology-Tutorials
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung. (Albert Einstein)

  3. #3
    Anwender
    Registriert seit
    02.01.2009
    Beiträge
    451

    Standard

    Ich dachte das ist besser so, sorry.

    2017-01-04T08:34:30+01:00 DS214 ipsec_setup: Stopping Openswan IPsec...
    2017-01-04T08:34:30+01:00 DS214 ipsec_setup: stop ordered, but IPsec appears to be already stopped!
    2017-01-04T08:34:30+01:00 DS214 ipsec_setup: doing cleanup anyway...
    2017-01-04T08:34:30+01:00 DS214 ipsec_setup: ...Openswan IPsec stopped
    2017-01-04T08:34:31+01:00 DS214 synonetd: base_hook.cpp:74 Hook environment is not valid
    2017-01-04T08:34:31+01:00 DS214 synonetd: base_hook.cpp:74 Hook environment is not valid
    2017-01-04T08:34:31+01:00 DS214 synonetd: SYSTEM: Last message 'base_hook.cpp:74 Hoo' repeated 1 times, suppressed by syslog-ng on DS214
    2017-01-04T08:34:31+01:00 DS214 synonetd: net_if_is_bonding_slave.c:46 Cannot get flags of network interface: No such device
    2017-01-04T08:34:33+01:00 DS214 builtin-dyn-autopkgupgrade-default: resource_api.cpp:231 Release webapi-desc for VPNCenter when 0x0002 (done)
    2017-01-04T08:34:35+01:00 DS214 synocrtunregister: synocrtregister.cpp:359 Un-Register certificate for VPNServer(pkg)
    2017-01-04T08:34:35+01:00 DS214 builtin-dyn-autopkgupgrade-default: resource_api.cpp:231 Release service-cfg for VPNCenter when 0x0002 (done)
    2017-01-04T08:34:35+01:00 DS214 builtin-dyn-autopkgupgrade-default: resource_api.cpp:163 Acquire service-cfg for VPNCenter when 0x0002 (done)
    2017-01-04T08:34:36+01:00 DS214 synocrtregister: synocrtregister.cpp:162 Register certificate for VPNServer/OpenVPN(pkg)
    2017-01-04T08:34:45+01:00 DS214 synopkgctl: resource_api.cpp:163 Acquire webapi-desc for VPNCenter when 0x0002 (done)
    2017-01-04T08:34:48+01:00 DS214 openvpn[3398]: Options error: Please correct these errors.
    2017-01-04T08:34:48+01:00 DS214 openvpn[3398]: Use --help for more information.
    Das habe ich im log gefunden, was soll mir das sagen??? Seltsam, so aus heiterem Himmel
    MfG
    linuxdep(endent)

    DS414 mit 3x 4TB ST4000DM000-1F2168 im Raid5, DSM5.2 (letzter Stand)
    new - DS918+ mit 3x 4TB im Raid5, aktuelle DMS Software soll die DS414 ablösen wegen Dockernutzung


    (zu Verkaufen) DS410 (RAM Upgrade auf 1GB) und DS-207+

  4. #4
    Anwender
    Registriert seit
    02.01.2009
    Beiträge
    451

    Standard

    scheiß Qualitätskontrolle bei Synology...

    habe es gefunden, hatte da noch was im hinterkopf mit dem Einrichten gab es ja auch ein Problem, habe dann das Zertifikat gelöscht und neu eingespielt und damit hat es wohl auch einen Weg zum VPN Packet gefunden.
    Ich hoffe es hilft einem Suchenden später mal weiter.

    Erst mal Autoupdate von den Packeten ausgestellt, das sind oben die Meldungen davon.

    Ticket habe ich trotzdem mal bei Syno aufgemacht, damit das mal gefixt wird.
    MfG
    linuxdep(endent)

    DS414 mit 3x 4TB ST4000DM000-1F2168 im Raid5, DSM5.2 (letzter Stand)
    new - DS918+ mit 3x 4TB im Raid5, aktuelle DMS Software soll die DS414 ablösen wegen Dockernutzung


    (zu Verkaufen) DS410 (RAM Upgrade auf 1GB) und DS-207+

  5. #5
    Anwender
    Registriert seit
    02.01.2009
    Beiträge
    451

    Standard

    So ein Sch... schon wieder ein Update das voll in die Hose gegangen ist. Jetzt geht nix mehr mit VPN und eigenem Zertifikat...
    Hat das noch einer das Problem?
    MfG
    linuxdep(endent)

    DS414 mit 3x 4TB ST4000DM000-1F2168 im Raid5, DSM5.2 (letzter Stand)
    new - DS918+ mit 3x 4TB im Raid5, aktuelle DMS Software soll die DS414 ablösen wegen Dockernutzung


    (zu Verkaufen) DS410 (RAM Upgrade auf 1GB) und DS-207+

  6. #6
    Anwender
    Registriert seit
    11.06.2017
    Beiträge
    616

    Standard

    Jep zwei andere Threads sind auch gerade ganz oben mit ähnlichen Problemen.

    Welches Certifikat hast du verwendet? Anscheinend gibt es da im Moment einige Probleme.

    Du könntest versuchen mal peer ssh auf die DS, in der openvpn config das Debug Log (falls noch nicht konfiguriert) aufdrehen, neustarten und in der neuen Log schauen was das Problem mit den Certs ist.

  7. #7
    Anwender
    Registriert seit
    02.01.2009
    Beiträge
    451

    Standard

    so, hatte erst mal eine DS410 mit altem Sortwarestand genutz, da ging es erst mal noch, bis zum 11.8. da ging auch hier nix mehr, der VPN dienst läßt sich nicht mehr deinst. da kommt ein fehler. Notgedrungen musste ich jetzt mal schauen woran es liegt, scheinbar an meinem Zertifikat, habe mal eines mit der Synology erstellt, das geht für VPN jetzt wieder, seltsam. Aber wenn das mit dem VPN so unzuverlässig arbeitet, bin ich fast geneigt einen RasPi als VPN zu nutzen, AVM stellt ja immer noch keine Software für Win10 (ausser die beta) bereit, ob die je final wird???
    MfG
    linuxdep(endent)

    DS414 mit 3x 4TB ST4000DM000-1F2168 im Raid5, DSM5.2 (letzter Stand)
    new - DS918+ mit 3x 4TB im Raid5, aktuelle DMS Software soll die DS414 ablösen wegen Dockernutzung


    (zu Verkaufen) DS410 (RAM Upgrade auf 1GB) und DS-207+

  8. #8
    Anwender
    Registriert seit
    02.01.2009
    Beiträge
    451

    Standard

    Ich Antworte mir mal wieder selber....

    Seit ein paar Tagen geht VPN wieder nicht mehr. Heute mal geschaut, log aktiviert (sollte ich wohl mal an lassen), da sehe ich das hier.

    Code:
    root@Suedpol:/usr/syno/etc/packages/VPNCenter/openvpn# cat /var/log/openvpn.log
    Options error: --tls-auth fails with '/var/packages/VPNCenter/target/etc/openvpn/keys/ta.key': No such file or directory
    Options error: Please correct these errors.
    Ist nicht da, hatte mich damals auch schon gefragt, warum das VPN Packet zwei Quellen hat...

    Code:
    root@Suedpol:/usr/syno/etc/packages/VPNCenter/openvpn# ll keys/
    total 28
    drwxr-xr-x 2 root root 4096 Apr  6 21:45 .
    drwxr-xr-x 3 root root 4096 Apr 11 11:02 ..
    -r-------- 1 root root 1464 Apr  6 21:45 ca.crt
    -rw------- 1 root root  636 Mar  4 22:35 hmac.key
    -r-------- 1 root root 1480 Apr  6 21:45 server.crt
    -r-------- 1 root root 1675 Apr  6 21:45 server.key
    -rw------- 1 root root  636 Mar  5 20:39 ta.key
    root@Suedpol:/usr/syno/etc/packages/VPNCenter/openvpn# ll /var/packages/VPNCenter/target/etc/openvpn/keys/
    total 24
    drwxr-xr-x 1 root root  116 Apr 11 11:02 .
    drwxr-xr-x 1 root root   86 Jan 15 03:43 ..
    -r-------- 1 root root 1464 Apr 11 11:02 ca.crt
    -rw-r--r-- 1 root root  595 Jan 15 03:43 dh3072.pem
    -rwxr-xr-x 1 root root 1121 Jan 15 03:43 openvpn.ovpn
    -rwxr-xr-x 1 root root 1862 Jan 15 03:43 README.txt
    -r-------- 1 root root 1480 Apr 11 11:02 server.crt
    -r-------- 1 root root 1675 Apr 11 11:02 server.key
    In welchem Path fasst der VPNCenter die Dateien nicht an??? Will ich ja nicht alle Nase lang Hand anlegen wollen?
    MfG
    linuxdep(endent)

    DS414 mit 3x 4TB ST4000DM000-1F2168 im Raid5, DSM5.2 (letzter Stand)
    new - DS918+ mit 3x 4TB im Raid5, aktuelle DMS Software soll die DS414 ablösen wegen Dockernutzung


    (zu Verkaufen) DS410 (RAM Upgrade auf 1GB) und DS-207+

  9. #9
    Anwender Avatar von MMD*
    Registriert seit
    26.10.2014
    Beiträge
    396

    Standard

    Hier findest du die Pfaden die benutzt werden:
    Code:
    cat /usr/syno/etc/packages/VPNCenter/openvpn/openvpn.conf
    DS414 DSM 5.2-5967 Update 2

  10. #10
    Anwender
    Registriert seit
    02.01.2009
    Beiträge
    451

    Standard

    So, neues Update und der ta.key ist wieder weg... scheinbar löscht der beim updaten das /var/packages/VPNCenter/target/etc/openvpn/keys/ Verzeichnis.
    Habe ich jetzt die opnepvpn.conf geändert auf /usr/syno/etc/packages/VPNCenter/openvpn/keys
    Mal das nächste Update abwarten... blöd wenn man etwas mehr einstellen will was Synology nicht vorgesehen hat.
    MfG
    linuxdep(endent)

    DS414 mit 3x 4TB ST4000DM000-1F2168 im Raid5, DSM5.2 (letzter Stand)
    new - DS918+ mit 3x 4TB im Raid5, aktuelle DMS Software soll die DS414 ablösen wegen Dockernutzung


    (zu Verkaufen) DS410 (RAM Upgrade auf 1GB) und DS-207+

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Antworten: 17
    Letzter Beitrag: 17.12.2016, 20:36
  2. su geht nicht mehr
    Von wildvirus im Forum Terminal-Dienste (Telnet, SSH) - Linux-Konsole
    Antworten: 2
    Letzter Beitrag: 11.04.2016, 19:54
  3. Teilweise kein Zugriff mehr nach OS-Reset und Rückspielen der Config
    Von nipponichi im Forum Benutzer, Gruppen, gemeinsame Ordner
    Antworten: 1
    Letzter Beitrag: 16.11.2014, 21:12
  4. Macbook sieht DS nicht - MacPro schon - Time Machine geht nicht mehr
    Von Balgenbruder im Forum Disk Station Manager
    Antworten: 17
    Letzter Beitrag: 12.02.2013, 18:01
  5. DS107 + Twonky Config geht nicht
    Von baeckerman83 im Forum Streaming Multimedia Server / iTunes Server
    Antworten: 2
    Letzter Beitrag: 22.01.2008, 21:13

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •