Seite 262 von 267 ErsteErste ... 162212252260261262263264 ... LetzteLetzte
Ergebnis 2.611 bis 2.620 von 2662
  1. #2611
    Anwender
    Registriert seit
    02.07.2013
    Beiträge
    2.964

    Standard

    Habe auch den Two Faktor Auth aber nie Fehler, daher keine eMail Benachrichtigung

    Werde aber mal schauen woran es liegt.
    ! Bitte Postfachgröße erhöhen !


    DS916+ | 8GB RAM | 3x3TB WD Red RAID 5 btrfs | DSM 6.1-15047-U2
    DS216+II | 8GB RAM | 2x4TB WD Red basic ext4 | DSM 6.0.2-8451-U9
    DS212j | | DSM 6.0.2-8451-U9 | Backup DS

    Fritzbox 7490 | Netgear GS108Tv2


    Projekte:

    Ultimate Backup - SPK
    Ultimate Search - SPK




  2. #2612
    Anwender
    Registriert seit
    16.06.2018
    Beiträge
    2

    Standard

    Danke für deinen Support, nur eine kleine Anmerkung

    Die Backups laufen bei mir auch durch ohne Fehler. Ich lasse grundsätzlich eine eMail nach dem Backup versenden, damit ich es mitbekomme, falls das Backup mal nicht ausgeführt wurde.

    Also solltest du das Verhalten - wenn es ein grundsätzliches Problem ist - nachvollziehen, indem du den EMail Versand grundsätzlich aktivierst

    Bin mal gespannt ... :-)

  3. #2613
    Anwender
    Registriert seit
    17.06.2011
    Beiträge
    96

    Standard

    Zitat Zitat von PsychoHH Beitrag anzeigen
    Setz mal die 3 rsnyc Befehle als /opt/bin/rsync
    Direkt im Script? Da finde ich aber wesentlich mehr als 3 rsync Befehle.

  4. #2614
    Anwender
    Registriert seit
    02.07.2013
    Beiträge
    2.964

    Standard

    Direkte rsync Befehle sind nur 3, folgende Zeilen.
    972
    978
    984
    ! Bitte Postfachgröße erhöhen !


    DS916+ | 8GB RAM | 3x3TB WD Red RAID 5 btrfs | DSM 6.1-15047-U2
    DS216+II | 8GB RAM | 2x4TB WD Red basic ext4 | DSM 6.0.2-8451-U9
    DS212j | | DSM 6.0.2-8451-U9 | Backup DS

    Fritzbox 7490 | Netgear GS108Tv2


    Projekte:

    Ultimate Backup - SPK
    Ultimate Search - SPK




  5. #2615
    Anwender
    Registriert seit
    17.06.2011
    Beiträge
    96

    Standard

    Mh, in dem von UB erstellten Script ist bei mir in der Nähe der genannten Zeilen weit und breit kein rsync-Aufruf (für mich) erkennbar.

    Code:
    if [ -f "$dir/$target_main.key" ]; then
    						echo "$target_main.key $lang_script_found" >> "$log"
    						synokeyfile=$(ecryptfs-unwrap-passphrase "$dir/$target_main.key" '$1$5YN01o9y')
    						$synoshare_target /usr/syno/sbin/synoshare --enc_mount "$mount_target" "$synokeyfile"
    						if [ $? -eq 0 ]; then
    							echo "$lang_script_encrypted $target_dir $target_main $lang_script_encrypted_will_mount" >> "$log"
    							target_mount=$(echo "$target_unmount" | sed 's/@//g')
    						else
    							source_error="$lang_script_encrypted $target_dir $target_main $lang_script_encrypted_not_mounted"
    						fi
    						unset synokeyfile
    					else
    						source_error="$lang_script_no_keyfile $target_main $lang_script_found!"
    					fi
    				elif [ -z "$target_unmount" ] && [ -z "$target_mount" ]; then
    					if [ ! -f "$stop"  ]; then
    						source_error="$target_dir $target_main $lang_script_not_found"
    					fi
    				fi
    				# Ziel definieren - sync=1
    				if [ ! -f "$stop"  ] && [ -z "$restore" ]; then
    					# Ziel nicht beim Script
    					if [ $nottoscript -eq 1 ]; then
    						desttarget=$(echo "$target_mount" | sed "s#$target_main.*##")
    						desttarget="$desttarget$target_only"
    					fi
    (das sind die Zeilen 969-993)

    Ich hab extra zwei völlig neue Scrips erstellt.

  6. #2616
    Anwender
    Registriert seit
    02.07.2013
    Beiträge
    2.964

    Standard

    Sorry bin mit den Zeilen nur vom direkten Scriptpart ausgegangen.
    Such mal danach und die drei roten rsync Teile musst du austauschen.

    Code:
    # SSH-SSH_FROM RSync-Datensicherung VON einer entfernten DS oder komp. Server
    #--------------------------------------------------------------------------
    if [ -n "$ssh_from" ] && [ -z "$ssh_to" ] && [ -n "$destination" ]; then
      share_check=$(echo "$share_check" | sed 's/\\//g;s/ /\\ /g')
      [ -n "$debug" ] && echo "rsync -e $rsync $syncopt $ssh_from:$share_check $logstat $exclude $recycle $destination" &>> "$log"
      rsync -e "$rsync" $syncopt $ssh_from:"$share_check" $logstat $exclude $recycle "$destination" &>> "$log"
      rsync_exit=$?
    # SSH-SSH_TO RSync-Datensicherung AUF eine entfernte DS oder komp. Server
    #--------------------------------------------------------------------------
    elif [ -z "$ssh_from" ] && [ -n "$ssh_to" ] && [ -n "$destination" ]; then
      [ -n "$debug" ] && echo "rsync -e $rsync $syncopt $share_check $logstat $exclude $recycle $ssh_to:$destination" &>> "$log"
      rsync -e "$rsync" $syncopt "$share_check" $logstat $exclude $recycle $ssh_to:"$destination" &>> "$log"
      rsync_exit=$?
    # RSync- Lokale Datensicherung auf Volume, USB- oder SATA-Datenträger
    #-------------------------------------------------------------------------
    elif [ -z "$ssh_from" ] && [ -z "$ssh_to" ] && [ -n "$destination" ]; then
      [ -n "$debug" ] && echo "rsync $syncopt $share_check $logstat $exclude $recycle $destination" &>> "$log"
      rsync $syncopt "$share_check" $logstat $exclude $recycle "$destination" &>> "$log"
      rsync_exit=$?
    fi
    ! Bitte Postfachgröße erhöhen !


    DS916+ | 8GB RAM | 3x3TB WD Red RAID 5 btrfs | DSM 6.1-15047-U2
    DS216+II | 8GB RAM | 2x4TB WD Red basic ext4 | DSM 6.0.2-8451-U9
    DS212j | | DSM 6.0.2-8451-U9 | Backup DS

    Fritzbox 7490 | Netgear GS108Tv2


    Projekte:

    Ultimate Backup - SPK
    Ultimate Search - SPK




  7. #2617
    Anwender
    Registriert seit
    17.06.2011
    Beiträge
    96

    Standard

    Danke! Schaue ich mir an!

  8. #2618

    Standard

    No Go on Ultimate Backup Street

    Was funktioniert:
    Backups aufs gleiche Volume

    Was geht nicht:
    Backups auf externes Volume
    USB Platte ist da
    Ohne Unterordner auf dem Volume geht schon mal gar nichts Platte wird gar nicht erkannt
    Mit Unterordner Platte und Ordner werden beim Sicherungs tja wie sag ichs erstes Menue Auswahl der Sicherungsorte erkannt und wird sauber angezeigt.

    Prima - NUR

    Auf der naechsten Seite - SICHERUNGSZIEL - wird sie nicht gezeigt

    Nun ja Trick 17 Skript auf der Platte im Ordner speichern

    Jetzt Ziel ist Skriptordner

    OK wird gespeichert.

    So nun ausfuehren niente - kein Zugriff moeglich.

    Ende Gelaende.

    Schade - haette mir gerne mal ein Proggie gewuenscht mit dem ich arbeiten kann.

    Beste Gruesse Bernd
    Beste Gruesse

    Bernd
    Jeder ist schlau - manche vorher - andere nachher

    DS1515+ mit 10TB Ironwolf Platten
    MacPro 64GB RAM / 1TB SSD
    Macbook Pro 3,3GHZ i7
    HP Switch mit LACP Trunk fuer die Syno und den MacPro

  9. #2619
    Anwender
    Registriert seit
    08.01.2020
    Beiträge
    46

    Standard

    Balgenbruder, was meinst du mit "ausfuehren niente - kein Zugriff moeglich."
    findest du das erstellte script nicht und kannst es nicht ausführen?
    oder bekommst du irgendeine Fehlermeldung beim Versuch dein Script auszuführen?
    DS918+ (DSM 6.2.2-24922 Update 4)

  10. #2620
    Anwender
    Registriert seit
    08.01.2020
    Beiträge
    46

    Standard

    Tommes und PsychoHH, danke für Eure Arbeit mit UB, ich glaube es ist das sinnvollste und mächtigste (nicht grafisch schönste ;-) ) was ich auf meiner Synology habe ;-) ( jetzt muss ich es nur noch richtig nutzen lernen )

    meine Frage:
    könnt Ihr mir bitte helfen, wie ich das script so ändere, dass ich weniger Unterverzeichnisse im Zeil erstellt bekommen? ( ich flehe euch an, dass dies geht *g* )

    Szenario, der Inhalt von:
    2020-02-25 16_09_28-DS918plus - Synology DiskStation.png
    DS918plus
    ∟shared temp

    soll bitte in
    usbshare1
    ∟T

    gesichert werden...

    bitte ohne, dass noch Volume1 und darin dann shared temp erstellt wird.

    gibts hier vielleicht eine positive Antwort?
    VIELEN HERZLICHEN DANK


    PS
    wenn dies alles mal funktioniert, können gern "Die Quell und Zielordner..." die Option "!werden synchronisiert" bekommen, gerade in den Allgemeinen Einstellungen gesehen, dass es sowas gibt
    Geändert von higherbeats (25.02.2020 um 16:39 Uhr)
    DS918+ (DSM 6.2.2-24922 Update 4)

Seite 262 von 267 ErsteErste ... 162212252260261262263264 ... LetzteLetzte

Ähnliche Themen

  1. MSI Digi Vox Ultimate HD Pro
    Von sideshowbob im Forum Video Station
    Antworten: 5
    Letzter Beitrag: 11.01.2013, 20:16
  2. DS109, Win7 64bit Ultimate und Technisat HD8-C
    Von oribi im Forum Installation und Konfiguration allgemein
    Antworten: 3
    Letzter Beitrag: 18.09.2009, 07:06
  3. Synology Assistent unter Windows7 (Ultimate)
    Von Herbie59 im Forum Disk Station Manager
    Antworten: 12
    Letzter Beitrag: 28.08.2009, 22:41
  4. DS 107+ nicht sichtbar unter Vista Ultimate
    Von Rabbit69 im Forum SMB-Server / AFP-Server
    Antworten: 2
    Letzter Beitrag: 17.08.2008, 10:43
  5. CS407 - Vista64Bit ultimate // 5,4mb/s
    Von Darky im Forum SMB-Server / AFP-Server
    Antworten: 4
    Letzter Beitrag: 30.04.2008, 14:28

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •