Ergebnis 1 bis 8 von 8
  1. #1
    Anwender
    Registriert seit
    06.12.2009
    Beiträge
    347

    Standard IPKG DS209 - 503 Service Unavailable

    Guten Abend allen

    Ich wollte mich mal erkundigen ob ich de fehlersuche aufgeben kann.

    zZ bekomme ich folgenden fehler :

    BusyBox v1.16.1 (2011-10-24 18:58:05 CST) built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    DS-209> ipkg update
    Downloading http://ipkg.nslu2-linux.org/feeds/op...le/Packages.gz
    --2011-11-15 18:23:12-- http://ipkg.nslu2-linux.org/feeds/op...le/Packages.gz
    Resolving ipkg.nslu2-linux.org... 69.163.133.43
    Connecting to ipkg.nslu2-linux.org|69.163.133.43|:80... connected.
    HTTP request sent, awaiting response... 503 Service Unavailable
    2011-11-15 18:23:12 ERROR 503: Service Unavailable.

    An error ocurred, return value: 1.
    Collected errors:
    ipkg_download: ERROR: Command failed with return value 8: `wget --passive-ftp -P /opt/ipkg-veMn9j http://ipkg.nslu2-linux.org/feeds/op...le/Packages.gz'
    DS-209>
    soll mir das sagen das der service auf dem server zZ nicht geht ?

    da IPKG bisher einwandfrei ging.
    Gruss MaCoM
    ----------------------------------------------------------------------------------------------
    DS209 DSM 4.2 (Backup)
    DS214 DSM 6.2
    FB 7490 / Win10 / NoxoN M520 / IPCam FI8908W - FI8904W - FI8921W - FI9803P
    --------------------------------------------------------------------------------------------------------

    Keiner ist unnütz, er kann immer noch als schlechtes Beispiel dienen.

  2. #2
    Moderator Avatar von jahlives
    Registriert seit
    19.08.2008
    Beiträge
    18.275
    Blog-Einträge
    20

    Standard

    503-er sind http-Fehler der Serverseite. Da hast du selber keinen (oder fast keinen) Einfluss darauf. Ich habe mal den Link zum packages.gz geklickt und ich habe die Datei sofort zum DL erhalten. Vielleicht also nur ein temporäres Problem, das sich zwischen Posterstellung und jetzt gelöst hat?
    Was im Leben zählt, ist nicht, dass wir gelebt haben. Sondern, wie wir das Leben von anderen verändert haben (Rolihlahla "Nelson" Mandela 1918-2013)

  3. #3
    Anwender
    Registriert seit
    06.12.2009
    Beiträge
    347

    Standard

    Danke jahlives für den Hinweis.
    Da es nun schon der 3 tag ist dachte ich das der fehler bei mir ligt.
    Per HTTP komme ich ja auch an alles ran.
    Gruss MaCoM
    ----------------------------------------------------------------------------------------------
    DS209 DSM 4.2 (Backup)
    DS214 DSM 6.2
    FB 7490 / Win10 / NoxoN M520 / IPCam FI8908W - FI8904W - FI8921W - FI9803P
    --------------------------------------------------------------------------------------------------------

    Keiner ist unnütz, er kann immer noch als schlechtes Beispiel dienen.

  4. #4
    Anwender
    Registriert seit
    06.12.2009
    Beiträge
    347

    Standard

    Nach dem ich nun schon seid 3 tagen hoffe hat sich immernoch nichts getan.
    Ich habe mal alles alte weggeschmissen und ipkg kommplet neu installiert.

    Das ergebniss ist das selbe ! ! !

    Gibt es eine möglichkeit herraus zu finden wo das problem liegt ?
    es scheint ja am "wget --passive-ftp" zu liegen nur wie kann ich es umgehen.

    kann es vielleicht jemand bestätigen das es zZ mit der DS209 nicht geht ?
    Gruss MaCoM
    ----------------------------------------------------------------------------------------------
    DS209 DSM 4.2 (Backup)
    DS214 DSM 6.2
    FB 7490 / Win10 / NoxoN M520 / IPCam FI8908W - FI8904W - FI8921W - FI9803P
    --------------------------------------------------------------------------------------------------------

    Keiner ist unnütz, er kann immer noch als schlechtes Beispiel dienen.

  5. #5
    Anwender
    Registriert seit
    16.09.2011
    Beiträge
    90

    Standard

    Vielleicht ein falscher oder keine iPKG wget? Musste nach der Installation den wget-ssl auch manuell installieren und hatte ähnliche Issues.

    Also samt dependencies ohne ipkg runterladen, ggf. installiere Variante löschen und dann offline installieren:
    Code:
    /usr/syno/bin/wget http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/unstable/wget-ssl_1.12-2_arm.ipk
    /usr/syno/bin/wget http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/unstable/libidn_1.21-1_arm.ipk
    /usr/syno/bin/wget http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/unstable/openssl_0.9.8p-1_arm.ipk
    ipkg -force-depends remove wget wget-ssl
    ipkg install openssl_0.9.8p-1_arm.ipk libidn_1.21-1_arm.ipk wget-ssl_1.12-2_arm.ipk
    rm openssl_0.9.8p-1_arm.ipk libidn_1.21-1_arm.ipk wget-ssl_1.12-2_arm.ipk
    ipkg update

    NAS: DS 211+ [1944], 2 x WD20EARS [2TB] RAID-1, 4 x WD30EZRX [3TB] via USB
    Workstation: 27" iMac Core i7 @3,4GHz, 16GB RAM, 256GB SSD, 2TB SATA, 2GB HD6970M, Lion
    HTPC: Zotac 9300 ITX WiFi, C2D E8400 @3GHz, 4GB RAM, 160GB SDD, MediaPortal 1.2.0 SVN, Win 7
    Storage Array: Adaptec 3085, 22 x WD2002FYPS [2TB] RAID 6 mit Hotspare
    Router: Netgear WNDR3700 [DD-WRT], Linksys E4200 [DD-WRT], AVM FRITZ!Box 7390 [Stock Firmware]
    Displays: Samsung 24" 244T, Asus 27" VE278Q, Samsung 55" LE-55A956

  6. #6
    Anwender
    Registriert seit
    06.12.2009
    Beiträge
    347

    Standard

    danke scythe42 für den tip.

    habs versucht - leider ohne erfolg - ergebniss ist das selbe. :-(
    Gruss MaCoM
    ----------------------------------------------------------------------------------------------
    DS209 DSM 4.2 (Backup)
    DS214 DSM 6.2
    FB 7490 / Win10 / NoxoN M520 / IPCam FI8908W - FI8904W - FI8921W - FI9803P
    --------------------------------------------------------------------------------------------------------

    Keiner ist unnütz, er kann immer noch als schlechtes Beispiel dienen.

  7. #7
    Anwender
    Registriert seit
    16.09.2011
    Beiträge
    90

    Standard

    Hab mal genauer nachgeguckt...

    Bei mir spuckt nslokoup für ipkg.nslu2-linux.org die IP 140.211.169.161 aus. Wenn ich auf 69.163.133.43 zugreife, bekomme ich nur einen falsch konfigurierten HTTP Server. Daher auch der 503 Error!

    Du hast also ein DNS Problem!

    Möglicherweise eine zu lange TTL? Wie sieht deine /etc/resolv.conf aus? Falls diese auf deinen Router zeigt, welche Name Server verwendet er?

    Bei mir sind die von Google eingetragen und OpenDNS als Backup, da die DNS Server meines Providers nicht viel taugen und der Cache eine viel zu lange TTL hat...

    Edit:
    Du könntest mal "69.163.133.43 ipkg.nslu2-linux.org" in die /etc/hosts eintragen. Darüber wird immer zu erst aufgelöst, bevor es an den Cache geht und dann zum DNS Server. Damit könntest du das Problem erstmal umgehen.
    Geändert von scythe42 (20.11.2011 um 12:43 Uhr) Grund: Ergänzung

    NAS: DS 211+ [1944], 2 x WD20EARS [2TB] RAID-1, 4 x WD30EZRX [3TB] via USB
    Workstation: 27" iMac Core i7 @3,4GHz, 16GB RAM, 256GB SSD, 2TB SATA, 2GB HD6970M, Lion
    HTPC: Zotac 9300 ITX WiFi, C2D E8400 @3GHz, 4GB RAM, 160GB SDD, MediaPortal 1.2.0 SVN, Win 7
    Storage Array: Adaptec 3085, 22 x WD2002FYPS [2TB] RAID 6 mit Hotspare
    Router: Netgear WNDR3700 [DD-WRT], Linksys E4200 [DD-WRT], AVM FRITZ!Box 7390 [Stock Firmware]
    Displays: Samsung 24" 244T, Asus 27" VE278Q, Samsung 55" LE-55A956

  8. #8
    Anwender
    Registriert seit
    06.12.2009
    Beiträge
    347

    Standard

    DANKE scythe42 !

    der tip war gold wert mit der /etc/hosts.

    ich bekomme 2 unterschiedliche ergebnisse zwischen PC (win7) und synology (ds209) bei nslookup.

    in meiner host standen 2 "ipkg.nslu2-linux.org" , "ipkg2.nslu2-linux.org" einträge drin mit der ungültigen ip.

    Da hab ich wohl mal vor langer zeit mist gebaut und vergessen :-(

    hab 1000 dank für dein hinweiss :-)
    Gruss MaCoM
    ----------------------------------------------------------------------------------------------
    DS209 DSM 4.2 (Backup)
    DS214 DSM 6.2
    FB 7490 / Win10 / NoxoN M520 / IPCam FI8908W - FI8904W - FI8921W - FI9803P
    --------------------------------------------------------------------------------------------------------

    Keiner ist unnütz, er kann immer noch als schlechtes Beispiel dienen.

Ähnliche Themen

  1. Antworten: 45
    Letzter Beitrag: 25.09.2011, 12:27
  2. IPKG auf DS209
    Von phillipp2003 im Forum IPKG
    Antworten: 10
    Letzter Beitrag: 14.02.2011, 14:36
  3. IPKG auf der DS209 installieren
    Von wired2051 im Forum Marvell basierte Geräte - DS110j, DS210j, DS410j, DS109, DS209, DS409, RS409
    Antworten: 6
    Letzter Beitrag: 19.04.2010, 17:53
  4. [Problem] DS209 & QOS (Quality-of-Service)
    Von Desperado im Forum Netzwerkkonfiguration
    Antworten: 4
    Letzter Beitrag: 30.01.2010, 18:06
  5. IPKG auf DS209+
    Von riedo im Forum IPKG
    Antworten: 14
    Letzter Beitrag: 17.04.2009, 13:13

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •