Seite 4 von 7 ErsteErste ... 23456 ... LetzteLetzte
Ergebnis 31 bis 40 von 65
  1. #31
    Moderator
    Registriert seit
    18.03.2009
    Beiträge
    13.423

    Standard

    Hallo,
    dovecot-1.0.15 kann man so nicht mit 1.2.11 vergleichen, der code ist schon sehr unterschiedlich. Auf der DS-106 (gcc 3.3.4) bekomme ich den gleichen Fehler, auf der DS-107+ (gcc 3.4.3) läuft es durch. Der 3.3 scheint penibler zu sein was nicht deklarierte Variablen angeht.
    Editier src/lib/compat.h, suche
    Code:
    #ifndef HAVE_SOCKLEN_T
    typedef int socklen_t;
    #endif
    danach fügst Du
    Code:
    #ifndef PATH_MAX
    #  define PATH_MAX 4096 /* for Hurd - Dovecot v2.0 removes the need for this */
    #endif
    ein und speicherst.
    In src/plugins/zlib/Makefile änderst Du die Zeile
    Code:
    LDFLAGS =
    zu
    Code:
    LDFLAGS = "-L/opt/lib"
    dann sollte das gehen.

    Gruß Götz
    DS1513+ / DSM 6.2 / 3x 2TB Samsung HD204UI
    DS916+ / DSM 6.1.7 / 3x 4TB HGST MegaScale DC 4000.B
    DS213+ / DSM 6.2 / 2x 2TB Seagate Constellation ES
    eTrayZ / Samsung HD103SI
    APC SMT750I+AP9631

  2. #32
    Moderator Avatar von jahlives
    Registriert seit
    19.08.2008
    Beiträge
    18.275
    Blog-Einträge
    20

    Standard

    @goetz
    Heisst das du konntest eine 1.2.11 Version auf der DS kompillieren?? Oder ist der "Fix" für die 1.0.15? Das konnte ich aus deinem Post nicht ganz rauslesen
    Was im Leben zählt, ist nicht, dass wir gelebt haben. Sondern, wie wir das Leben von anderen verändert haben (Rolihlahla "Nelson" Mandela 1918-2013)

  3. #33
    Moderator
    Registriert seit
    18.03.2009
    Beiträge
    13.423

    Standard

    Hi,
    ist für die 1.0.15 so wie er sie auf der 108j compilieren wollte, die 1.2.11 lief ja bei ihm durch.

    Gruß Götz
    DS1513+ / DSM 6.2 / 3x 2TB Samsung HD204UI
    DS916+ / DSM 6.1.7 / 3x 4TB HGST MegaScale DC 4000.B
    DS213+ / DSM 6.2 / 2x 2TB Seagate Constellation ES
    eTrayZ / Samsung HD103SI
    APC SMT750I+AP9631

  4. #34
    Moderator Avatar von jahlives
    Registriert seit
    19.08.2008
    Beiträge
    18.275
    Blog-Einträge
    20

    Standard

    Zitat Zitat von goetz Beitrag anzeigen
    Hi,
    ist für die 1.0.15 so wie er sie auf der 108j compilieren wollte, die 1.2.11 lief ja bei ihm durch.

    Gruß Götz
    Ob aber deliver von 1.2.11 mit dovecot 1.0.15 korrekt zusammenarbeiten kann wage ich mal zu bezweifeln
    @topicstater
    Verwende mal den Tip von goetz. Ist auf jeden Fall besser als einen LDA zu installieren, der nicht zur Basisversion der Software passt (versionsmässig)
    Was im Leben zählt, ist nicht, dass wir gelebt haben. Sondern, wie wir das Leben von anderen verändert haben (Rolihlahla "Nelson" Mandela 1918-2013)

  5. #35
    Moderator
    Registriert seit
    18.03.2009
    Beiträge
    13.423

    Standard

    Hi,
    ich habe keinen blassen Schimmer was mit wem funktioniert, ging nur darum das Problem beim compilieren der 1.0.15 auf alter ppc Hardware zu finden. Damit sollte es möglich sein nach Deiner Anleitung weiter zu machen. dovecot-sieve-1.0.3 habe ich dann nicht mehr probiert, werde es aber gleich mal dem gcc zum Fraß vorwerfen.

    Gruß Götz

    PS: ich selber habe rein garnichts was mail betrifft auf der DS am laufen.
    DS1513+ / DSM 6.2 / 3x 2TB Samsung HD204UI
    DS916+ / DSM 6.1.7 / 3x 4TB HGST MegaScale DC 4000.B
    DS213+ / DSM 6.2 / 2x 2TB Seagate Constellation ES
    eTrayZ / Samsung HD103SI
    APC SMT750I+AP9631

  6. #36
    Anwender
    Registriert seit
    23.02.2010
    Beiträge
    77

    Standard

    Danke an alle.

    Jetzt ist es durchgelaufen.

    Ergebniss, werde ich heute sehen.
    DS108j - mit IPKG (Für PowerPC (ppc_6xx)) und mail

  7. #37
    Moderator
    Registriert seit
    18.03.2009
    Beiträge
    13.423

    Standard

    Hallo,
    Jetzt ist es durchgelaufen.
    sehr schön. dovecot-sieve-1.0.3 ist dann bei mir auch durchgelaufen.

    Gruß Götz
    DS1513+ / DSM 6.2 / 3x 2TB Samsung HD204UI
    DS916+ / DSM 6.1.7 / 3x 4TB HGST MegaScale DC 4000.B
    DS213+ / DSM 6.2 / 2x 2TB Seagate Constellation ES
    eTrayZ / Samsung HD103SI
    APC SMT750I+AP9631

  8. #38
    Anwender
    Registriert seit
    12.07.2007
    Beiträge
    9.848

    Standard

    Wo könnte hier das Problem sein?
    Code:
    DS508> ./configure && make
    checking for a BSD-compatible install... /opt/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /opt/bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for style of include used by make... GNU
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking dependency style of gcc... gcc3
    checking for library containing strerror... none required
    checking for gcc... (cached) gcc
    checking whether we are using the GNU C compiler... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking for gcc option to accept ISO C89... (cached) none needed
    checking dependency style of gcc... (cached) gcc3
    checking how to run the C preprocessor... /lib/cpp
    configure: error: C preprocessor "/lib/cpp" fails sanity check
    See `config.log' for more details.
    Disk Station 1511+ - DSM 4.3 - 3776
    3x3TB Western Digital WD30EZRX, Raid 5
    1x1TB
    Western Digital WD10EADS, Basic

    Disk Station 212+
    - DSM 4.3 - 3776
    2x1TB Western Digital WD10EADS, Basic

  9. #39
    Moderator
    Registriert seit
    18.03.2009
    Beiträge
    13.423

    Standard

    Hallo,
    der reprocessor wird unter /lib gesucht und nicht gefunden, liegt wahrscheinlich unter /opt/bin. Eventuell reicht ein Symlink, ipkg update, ipkg upgrade könnte evtl. auch helfen.
    ./configure --help spuckt alle möglichen Optionen aus die man angeben kann.

    Gruß Götz
    Geändert von goetz (12.05.2010 um 15:04 Uhr)
    DS1513+ / DSM 6.2 / 3x 2TB Samsung HD204UI
    DS916+ / DSM 6.1.7 / 3x 4TB HGST MegaScale DC 4000.B
    DS213+ / DSM 6.2 / 2x 2TB Seagate Constellation ES
    eTrayZ / Samsung HD103SI
    APC SMT750I+AP9631

  10. #40
    Moderator Avatar von jahlives
    Registriert seit
    19.08.2008
    Beiträge
    18.275
    Blog-Einträge
    20

    Standard

    @trolli
    Hast du auch alle Devloper Pakete installiert? gcc scheint ja drauf zu sein, aber hast du auch libc-dev?
    Was im Leben zählt, ist nicht, dass wir gelebt haben. Sondern, wie wir das Leben von anderen verändert haben (Rolihlahla "Nelson" Mandela 1918-2013)

Seite 4 von 7 ErsteErste ... 23456 ... LetzteLetzte

Ähnliche Themen

  1. Kann keine Mails verschicken
    Von babsitz83 im Forum Mail Station
    Antworten: 16
    Letzter Beitrag: 15.12.2009, 09:18
  2. Wiederherstellen der Mails
    Von HarryPotter im Forum Mail Station
    Antworten: 3
    Letzter Beitrag: 16.09.2009, 15:09
  3. Mailstation - Spam in eigenen Ordner filtern
    Von boecki im Forum Mail Station
    Antworten: 14
    Letzter Beitrag: 04.08.2009, 21:55
  4. mails empfangen, postfächer anlegen
    Von securico im Forum Webserver
    Antworten: 8
    Letzter Beitrag: 14.09.2008, 11:59
  5. Mails via PHP verschicken
    Von Miesnis im Forum Webserver
    Antworten: 18
    Letzter Beitrag: 26.10.2007, 13:21

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •