Hallo liebe Forumsmitglieder,

ich habe seit dem letzten Update des Synology Medienserver auf jetzt Version 1.8.0-2867 reproduzierbare Probleme mit der Medienanzeige auf meinem Smart-TV, die ich trotz langen Versuchens nicht beheben konnte:

Auf dem Smart-TV möchte ich über dessen DMA Media Player vom Synology Medienserver auf meiner DS 218 Fotos und Videos in verzeichnisbezogener gemischter Form anzeigen, d.h. Fotos und Videos aus ein- und demselben Verzeichnis abwechselnd als durchgängige Diashow. Dies hat bislang problemlos funktioniert, einfach per Umschalten des anzuzeigenden Medientyps im Smart-TV-Media Player.

Auf der DS 218 sind installiert:
  • DSM 6.2.2-24922 Update 6
  • PhotoStation 6.8.13-3499
  • Medienserver 1.8.0-2867
  • AudioStation 6.5.4.3367
  • VideoStation 2.4.7-1603

Organisation im Dateisystem:
  • Auf der DiskStation sind die Dateien wie folgt in den Standard-Verzeichnissen Photo (/photo) und Video (/video) organisiert (es werden nur Bilddateien vom Typ .jpg und .png sowie Videodateien der Typen .mp4 und .mov verwendet).
  • Unter Photo sind ereignisbezogen Bild- und Videodateien mit gemischten Dateitypen enthalten, d.h. es finden sich in ein- und demselben Unterverzeichnis für z.B. "Ereignis-X" sowohl die zugehörigen Fotos als auch Videos, wie sie von der Kamera geliefert wurden, so dass auf dem Smart-TV eine durchgängige Diashow von abwechselnd Bildern und Videos möglich ist. Die Pfade sind dann z.B.
    /<NAS-Name>/Photo/<Ereignis-X>/bild_aaa.jpg
    /<NAS-Name>/Photo/<Ereignis-X>/video_bbb.mp4
    und sollen auch so per Smart-TV auffindbar sein (und waren es auch zuvor).
  • Unter Video sind einzelne Videodateien (ohne Ereignisbezug) im .mp4-Format abgelegt.

Folgendes Fehlverhalten tritt nun seit dem Update auf:
Im Media Player auf dem Smart-TV werden in keinem Fall mehr alle Dateien eines Verzeichnisses auf der DiskStation angezeigt, selbst wenn man im Media Player auf dem Smart-TV den Filter "Angezeigte Dateitypen" auf "Alle Medien" schaltet. Somit ist keine durchgängige Anzeige/Diashow mehr möglich. Dies tritt immer auf, egal, ob man den Media Player per "Inhalt --> Fotos", "Inhalt --> Videos" oder "Quelle: Netzwerk" aufruft. Ich habe auch ein Update bzw. Neuinstallation der kompletten Synology-Software inkl. DSM durchgeführt, um zu sehen, ob es hier Abhilfe gibt. Dies blieb leider auch erfolglos. Die Inhalte im NAS-Dateisystem sind aber OK, geprüft auch per Check über ssh, und auch die PhotoStation zeigt die Inhalte richtig an.

Mit dem Smart-TV Media Player sehe ich nun folgende Verzeichnisstruktur und Inhalte auf der DiskStation, je nach eingestellter Dateiindizierung (unter Systemsteuerung -> Indizierungsdienst):
  • Mit Indizierung von nur Dateityp photos unter dem Photo-Verzeichnis auf der DiskStation (dies war auch die Einstellung vor den Updates, mit der die gemischte Anzeige sogar funktioniert hatte):

    Im Media Player unter Photo sehe ich:
    /<NAS-Name>/Photo/<Ereignis-X>/bild_aaa.jpg : Bei angezeigtem Medientyp "Bilder" (--> OK)
    /<NAS-Name>/Photo/<Ereignis-X>/ : Nichts/Leer bei angezeigtem Medientyp "Videos" oder "Alle Medientypen" (--> Nicht OK)

    Im Media Player unter Video sehe ich:
    /<NAS-Name>/Video/filmdatei_yyy.mp4 : Bei angezeigtem Medientyp "Videos" oder "Alle Medientypen" (--> OK)
    /<NAS-Name>/Video/ : Nichts/Leer bei angezeigtem Medientyp "Bilder" (--> OK)

  • Mit Indizierung von Dateitypen "photos + videos" unter dem /photo-Verzeichnis auf der DiskStation:
    /<NAS-Name>/Photo/<Ereignis-X>/bild_aaa.jpg : Bei angezeigtem Medientyp "Bilder" (--> OK)
    /<NAS-Name>/Photo/<Ereignis-X>/ : Nichts/Leer bei angezeigtem Medientyp "Videos" oder "Alle Medientypen" (--> Nicht OK)

    Im Media Player unter video sehe ich darunter nochmals eine irritierende photo/video-Pfad-Unterscheidung, die ich mir nur als "Videos im Unterzeichnis Photos" und "Videos im Unterverzeichnis Videos" erklären kann:
    /<NAS-Name>/Video/videodatei_yyy.mp4 : Bei angezeigtem Medientyp "Videos" oder "Alle Medientypen" (--> OK)
    /<NAS-Name>/Video/photo/<Ereignis-X>/ : Nichts/Leer bei Medientyp "Bilder" (--> Wie erwartet, aber der doppelte Pfad ist irritierend)
    /<NAS-Name>/Video/photo/<Ereignis-X>/video_xxx.mp4 : Bei angezeigtem Medientyp "Videos" oder "Alle Medientypen" (--> Nicht OK)
    /<NAS-Name>/Video/video/filmdatei_yyy.mp4 : Bei angezeigtem Medientyp "Videos" oder "Alle Medientypen" (--> Nicht OK; damit ist die filmdatei_yyy unter zwei Pfaden "Video" und "Video/video" zugänglich)
    /<NAS-Name>/Video/video/ : Nichts/Leer bei Medientyp "Bilder" (--> Wie erwartet, aber der doppelte Pfad ist irritierend)

Es ist damit also in keinem Fall mehr möglich, die gewünschte durchgängige Anzeige von abwechselnd Bildern und Videos zu einem Ereignis in einem Verzeichnis am Stück zu erhalten, egal was ich versuche.
Verwendet man auf der DiskStation weiterhin die Indizierung nur mit Typ "photos" unter Verzeichnis "/photo", so sieht man im Smart-TV Media Player die enthaltenen Videodateien überhaupt nicht mehr, egal welcher Medientyp gewählt wird. Das Pfad-Konstrukt "Video/photo" wird ja erst im anderen Indizierungsmodus angezeigt/erstellt.
Stellt man in "Systemsteuerung -> Indizierungsdienst" die Indizierung auf "photos + videos" unter Verzeichnis "/photo", so erreicht man die Videodateien nur noch, in dem man die Diashow unterbricht und komplett zum anderen Pfad navigiert; das Umschalten der angezeigten Medientypen funktioniert nicht mehr.
Bereits zuvor und auch jetzt ist "Systemsteuerung --> Indizierungsdienst --> Videokonvertierung für Mobilgeräte" ausgeschaltet; war auch zuvor nicht notwendig.

Ich habe bereits Folgendes - leider erfolglos - probiert:
  • die Einstellungen im TV und dem NAS überprüft und neu gesetzt,
  • auf der DiskStation die PhotoStation und den Medienserver deinstalliert und neu installiert,
  • eine Neuindizierung im Medienserver mit geändertem DMA-Menüstil durchgeführt (zum Erzwingen einer neuen Indexstruktur),
  • eine Neuindizierung im Indizierungsdienst mit erst Abwählen aller Inhalte (so dass auf dem Smart-TV nichts mehr angezeigt wird) und danach Wiederanwählen von Videos + Fotos in /photo,
  • im Medienserver ein Ändern der Anzeigereihenfolge von Fotos von Namen auf Datum,
  • den Smart-TV im Synology Medienserver unter DMA-Kompatibilität sowohl als "Generisches DLNA" wie auch als "Standardgerät" eingetragen,
  • die Netzwerkverbindung des Smart-TV neu konfiguriert,
  • und sowohl DiskStation als auch Smart-TV jeweils kalt gestartet.

Leider bleibt das Ergebnis stets negativ: der MediaPlayer auf dem Smart-TV zeigt beharrlich unter Photos auch nach Umschalten auf "alle Medientypen" nur Bilddateien an, selbst wenn sich im selben Verzeichnis auch Videodateien, die laut Einstellungen mitindiziert wurden, befinden. Die Videodateien sind nur zu erreichen, wenn man den Pfad wieder bis ganz zur Wurzel navigiert und dann anstatt Fotos den Zweig Videos und dann /photos auswählt (sinngemäß also "Videos, die im Foto-Verzeichnis liegen"). Dann wiederum sieht man die Bilddateien nicht mehr, obwohl man sich im selben Verzeichnis wie zuvor befindet. Da zuvor die Anzeige gemischter Verzeichnisse (Bilder + Videos im selben Verzeichnis; die Medienserver-Indizierung war sogar nur auf "photos" eingestellt) kein Problem war, bin ich hier nun ratlos.
Benutze ich die PhotoStation direkt über die Web-Oberfläche, wird alles richtig angezeigt, d.h. gemischt Fotos + Videos in einem Verzeichnis. Damit kann es wohl nur am Zusammenspiel Smart-TV-MediaPlayer und Medienserver liegen.

Den Support des TV-Herstellers hatte ich auch bereits angefragt, in der Annahme, dass es an einem Update dort lag, allerdings ist dort laut Auskunft keine Veränderung der Software des Smart-TV-MediaPlayers erfolgt.

Was kann ich daher tun, um wieder die gemischte Anzeige zu erhalten? Gibt es ggf. Tricks, die Datenbank anzupassen (SQL Patch Script o.ä.)? Gibt es bekannte Wechselwirkungen zwischen den Paketen? Hat hier vielleicht jemand eine Idee, wie dem Phänomen beizukommen wäre?

Besten Dank im Voraus!