Ergebnis 1 bis 2 von 2
  1. #1
    Anwender
    Registriert seit
    31.01.2016
    Beiträge
    2

    Standard Datenübertragung (schreibend) auf DS 1515+ langsam bei deaktiviertem Schreibcache

    Hallo,

    zunächst meine Konfiguration:
    DS 1515+, DSM 6.2.2-24922 Update 4
    8 GB RAM
    Dateisystem btrfs
    RAID SHR mit Datenschutz für ein Laufwerk
    Platten: 2x WD60EFRX (RED) 6 TB, 2x WD30EFRX (RED) 3 TB
    Switch: HP Procurve 1810G-24. Die Rechner (iMac und Windows Notebook) sind darüber direkt mit der DS verbunden.

    Nun zu meinem Problem:
    Egal mit welchem Protokoll (SMB, AFP, FTP): Schreibzugriffe auf das NAS in einem GBit-Netzwerk sind deutlich zu langsam (im Schnitt 40-50 MB/s, lesend erreiche ich locker die 100 MB/s).

    Was habe ich versucht:
    Ich habe alle Tips und Hinweise, die ich finden konnte ausprobiert (SMB Signing off, SMB-Übertragungsverschlüsselung aus, SMB-Protokoll-Versionen auf min 2 und max 3 gesetzt, etc.). Hatte alles keine Auswirkung.

    Getestet habe ich mit MacOS 10.15.4 und Windows 10 1909.

    Da immer am Anfang der Übertragung die 100 MB/s erreicht werden und dann ein massiver Einbruch nach wenigen Sekunden erfolgt, bin ich dann irgendwann auf die Idee gekommen, dass es gar nicht an den Protokollen sondern an den Platten in der Station liegt (daher der Post auch in diesem Unterforum).

    Ich habe mir dann mal die Einstellungen der Festplatten angeschaut und gesehen, dass der Schreibcache der Platten abgeschaltet ist. Das war eigentlich auch so beabsichtigt, da ich keine USV habe. Ich habe dann mal testhalber den Schreibcache für alle Platten aktiviert und neue Tests gemacht.
    Bei diesen Tests hatte ich jetzt in allen Betriebssystemen und mittels SMB (die anderen Protokolle habe ich nicht mehr getestet) die volle Geschwindigkeit von ca. 100 MB/s.

    Meine Fragen:
    1. In vielen Beiträgen zum Thema "SMB-Geschwindigkeit" wurden von vielen von Euch Geschwindigkeiten um die 100 MB/s genannt. Habt Ihr den Schreibcache ein?
    2. Wenn ich den Schreibcache einschalte und es kommt zu einem Stromausfall. Ist dann die Gefahr eines Datenverlustes sehr groß oder haben moderne Platten einen Kondensator der dann noch ein "Notschreiben" der Daten ermöglicht?
    3. Kann es sein, dass meine schlechten Geschwindigkeiten an den verwendeten Platten liegen (die können ja "nur" 5400 RPM).?

    Vielen Dank für Eure Hilfe,
    Günther.

  2. #2
    Anwender
    Registriert seit
    31.01.2016
    Beiträge
    2

    Standard

    Die Sache hat mir keine Ruhe gelassen und ich habe noch etwas experimentiert.
    Ich habe daher die DS1515+ nochmal komplett neu aufgesetzt und diesmal zwei EVO 860 SSDs genommen. Die eine hat 512 GB, die andere 1 TB.
    Wieder habe ich einmal den Schreibcache aktiviert und einmal nicht. Interessanterweise war der Schreibcache bereits standardmäßig eingeschaltet.
    Ansonsten gleiche Konstellation wie oben beschrieben. SMB etc. gleich eingestellt. Gleiches Testprogramm (LAN Speedtest 4.4 von www.totusoft.com).
    Speedtest.jpg
    1: 5 GB Datei mit ausgeschaltetem Write-Cache
    2: 5 GB Datei mit eingeschaltetem Write-Cache
    3: 9 GB Datei mit eingeschaltetem Write-Cache
    4: 9 GB Datei mit augeschaltetem Write-Cache
    Bei der SSD macht also der Write-Cache erwartungsgemäß nicht soviel aus.

    Was ich allerdings überhaupt nicht verstehe: Warum kommt es bei der Übertragung immer wieder zu diesen Einbrüchen der Geschwindigkeit? Beim Schreiben ohne Cache würde ich das noch halbwegs verstehen (die Platte ist halt zu langsam, daher bei der SSD auch bessere Werte). Aber wie kommt es zu den Einbrüchen beim Lesen?
    CPU und RAM sind übrigens nicht wirklich ausgelastet:
    CPU.jpg

    Hat jemand von Euch hierfür eine Erklärung?

    Kann es sein, dass es an dem SHR-RAID liegt? Das wird ja, wenn ich das richtig gesehen habe über eine LVM Gruppe gemacht, da das wohl per Software abläuft könnte hier natürlich ein Flaschenhals sein.

    Um das zu prüfen, habe ich jetzt nochmal ein einfaches RAID1 mit btrfs aufgesetzt. Da sieht es bei der 9 GB Datei etwas besser aus, aber es sind immer noch Einbrüche.
    Leistung2.jpg

    Wie man sehen kann, sind auch hier CPU und RAM so gut wie nicht beschäftigt.

    Oder ist das einfach so? Sprich: Sieht das bei Euch auch so aus.

    Danke.

    Viele Grüße,
    Günther.
    P.S.: Unter Windows sieht es übrigens genauso aus. Liegt also nicht an der SMB-Implementation von Apple.
    Geändert von gmh15 (03.05.2020 um 11:45 Uhr)

Ähnliche Themen

  1. [DS1618+] SMB schreibend über 10 Gb/s plötzlich langsam
    Von prawn im Forum SMB-Server / AFP-Server
    Antworten: 11
    Letzter Beitrag: 09.06.2019, 18:48
  2. Datenübertragung langsam
    Von Nevs1012 im Forum Netzwerkkonfiguration
    Antworten: 9
    Letzter Beitrag: 27.04.2016, 16:18
  3. Datenübertragung zu langsam
    Von mick im Forum Sonstiges
    Antworten: 3
    Letzter Beitrag: 30.12.2015, 19:20
  4. Datenübertragung auf Synology DS213j extrem langsam
    Von Smoody im Forum Netzwerkkonfiguration
    Antworten: 10
    Letzter Beitrag: 17.01.2014, 10:57
  5. Datenübertragung auf DS109 sehr langsam
    Von DS109-User im Forum Backup / Restore / Data Replicator Allgemein
    Antworten: 15
    Letzter Beitrag: 09.04.2010, 21:46

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •