Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11
  1. #1

    Standard Photostation Rechte-Problem: Hinweis, keine Rechte, obwohl vorhanden

    Moin allerseits!

    War lange nicht mehr hier, aber jetzt habe ich mal wieder eine Frage.

    Und zwar nutze ich eigentlich schon seit Ewigkeiten die Photostation und bin damit eigentlich auch sehr zufrieden.

    Für den Zugriff nutze ich hauptsächlich die Android-App "DS-Photo", was auch meistens gut funktioniert.

    Doch in letzter Zeit kommt beim Zugriff auf die Ordner immer mal wieder eine Meldung, ich hätte keine Rechte für das Album, und anschließend lande ich dann wieder im übergeordneten Album.

    Beim nächsten Versuch klappt es dann, manchmal muss ich auch öfter probieren. Es liegt definitiv nicht an den Rechten, denn dann könnte ich ja nicht nach mehreren Versuchen auf das Album zugreifen, für das zuvor noch der HInweis kam, ich hätte keine Rechte.

    Ich meine, ich hätte dazu schon mal was gelesen, kann es aber nicht mehr finden.

    Freu mich auf Tipps!

    Danke und viele Grüße,

    Björn
    Geändert von bjoernkrueger (27.02.2020 um 12:55 Uhr)

  2. #2

    Standard

    Läuft deine Photostation auf DSM-Kontensteuerung oder auf Photostation Kontensteuerung?
    Synology DS 916+ | 8 GB RAM | @ DSM 6.2.2 - 24922-U6
    1x Western Digital Red WD60EFRX @ SHR, ext4
    3x Western Digital Red WD100EFAX @ SHR, ext4
    Synology DS 218+ | 16 GB (8+8) RAM | @ DSM 6.2.2 - 24922-U6 (Backup DS)
    2x Western Digital Red WD100EFAX @ Basis, ext4
    Backup: 3x ext. HDDs USB 3.0 @ GPT / NTFS + ext4
    Backup: Dockingstation Inateck FD1003 USB 3.0 @ ext4
    USV: APC Back-Ups Pro 1500
    usbshare Nummern frei definieren: <Anleitung klick>

  3. #3

    Standard

    Moin!

    Ich würde jetzt nicht auf das Leben meiner Kinder schwören, aber ich glaube, auf Photostation Kontensteuerung.
    Ja, ich lege eigene Benutzer an, die dann nur für die PS gelten. Insofern also wohl PS-Konten.

    Danke und viele Grüße,

    Björn

  4. #4

    Standard

    Das gefällt mir, "... ich glaube....", kannst du bitte nachsehen:
    DSM > Hauptmenü > Systemsteuerung > User "admin" aktivieren > Jetzigen Benutzer im DSM abmelden > Als User "admin" (admin, NICHT ein anderer User mit Adminrechten, user "admin"!) in der Photostation anmelden.
    NUR der User "admin" sieht die Kontensteuerung, bitte nachsehen wo der Punkt gesetzt ist:

    ps_benutzerkontensystem.jpg

    Noch mal, NUR der User "admin" sieht in der Photostation die Anzeige der Benutzerkontensteuerung,also der Teil im roten Rahmen.

    *) DSM-Konten = die User werden vom DSM Benutzerkonto in die PS "übernommen" und deren Rechte (=Privilegien) werden in der PS eingestellt, auch wenn die User aus der DSM Kontenverwaltung kommen
    *) Photo-Station-Konten = die PS selbst hat ein erweitertes Menü mit mehreren Schaltflächen um neue User anlegen zu können, sie existieren dann nur in der PS aber nicht im DSM Benutzerkonto für DSM usw.

    WENN du auf Photo-Station-Konten stehst, dann bitte noch mal genau Kontrollieren ob deine User wirklich die korrekten Privilegien für die Alben haben.
    Der gemeinsame Ordner /photo hat eine Sonderstellung, er wird direkt von der Photostation verwaltet!
    Wenn du also DSM Konten hast und in der Filestation aus alten DSM Versionen den Usern die Rechte in den Alben unter /photo erteilt hast, so kann das funktionieren muss aber nicht, da ausschliesslich die Photostation den Ordner /photo verwaltet und die Rechte (=Privilegien) erteilt.
    Synology DS 916+ | 8 GB RAM | @ DSM 6.2.2 - 24922-U6
    1x Western Digital Red WD60EFRX @ SHR, ext4
    3x Western Digital Red WD100EFAX @ SHR, ext4
    Synology DS 218+ | 16 GB (8+8) RAM | @ DSM 6.2.2 - 24922-U6 (Backup DS)
    2x Western Digital Red WD100EFAX @ Basis, ext4
    Backup: 3x ext. HDDs USB 3.0 @ GPT / NTFS + ext4
    Backup: Dockingstation Inateck FD1003 USB 3.0 @ ext4
    USV: APC Back-Ups Pro 1500
    usbshare Nummern frei definieren: <Anleitung klick>

  5. #5
    Anwender Avatar von Puppetmaster
    Registriert seit
    03.02.2012
    Beiträge
    17.016

    Standard

    Welche Rolle sollte das Kontenmodell bei dem geschilderten Verhalten denn überhaupt spielen?
    DS415+ DSM 6.2.1-23824 U1 | 2x2TB BTRFS RAID1 + 8TB EXT4 (Basis) WD Red 24/7
    DS214+ DSM 6.2.1-23824 U1 | 3TB WD Red (Basis) + 6TB Seagate Archive (Basis)
    Media Logitech Media-Server 7.7.2 | Squeezebox Classic | Squeezebox Transporter | VU+ Uno | Raspberry Pi - OpenELEC 6.0.1 Kodi v15
    USV APC Back-UPS RS550GI


    Reset einer DiskStation | Migration zwischen DiskStations | Festplattenzugriff mittels Knoppix-DVD

  6. #6

    Standard

    Mein Verdacht liegt/lag auf den Benutzerrechten da Björn die PS schon (so wie ich auch) seit "Ewigkeiten" benutzt und in Verwendung hat. Also zu einer Zeit damit gestartet ist (bei mir war es damals DSM 5.2) als man noch im DSM selbst die Rechte für den gemeinsamen Ordner /photo eingestellt und vergeben hat. Irgendwann im Laufe der Zeit und viele DSM und PS Updates später wurde das ja komplett umgestellt und im DSM ist die Einstellung der Rechte nur mehr "hellgrau/inaktiv" geworden und man hat die Rechte (=Privilegien) nur mehr ausschliesslich in der PS eingestellen können.
    Jetzt ist es bei den "alten" PS Installationen aber so, das man die Ursprungseinstellungen immer "mitgenommen" hat. Das kann ich auch heute noch sehr schön auf meiner DS916+ sehen obwohl hier brav die aktuellste PS Version läuft.
    ABER da ich damals von meiner alten DS415+ mit DSM 5.2 und der damals "aktuellen" PS Installation begonnen habe, wurde durch die Migration der damals 3 HDDs aus der DS415+ in die DS916+ die "alte" Variante mit der immer noch möglichen DSM Photosteuerung mitgenommen, bis zum heutigen Tag.
    Dh. obwohl ich aktuelles DSM und PS heute verwende, habe ich auf der DS916+ immer noch die Möglichkeiten die Rechte direkt im DSM zu vergeben.
    Mache ich aber schon sehr lange nicht mehr, sondern vergebe die Rechte, so wie es jetzt üblich ist, nur mehr direkt über die PS.
    Daher meine Frage an Björn welche Kontensteuerung er benützt, da es bei ihm vermutlich so wie bei mir immer noch alte Fragmente der Steuerung gibt die möglicherweise seine sporadischen, heutigen Probleme beim Zugriff auf manche Alben verursachen.

    Nachtrag:
    Hier noch Bilder zum besseren Verständnis, auf der DS916+ trotz aktuellem DSM und PS kann ich immer noch die Rechte für /photo direkt im DSM vergeben, die Spalten sind nach wie vor aktiv und können verwendet werden:
    ps_dsm_rechtevergabe.jpg

    im Vergleich dazu auf der "neueren" DS218+ auch mit aktuellem DSM und PS kann ich im DSM keine Rechte mehr für /photo einstellen, die Spalten sind "hellgrau/inaktiv":
    ps_dsm_rechtevergabe_neu.jpg

    die Rechtevergabe erfolgt nur mehr ausschliesslich über die PS selbst.
    Geändert von Kurt-oe1kyw (28.02.2020 um 00:16 Uhr)
    Synology DS 916+ | 8 GB RAM | @ DSM 6.2.2 - 24922-U6
    1x Western Digital Red WD60EFRX @ SHR, ext4
    3x Western Digital Red WD100EFAX @ SHR, ext4
    Synology DS 218+ | 16 GB (8+8) RAM | @ DSM 6.2.2 - 24922-U6 (Backup DS)
    2x Western Digital Red WD100EFAX @ Basis, ext4
    Backup: 3x ext. HDDs USB 3.0 @ GPT / NTFS + ext4
    Backup: Dockingstation Inateck FD1003 USB 3.0 @ ext4
    USV: APC Back-Ups Pro 1500
    usbshare Nummern frei definieren: <Anleitung klick>

  7. #7
    Anwender Avatar von Puppetmaster
    Registriert seit
    03.02.2012
    Beiträge
    17.016

    Standard

    Aber das erklärt doch nicht, warum sich ein Benutzer 3x nicht anmelden kann und beim vierten Mal dann doch.
    Die Berechtigung wird sich ja nicht spontan ändern.
    DS415+ DSM 6.2.1-23824 U1 | 2x2TB BTRFS RAID1 + 8TB EXT4 (Basis) WD Red 24/7
    DS214+ DSM 6.2.1-23824 U1 | 3TB WD Red (Basis) + 6TB Seagate Archive (Basis)
    Media Logitech Media-Server 7.7.2 | Squeezebox Classic | Squeezebox Transporter | VU+ Uno | Raspberry Pi - OpenELEC 6.0.1 Kodi v15
    USV APC Back-UPS RS550GI


    Reset einer DiskStation | Migration zwischen DiskStations | Festplattenzugriff mittels Knoppix-DVD

  8. #8

    Standard

    Das kann ich leider nicht beantworten, ich kann nur Vermuten das es eventuell "Laufzeitfehler" oder was auch immer sind. So erhalte ich sporadisch von meiner handy APP DS Photo unmittelbar nach dem Aufruf der App den Hinweistext "Albendaten konnten nicht geladen werden, versuchen sie es später noch einmal". Obwohl ich alle Alben korrek sehe, alle Bilder sehen kann usw. Das taucht aber nur sporadisch auf und ich konnte keine Regelmässigkeit dabei beobachten.
    Aber die Fehlermeldung erscheint, obwohl sie "falsch" ist, daher meine Vermutung das es irgendwo "hängt".
    Wenn ich es schaffe und es wieder mal da ist versuche ich einen screenshot davon zu machen.
    Synology DS 916+ | 8 GB RAM | @ DSM 6.2.2 - 24922-U6
    1x Western Digital Red WD60EFRX @ SHR, ext4
    3x Western Digital Red WD100EFAX @ SHR, ext4
    Synology DS 218+ | 16 GB (8+8) RAM | @ DSM 6.2.2 - 24922-U6 (Backup DS)
    2x Western Digital Red WD100EFAX @ Basis, ext4
    Backup: 3x ext. HDDs USB 3.0 @ GPT / NTFS + ext4
    Backup: Dockingstation Inateck FD1003 USB 3.0 @ ext4
    USV: APC Back-Ups Pro 1500
    usbshare Nummern frei definieren: <Anleitung klick>

  9. #9

    Standard

    Moin!

    Ich konnte die Frage nach dem verwendeten Konto nicht 100%ig beantworten, da ich momentan keinen direkten Zugriff auf die DS habe. Das wird aber heute Abend der Fall sein, und dann kann ich das definitiv beantworten.

    Aber trotzdem: Damit kann es doch eigentlich nicht wirklich zusammen hängen, denn wie ich schrieb, erscheint die Fehlermeldung, ich werde aus dem Album rausgeschmissen (bzw. komme gar nicht erst drauf), und Sekunden später, nach einem oder mehreren weiteren Versuchen, kann ich plötzlich zugreifen.

    Die Ursache, dass ich temporär nicht zugreifen kann, kann also eigentlich nicht wirklich an fehlenden Rechten liegen. Sonst könnte ich ja gar nicht zugreifen.

    Aber irgendeinen Grund muss es ja geben.

    Viele Grüße,

    Björn

  10. #10
    Anwender
    Registriert seit
    11.06.2017
    Beiträge
    831

    Standard

    Ich habe das gleiche Verhalten auf meinen Android Geräten und vermute einen Fehler in DS Photo.
    Die App meint ich bin noch angemeldet, ich gehe Ordner rein und dann kommt er drauf, dass ich irgendwie doch nicht angemeldet war. Dann schmeißt er mich zurück, meldet mich an und es klappt.

    Denke es hängt damit zusammen, dass ich mich manchmal mit lokaler IP anmelde (192.xx) und manchmal mit VPN (10.xx).
    RT2600AC, DS416play (3x 3TB WD Reds, SHR1)

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Rechte-Problem
    Von Jabberwacky im Forum Terminal-Dienste (Telnet, SSH) - Linux-Konsole
    Antworten: 7
    Letzter Beitrag: 19.09.2018, 22:57
  2. Minidlna Rechte Problem
    Von Foxen im Forum Andere 3rd Party Anwendungen
    Antworten: 1
    Letzter Beitrag: 07.11.2014, 14:10
  3. Antworten: 7
    Letzter Beitrag: 27.08.2014, 18:03
  4. Rechte Probleme obwohl ich Admin bin / Festplatten-Ruhezustand
    Von md_1972 im Forum Terminal-Dienste (Telnet, SSH) - Linux-Konsole
    Antworten: 3
    Letzter Beitrag: 03.12.2013, 16:26
  5. Rechte-Problem beim Verschieben
    Von ChristianW im Forum Benutzer, Gruppen, gemeinsame Ordner
    Antworten: 4
    Letzter Beitrag: 07.11.2010, 11:32

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •