Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16
  1. #1
    Anwender
    Registriert seit
    24.11.2014
    Beiträge
    195

    Standard wget Version updaten

    Hallo zusammen,
    nach langer Zeit komm ich mal wieder dazu mich etwas mit meiner Synology zu beschäftigen und komme bei einem Thema gleich schon nicht weiter.
    Ich habe eine DS214play mit DSM5.2 (Update 9) am Laufen und die (systemeigene) Version von WGET ist 1.15.

    Gibt es denn eine Möglichkeit die Version von WGET zu updaten?

    Geht das nur über IPKG oder kann man die systemeigenen Versionen auch updaten? Bei IPKG muss ich mich sonst erst nochmal einlesen, weil das alles weng her ist und ich im Hinterkopf habe, dass das nicht immer ohne Risiko ist..

    Das Update hätte ich gerne, weil die neueren WGET Versionen auch ftps unterstützen und ich einen entfernten USB-Stick, welcher an nem Router hängt auf meine DS sichern möchte.
    Eine verschlüsselte Verbindung wäre mir dabei am liebsten.

    Vielen Dank schonmal für den ein oder anderen Hinweis und Tip!

    Grüßle

    Johannes
    DS214play | 1x WD20EFRX + 1x WD40EFRX (Basis) | DSM 5.2 | TP-Link WDR4300 (DD-WRT) | KD-Modem Hitron CVE30360 (bridge) | RaspberryPi2 (Openelec/Kodi, TVHeadend) | Raumfeld (Expand, Cubes, C², OneS)

  2. #2
    Anwender
    Registriert seit
    06.04.2013
    Beiträge
    9.936

    Standard

    DSM 6.2.2 hat wget 1.20.1 auf der DS415+ mit Kernel 3.10-105.
    Das gibt es nicht separat als Paket oder ähnliches.

    Andere Wege via ipkg/opkg oder Docker oder ähnlich.
    Scripten musst dann eh, weil die "eingebaute" Software normal auch nur auf die eingebauten Versionen zugreift.
    Synology Tech Support | Feature request
    Site 0: DS1812+ 3GB 6.2.2-U4 | 2*3/6*6TB WD Red (SHR-1 + Basic) | DS415+ 8GB 6.2.2-U4 | je 2*10TB Ironwolf/WD Red (Basic)
    Site 1/2/3: DS216+II 8/8/1GB 6.2.2-U4 | 2*3/4/3TB WD Red (SHR1)
    USV APC BK650EI | UPS Pro 900 | Net UMBW 400/40 | FB 6490 (IPv4/v6 Dual-Stack) | Unifi US-8/16 PoE
    Streaming NUC Plex (1.16.4 (hw)) | AFTV (Plex/Kodi 17.6) | Inverto Sat>IP IDL400s, TVMosaic tv server | Raumfeld (C2, M, One), CCA Multi-Room | KDL-55W905A

  3. #3
    Anwender
    Registriert seit
    24.11.2014
    Beiträge
    195

    Standard

    Danke Fusion,

    hmmm fürs DSM-Update bin ich glaub ich noch nicht bereit... brauch dafür erstmal wieder weng Muse durchzugehen ob auch alle Pakete in Zukunft funktionieren würden...

    Habe IPKG jetzt mal installiert und versucht eine aktuelle WGET-Version zu bekommen... Allerdings lädt er mir nur die bereits exisiterende 1.12 runter... (1.15 in meinem ersten Post war glaub ich falsch...)

    Kriegt man IPKG iwie dazu hier eine aktuellere Version zu verwenden, oder kanns sein, dass es für meine DS gar keine neuere gibt?

    Gäbs ansonsten einen Vorschlag wie ich am besten Daten per FTPS (explicit, also Port 21) auf die DS ziehen kann?

    Merci schonmal
    Johannes
    DS214play | 1x WD20EFRX + 1x WD40EFRX (Basis) | DSM 5.2 | TP-Link WDR4300 (DD-WRT) | KD-Modem Hitron CVE30360 (bridge) | RaspberryPi2 (Openelec/Kodi, TVHeadend) | Raumfeld (Expand, Cubes, C², OneS)

  4. #4
    Anwender
    Registriert seit
    08.09.2013
    Beiträge
    74

    Standard

    Soweit ich weiss kann curl auch ftps und ist glaube ich sogar standardmässig im DSM mit dabei.

  5. #5
    Anwender Avatar von Tommes
    Registriert seit
    26.10.2009
    Beiträge
    7.600

    Standard

    Ich meine, das IPKG nicht wirklich aktuell ist, weshalb ich hier bei mir OPKG verwende. Am einfachsten richtest du das über den Easy Bootstrap Installer ein. Ich erhalte dadurch die wget Version 1.20.3

    Tommes

    DS218+ | 2x WD Red 3TB Basis (btrfs) | 2 + 8 GB RAM
    DS216+ | 1x WD Red 4TB Basis (btrfs) | 4 GB RAM
    DS115 | WD Green 4TB (ext4) | 512 MB RAM
    Raspberry Pi 4B | Transcent 16 GB | 4 GB RAM | Pi-Hole, OpenVPN

  6. #6
    Anwender
    Registriert seit
    11.06.2017
    Beiträge
    775

    Standard

    Wenn du IPKG bereits am Laufen hast, sieh dir mal lftp an. Damit sollte es auch klappen!

    Hier noch die man page.
    RT2600AC, DS416play (3x 3TB WD Reds, SHR1)

  7. #7
    Anwender
    Registriert seit
    25.04.2018
    Beiträge
    57

    Standard

    lftp sollte auch ohne IPKG vorhanden sein

  8. #8
    Anwender
    Registriert seit
    11.06.2017
    Beiträge
    775

    Standard

    Danke für den Hinweis...
    Kann natürlich gut sein, dass es bei alten DSM noch nicht dabei war. Jetzt scheint DSM mit lftp Version 4.7.x ausgeliefert sein.
    RT2600AC, DS416play (3x 3TB WD Reds, SHR1)

  9. #9

    Standard

    Zitat Zitat von Tommes Beitrag anzeigen
    ...Ich meine, das IPKG nicht wirklich aktuell ist, weshalb ich hier bei mir OPKG verwende. Am einfachsten richtest du das über den Easy Bootstrap Installer ein...
    <OT>
    Hm ... ich habe bei mir iPKG installiert und verschiedene nuetzliche Linux Tools nachinstalliert. Kann ich OPKG zusammen mit iPKG benutzen oder muesste ich erst alles mit iPKG installierte erst wieder loeschen und dann wieder mit OPKG installieren - sofern ich fuer einen Wechsel entscheide?
    </OT>

  10. #10
    Anwender
    Registriert seit
    06.04.2013
    Beiträge
    9.936

    Standard

    @tommes - danke der Erinnerung. Hab natürlich auch opkg installiert.
    DSM 6.2.2 auf der DS415+ liefert 1.19.1, opkg 1.20.3 wie du geschrieben hattest.

    @framp, easy bootstrap installer kann glaube nur entweder oder. Liegt ja alles unter /opt/bin nachher. Sagt er glaube auch, wenn er etwas antrifft und fragt wie er damit verfahren soll.
    Von Hand musste ich glaube nichts löschen damals.
    Synology Tech Support | Feature request
    Site 0: DS1812+ 3GB 6.2.2-U4 | 2*3/6*6TB WD Red (SHR-1 + Basic) | DS415+ 8GB 6.2.2-U4 | je 2*10TB Ironwolf/WD Red (Basic)
    Site 1/2/3: DS216+II 8/8/1GB 6.2.2-U4 | 2*3/4/3TB WD Red (SHR1)
    USV APC BK650EI | UPS Pro 900 | Net UMBW 400/40 | FB 6490 (IPv4/v6 Dual-Stack) | Unifi US-8/16 PoE
    Streaming NUC Plex (1.16.4 (hw)) | AFTV (Plex/Kodi 17.6) | Inverto Sat>IP IDL400s, TVMosaic tv server | Raumfeld (C2, M, One), CCA Multi-Room | KDL-55W905A

Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Joomla - Version updaten auf 3.4.6
    Von bernd_ im Forum Sonstiges
    Antworten: 5
    Letzter Beitrag: 28.12.2015, 02:09
  2. Wie aktuelle PHP Version updaten - installieren
    Von ITfisi im Forum Webserver
    Antworten: 0
    Letzter Beitrag: 13.06.2015, 12:27
  3. Antworten: 27
    Letzter Beitrag: 26.04.2013, 12:42
  4. iconv Version von PHP im Webserver updaten?
    Von HarryMe im Forum Webserver
    Antworten: 0
    Letzter Beitrag: 19.07.2012, 04:21
  5. [Frage] - wget versus IPKG wget & wget-ssl
    Von Binomico im Forum IPKG
    Antworten: 12
    Letzter Beitrag: 12.11.2011, 20:04

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •