Ergebnis 1 bis 4 von 4
  1. #1

    Standard DS415PLAY - Fehlerhaftes Raid5 läßt sich mit Austauschdisk nicht reparieren

    Hallo liebe Community,

    ich habe hier ein großes Problem. Folgende Sitation:

    Am Wochende machte sich meine DS415Play (1 Volume, vier identische Disks WD Red 3TB) durch lautes Piepen auf sich aufmerksam, die Status Anteige blinkte gelb.

    Beim Login in die DSM Web Gui wurde ein Fehler "An i/o error occured on drive 3" angezeigt.

    Der Speicherpool zeigte "Fehlerhaft" an und unter SSD/HDD wurde für die Disk 3 "schwer fehlerhaft" angezeigt.

    Siehe hierzu auch beigefügte Screenshots.

    So weit so gut, so weit so schlecht. Jetzt komme ich zu den eigentlichen Problemen:

    1. Trotz wöchentlicher SMART-Tests (einfach) und monatlicher SMART-Tests (erweitert) auf allen Disks, trotz funktionierender Emailbenachrichtigung bei Fehlern hierzu, erschien die erste Meldung zu einem DIskproblem erst mit dem Login an der GSM GUI am vergangenen Smastag. Ein Blick in die detaillierten SMART-Logs zeigte jedoch, dass eben genau dieser i/o Fehler und Meldungen wie "Drive 3 failing" erstmals am 03.08.2019 detektiert, und seither hundertfach und allwöchentlich detektiert wurde! Großes Staunen, großes Entsetzen und deshalb die Frage: WESHALB BEKOMME ICH ERST AM 04.01.2020 AUFGRUND EINER AKUSTISCHEN WARNUNG DIESEN FEHLER ANGEZEIGT. Zwischenzeitlich wurden sogar noch DSM Updates eingespielt, ohne das der oder die Fehler in irgendeiner Form gemeldet wurden, sie sind einzig in den detaillierten Logs der SMART-Test aufgelistet, jedoch nicht in der Systemübersicht oder an anderer Stelle, wo ich es bei solch schweren Fehlern erwarten würde.

    2. Ich habe mir heute eine identische Austauschdisk gekauft, selber Hersteller, selber Typ, selbe Größe, aber egal was ich versuche, das Raid 5 lässt sich nicht reparieren.

    Hot-Swap (Disk tauschen) und "Reparieren" führte zu einem "Reparieren fehlgeschlagen" mit nachfolgendem Volume-Crash und es wurden nur noch zwei der vier DIsk erkannt. Der erneute EInbau der defekten DIsk stellte glücklicherweise den ursprünglichen Zustand wieder her: "Speicherpool fehlerhaft", es werden vier Disks erkannt, eine davon "Fehlerhaft". Ich habe dann die neu gekaufte DIsk bei ausgeschaltetem SYstem eingebaut und die DS415PLAY anschließend hochgefahren, mit dem Problem, dass nun der Speicherpool wieder als "abgestürzt" angezeigt wurde, allerdings war die Reparieren-Option nicht mehr verfügbar.

    Lange Rede, kurzer SInn: Was kann ich in dieser Situation jetzt noch machen, um das Volume b zw. dem Speicherpool mit der neuen Austauschdisk wieder in einen ordnungsgemäßen "Normal"-Zustand zu bekommen?

    Merkwürdig erscheint mir auch der aktuelle Zustand von Disk 4 "initialisiert", denn der war früher - soweit ich mich erinnern kann - ebenfalls "Normal".

    Ach ja, noch ist das Raid5 funktional (d.h. ich kann Dateien auf dem fehlerhaften Volume lesen/schreiben) und auch ein Backup ist vorhanden.



    Vielen Dank für eure Unterstützung!
    Angehängte Grafiken Angehängte Grafiken
    Geändert von NoNameUser (06.01.2020 um 20:12 Uhr)

  2. #2

    Standard

    Bevor Spekulationen zum aktuellen Systemzustand aufkommen: Ich habe die Disk 3 ausgetauscht. Die Disk 1+2+4 habe ich nicht angefasst.
    Geändert von NoNameUser (06.01.2020 um 20:10 Uhr)

  3. #3
    Anwender
    Registriert seit
    22.12.2017
    Beiträge
    1.219

    Standard

    Disk 4 wird im RAID nicht verwendet. Wenn das früher anders war, so ist die aus dem RAID geflogen, und du hast jetzt keine Redundanz mehr. Was fatal ist, denn jetzt ist auch noch eine der verbleibenden Platten defekt. Um die unbenutzte Platte wieder ins RAID zu integrieren, muss das erst repariert werden, was wiederum nicht geht, weil du die fehlerhafte Platte wegen fehlender Redundanz nicht mehr tauschen kannst.

  4. #4

    Standard

    Der Raid-Fehler war irreparabel, die noch vorhandenen Daten nicht mehr vollständig. Das sollte jedem eine Warnung sein, denn für ein Last-minute Backup wäre es in dieser Situation definitiv zu spät gewesen. Ich habe zwei neue Disks kaufen müssen, habe das NAS komplett neu aufsetzten und die Daten über ein vorhandenes Backup recovern müssen. Seit heute ist das "neue" NAS nun wieder online. Fazit: Ein Raid ersetzt niemals ein Backup!

Ähnliche Themen

  1. Reparaturfunktion der DS415Play / Fehlerhaftes Volume
    Von Nils365 im Forum Raid Konfiguration
    Antworten: 7
    Letzter Beitrag: 15.10.2018, 22:04
  2. Ordner läßt sich nicht synchronisieren mit ds215j Fehlermeldung
    Von hans mustermann im Forum Disk Station Manager
    Antworten: 1
    Letzter Beitrag: 07.09.2015, 00:20
  3. Antworten: 3
    Letzter Beitrag: 15.02.2013, 17:47
  4. DS209j mit Raid1 läßt sich nicht mehr ansprechen
    Von crazywilli im Forum Datenrettung
    Antworten: 0
    Letzter Beitrag: 11.10.2010, 22:25
  5. raid5 reparieren mit mdadm schlägt fehl
    Von pleemann im Forum Datenrettung
    Antworten: 16
    Letzter Beitrag: 15.10.2008, 17:43

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •