Ich habe das Thema in das Forum "Sonstiges" begonnen, da es kein Synology Phänomen ist, sondern ausschließlich das derzeit neue windows 10 mit Funktionsupdate 1909 betrifft.
All jene von euch welche die gewohnte win Explorer Suche nicht mehr verwenden können bei verbundenen Netzlaufwerken von einer DS können dieses Problem selber beheben.
Auch ich war davon betroffen.
Früher konnte ich problemlos rechts oben im windows Explorer einen beliebigen Suchbegriff eintippen und mein Netzlaufwerk (gemeinsamer Ordner auf der DS) wurde komplett durchsucht nach diesem Begriff und ich habe bisher immer eine "Trefferliste" erhalten, der win PC hat also bei Bedarf die DS "durchsucht" nach diesen Begriff.
Mein Problem nach dem win10-1909 Update war nun, dass ich keine Eingabe durchführen konnte im win Explorer rechts oben in das Eingabefeld, da war zwar wie üblich die "Suchlupe" zu sehen, aber ich konnte den Suchbegriff nicht eintippen, ebenso hat mir der blaue "Pfeil nach rechts" gefehlt um die Suche überhaupt zu starten.
Abhilfe bringt in Windows DIENSTE (Lokal) die Zeile "Windows Search" zu markieren und oben in der Menüzeile auf das Icon für "Startet den Dienst neu" anzuklicken:

win10_1909_suche_geht_nicht1.jpg

Der Windows Search Dienst startet daraufhin neu, anschließend den PC unbedingt neu starten!
Jetzt wieder in den windows explorer wechseln, eine Eingabe in das Suchfeld ist jetzt wieder möglich, Suchbegriff eingeben und der blaue Pfeil nach rechts ist auch wieder da:

win10_1909_suche_geht_nicht2.jpg

Ebenso erscheint das Register "Suchen" wieder ganz oben in der win Explorerleiste. Der windows Suchdienst kann jetzt wieder nach Begriffen suchen, so wie es früher schon immer möglich war.
Also all jene von euch, die ebenfalls keine Texteingabe in das Suchfeld vornehmen können, bitte den windows search Dienst wie oben erklärt nochmal neu starten und PC ebenfalls neu starten.