Ergebnis 1 bis 3 von 3
  1. #1

    Standard Moodle und PHP 7.2

    Hallo,
    ich benötige das aktuelle Moodle 3.7, daher muss ich das Synology Paket (Moodle 3.4) manuell updaten.
    Während Moodle 3.4 noch PHP 7.0 braucht, benötigt Moodle 3.7 PHP 7.2.
    So weit, so gut.

    Ich habe PHP 7.2 installiert, aber Moodle findet dennoch nur PHP 7.0.

    Was muss ich tun, um Moodle klar zu machen, dass durchaus PHP 7.2 installiert ist und Bitteschön verwendet werden soll?

    Ich verzweifle....Help!

  2. #2
    Anwender Avatar von Frogman
    Registriert seit
    01.09.2012
    Beiträge
    17.463

    Standard

    So als erstes würde mir einfallen, mal in die Konfig-Files von Moodle hineinzuschauen, inwieweit dort ein PHP-Pfad definiert ist...
    DS713+ | 2x 1TB Crucial M500 SSD # 4GB RAM # be quiet! Shadow Wings | DSM 6.1.7-15284-U3
    DS212+ | Backup-DS: 2x 4TB HGST Deskstar NAS | DSM 6.1.7-15284-U3
    Extras: fail2ban 0.11.0 - Java 1.8.0.212 - Nextcloud 16.0.3 - Roundcube 1.3.8 - HumHub 1.3.14 - tt-rss 19.02
    Synology-Support-Portal | DSM-Hilfe online | Synology-Tutorials
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung. (Albert Einstein)

  3. #3

    Standard

    Ich habe mittlerweile kapituliert.
    Während die Installation von Moodle 3.4 noch über die Paketverwaltung reibungslos klappt, scheint 3.7 nicht zu funktionieren.
    Nachdem ich es mit viel Trickserei geschafft habe Moodle davon zu überzeugen, die richtige PHP - Version zu nehmen, konnte ich die Dateien von moodle.org installieren.

    Leider ist zum einen das Style "zerschossen", d.h. ich sehe nur eine Textseite ohne die grafischen Elemente, zum anderen reagiert die Seite nicht auf meinen Klick auf den Link, der das Adminpasswort ändern soll. Und ohne die Änderung komme ich nicht weiter.
    Auch eine Neuinstallation hat hier keine Hilfe gebracht.

    Daher habe ich jetzt aufgegeben.

Ähnliche Themen

  1. Verschiedene PHP Installationen und Configs - Fehlende PHP Extensions
    Von phill54 im Forum Terminal-Dienste (Telnet, SSH) - Linux-Konsole
    Antworten: 4
    Letzter Beitrag: 29.05.2018, 21:44
  2. MariaDB 10 und Moodle
    Von tgusenda im Forum Sonstiges
    Antworten: 20
    Letzter Beitrag: 29.06.2017, 22:47
  3. Antworten: 1
    Letzter Beitrag: 18.12.2014, 14:41
  4. moodle und Schule
    Von DeeKey im Forum Kaufberatung - Fragen vor dem Kauf
    Antworten: 7
    Letzter Beitrag: 21.07.2012, 16:27
  5. DS211+ als Webserver für Joomla und Moodle?
    Von Zimmi im Forum Kaufberatung - Fragen vor dem Kauf
    Antworten: 2
    Letzter Beitrag: 05.05.2011, 06:43

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •