PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Zugriff auf DS über´s Internet



dietsmoke
19.12.2009, 18:53
Hallo zusammen,

bin neu hier und versuche mich gerade daran, meine DS über´s Internet zu erreichen, aber irgendwie scheint das nicht zu funktionieren.

Folgendes Szenario:

>> Alice Wlan Router 1121
>> Account bei dyndns eingerichtet und Daten in der DS hinterlegt; Status = normal
>> Ports (21, 80, 5000, 5001, 7001 - alle TCP) im Router auf die DS weitergeleitet
>> Aktualisierung mein IP funktioniert problemlos (kann ich auf dyndns. org in meinem Account sehen)
>> intern komme ich über die dyndns Adresse auf das Interface meines Routers, aber nicht auf die DS
>> von extern bekommeich einen Timeout
>> wenn ich meine dyndns Adresse pinge, sehe ich die richtige IP, bekomme aber auch eine Zeitüberschreitung
>> https in der DS aktiviert

Bin irgendwie mit meinem Latein am Ende. Hart jemand von euch eine Idee woran es liegen könnte? Welche einstellungen muss ich noch vornehmen, oder wie genau muss ich meine DS im Browser ansprechen? Will den Manager, Photo- und Filestation nutzen....

vielen Dank :)

steffi
19.12.2009, 19:07
hallo

für den anfang versuche mal "deine-dyndnsadresse:5000" oder halt einfach nur "deine-dyndnsadresse" (immer ohne "")

manche router lassen einen zugriff auf die webadresse aus dem eigenen netz (lan) nicht zu....(ich glaube, die von alice gehören auch dazu)

dann kannst du es nur testen, wenn du wirklich von aussen auf die ds zugreifst.

Matthieu
19.12.2009, 19:09
Das Webinterface des Routers schiebt sich gerne mal dazwischen. Schau bitte im Handbuch oder in der Hilfe oder sonstwo nach, wie man das Interface davon abhalten kann bei einem externen Zugriff zu antworten.

Wenn du eine Anfrage auf Port 80 absendest (also ohne : hinten an der Adresse für einen speziellen Port), dann stelle bitte sicher das die WebStation aktiviert ist und eine entsprechende kleine Internetseite antwortet. Normalerweise würde die DS sonst auf Port 5000 weiterleiten, was von extern meist zu Problemen führt.

MfG Matthieu

dietsmoke
19.12.2009, 19:17
Hallo und Danke für die schnellen Antworten.

Ich versuche parallel über einen anderen Rechner, der per UMTS Stick im Netzt ist von "aussen" auf meine DS zuzugreifen. Leider geht weder deine-dyndnsadresse:5000 noch deine-dyndnsadresse.

Wie gesagt, von aussen, bekomme ich gar keinen Zugriff und innerhalb des eigenen Netztes nur den Zugriff auf den Router. Ich wäre ja schon froh, wenn ich von aussen nur den Router sehen könnte ;)

Ich muss zugeben, ich bin irgendwie ratlos?!

Danke euch :)

Matthieu
19.12.2009, 19:20
Versuch mal dich über die externe IP zu erreichen die DynDNS.com angibt. Dann wissen wir, ob DDNS nicht läuft, oder obs am Router oder am ISP liegt.

MfG Matthieu

dietsmoke
19.12.2009, 19:28
Das hatte ich auch schon versucht - ging aber leider nicht...


ABER: Ich glaube ich habe die Lösung. Habe zusätzlich den externen Port 443 auf intern 5001 weitergeleitet. Dafür Port 5000 (HTTP) rausgeschmissen.

Jetzt geht es- warum weiß ich auch nicht.

Kann jetzt nur über "https://deine-dyndnsadresse" auf meinen Disk Station Manager zugreifen. Gehe ich Recht in der Annahme, dass dieser Zugriff sicher ist und dass ich mit den offenen Ports 21,80,5001 und 7001 keine unnötigen Gefahren eingehe?

Danke für den super und vor allem sehr schnellen Support hier!

Matthieu
19.12.2009, 19:38
Die Ports sind keine zu großen Sicherheitsrisiken.
Falls du dich damit noch ein wenig genauer beschäftigen willst, kann ich unsere Port-Tabelle mit Sicherheitseinstufung empfehlen:
http://www.synology-wiki.de/index.php/Zugriff_auf_die_Synology-Dienste_%C3%BCber_Internet#Liste_der_verwendeten_P orts

Einen letzten Schritt würde ich noch dringend empfehlen: Aktiviere die "Automatische Blockierung" um Brute-Force-Attacken zu verhindern.

MfG Matthieu

dietsmoke
19.12.2009, 19:39
...eine Frage noch - wie kann ich denn gefwährleisten, dass die Phot Station auch über https läuft? Wenn ich nur private Alben habe, möchte ich ja auch, dass die Passwortübertragung einigermassen sicher ist.

per https://deine-dyndnsadresse/photo ist der Dienst nämlich nicht erreichbar. Nur über http://

soo viele Fragen..?!?

dietsmoke
19.12.2009, 19:57
Danke Matthieu - an dieser Liste habe ich mich orientiert.

Die automatische Blockierung ist nun auch aktiv und ich werde mich direkt weiter mit meiner DS beschäftigen.

vielen Dank erstmal.

Matthieu
19.12.2009, 20:04
Und jetzt wirds spannend. Ein Port lässt sich immer nur für einen Dienst verwenden. Das heißt wenn du den "offiziellen" https-Port 443 auf den DSM umleitest ist kein Zugriff mehr auf normale Dienste über https möglich. Zwar gibt es noch Virtual Hosts und so ein paar andere Sachen, aber das ist nicht ganz ohne in Planung, Konfiguration und Wartung ...

MfG Matthieu

dietsmoke
19.12.2009, 20:23
??? ok - jetzt stehe ich völlig auf dem Schlauch. Was meinst du mit normalen Diensten auf die ich dann keinen Zugriff mehr habe?

Habe Testweise mal die Portweiterleitung von 443 auf 5001 rausgenommen - und schwupps geht nichts mehr... Wie könnte ich denn sonst den ZUgriff gewährleisten?

mfg*holger

Matthieu
19.12.2009, 21:29
Auf einer DS arbeiten zwei Webserver.
Das ganze aus Sicherheitsgründen. Während die Admin-Oberfläche alias DSM vollen Zugriff auf das System benötigt und daher unter dem "Super-admin" root laufen muss, wäre dies bei der WebStation, PhotoStation etc. ein großes Risiko. Diese Dienst laufen daher unter einem anderen Webserver der dem Benutzer "niemand" (engl. nobody) zugeordnet ist.

Die Standardports für eine HTTP-Verbindung sind 80 und 443 (verschlüsselt, https). Pro Port kann aber immer nur ein Server antworten. Wenn du daher alle Anfragen an 443, die eigentlich an den "niemand-Server" gehen würden, umlenkst auf 5001, also den root-Webserver, kannst du 443 nicht mehr für "niemand" nutzen.

MfG Matthieu

spacefrog
12.01.2010, 19:46
Hallo zusammen,
habe seit einiger Zeit die ds209+II, habe dies auch einige Zeit über das iNet erreichen können, wie folgt:
bei dyndns ein account, dort die aktuelle IP übernommen.
in der fritz box 7270 die dyndns Funktion aktiviert, dort xxx.selfip.com/photo eingetragen.
die Prots 80 auf 80 UND 5001 auf 443 freigegeben.
in der ds die dyndns funktion deaktiviert.
soweit so gut lief auch ein paar Tage die IP hatte sich auch immer wieder neu eingetragen, nun aber nicht mehr und ich weiß nicht mehr weiter,,,,HILFE:confused:

goetz
12.01.2010, 20:37
Hallo,
schau mal bei Deinem Konto bei dyndns vorbei ob da was bemängelt wird. Du hast auf der Fritzbox und auf der DS dyndns aktiviert, es darf aber nur ein Gerät die Änderung melden, laß es die Fritzbox machen, die merkt es am ehesten.

Gruß Götz

spacefrog
12.01.2010, 20:51
Hallo,
erstmal danke für die Antwort,
habe nur in der Fritzs box dyndns aktiviert, in der ds DEAKTIVIERT.
habe gerade mein account überprüft, da wird nix bemängelt, jedenfalls so wie ich das sehe, ist halt nur die alte IP von gestern noch drin.
MfG

spacefrog
13.01.2010, 15:42
Hallo nochmal,
habe heute mein Zugang und die automatische Aktuallisierung hinbekommen.
HAbe in der FRitzsbox den Link für dyndns geändert und zwar die Erweiterung
/photo entfernt, nun läuft das, auch komme ich auf die Photo Station, kann mir jemand sagen wieso das so ist:confused:

king_dingeling
13.01.2010, 15:56
Hallo nochmal,
habe heute mein Zugang und die automatische Aktuallisierung hinbekommen.
HAbe in der FRitzsbox den Link für dyndns geändert und zwar die Erweiterung
/photo entfernt, nun läuft das, auch komme ich auf die Photo Station, kann mir jemand sagen wieso das so ist:confused:

Im Router stellst du deinen hostnamen ein. /photo ist ja nur ein verweis auf einen Unterordner deines Hostnamens

spacefrog
13.01.2010, 17:44
Das verstehe ich schon mit den Unterordnern, in nverschiedenen Beiträgen steht aber, wenn man die Photo Station anwählen will muss das mit /photo hinder dem dyndns Namen Stehen,xxx.selfip.com/photo da sonst und so war es auch bei mir immer nur die Meldung kommt, dass die Seite nicht angezeigt werden kann. JEtzt komme ich auch ohne /photo hinter dem dyndns NAmen auf die Photo Station und das verwundert mich.

:eek:

jahlives
13.01.2010, 19:53
Hast du eine .htaccess mit mod_rewrite im Document Root oder einen vhost für die Mailstation eingerichtet? Beides könnte dafür sorgen, dass es ohne /photo klappt. Oder hast du den DocumentRoot in der Hauptkonfig auf das Verzeichnis der Photstation umgebogen? Funzt es denn auch wenn du https://xxx.dyndns.tld aufrufst? Landest du dann auch auf der Photostation?

spacefrog
14.01.2010, 16:28
Daich mich mit dieser Angelgenheit erst vertraut machen muss bin ich jetzt etwas überfahren von diesen Fragen. Um ehrlich zu sein verstehe ich nur Bahnhof. Habe im grunde keine veränderungen vorgenommen, nur ganz einfach den vorgegebenen weg. WÜrde mich gern intensiver damit beschäftigen, dazu werde ich wohl vorab noch viel lesen müssen.

rstle
15.01.2010, 16:08
Mit diesen Freigaben (Fritzbox) läuft Photo, FTP, und Fileserver über https. :)

Also alle Ports 1 zu 1 weitergeleitet.
Habe allerdings festgestellt, daß bei Umleitungen von z.B. 7001 auf 80 Probleme auftreten.
Da hilft dann nur in der Firma nachfragen, welche Ports freigegeben sind und dann austesten.

Port 80 nutze ich für eine Webcam. Port 5000/5001 habe ich nicht freigegeben, weil ich keinen Zugriff auf das System will.
Einstellungen im DS siehe Bild unten.

In der Fritzbox habe ich einen Selfhost dyndns und im DS einen von dyndns.org eingerichtet.
Laufen beide völlig problemlos und gleichzeitig.

Aufruf https:// abcxyz.dyndsnsadresse/photo für Photo
bzw. https:// abcxyz.dyndsnsadresse:7001 für Fileserver

Filezilla: FTPES FTP über explizites TLS/SSL und Transfermodus Standard

crunkmunk
03.06.2010, 09:35
Also ich komm mit meiner DS 210j im Moment gar nicht klar...

habe auch einen router von Alice (Wlan 1121) und bei mir geht gar nichts!
habe soweit ich konnte alle Einstellungen, wie hier beschrieben übernommen.
1. bei dyndns.org einen account erstellt.
2. die Adresse in der DS eingestellt, und nur dort.
3. webstation aktiviert, filestation aktiviert, https: aktiviert.
4. die ports im router freigegeben, 443 an 5001/7001 an 7001/ 21 an 21/

geht aber alles nicht, bin echt am verzweifeln. über die DynDns adresse komme ich nicht drauf und über die IP selbst auch keine Antwort.

weiß echt nicht mehr weiter:confused:

tmfkab
05.06.2010, 10:13
dann nimm mal die dyndns einstellungen aus der DS wieder raus und stell das im router ein.
meiner meinung nach kann deine ds hinter nem router nur die interne ip weiterleiten,
da die ip der ds ja immer die gleiche ist, der router bekommt aber von extern immer wieder ne neue ip,
und das ist diejenige die an den dyndns dienst weitergeleitet werden muss

goetz
05.06.2010, 11:43
Hallo,
@crunkmunk
testest Du wirklich von außen? Viele Router können die Anfrage an die eigene externe Adresse nicht bearbeiten.

@tmfkab
Die DS kann sehr wohl die externe Adresse an dyndns senden. Alle 5min. fragt sie eine externe Website "mit welcher IP hab ich angefragt?" und das ist die externe IP des Routers (NAT).

Besser ist es aber den Router das machen zu lassen, er bekommt sofort mit wenn sich die IP geändert hat.

Gruß Götz

crunkmunk
05.06.2010, 12:53
Ja ich teste von außen, einmal von meiner Schule aus und zu Hause über ein anderes Wlan Netz aber bis jetzt hab ich es noch nicht hin bekommen. Werde die Tage mal die Einstellungen alle durch gehen und dann berichte ich nochmal. Aber danke schonmal für eure schnelle Hilfe, super Forum hier...:)

klarmacker
05.06.2010, 13:27
@crunkmunk
wenn du dich selber anpingst?

oder mal die ports alle wieder raus nimmst? kommst du dann auf deinen router? hast du einen wan to lan block drin?