PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : HTTPS-Verbindung verstehen



mr. winterbottom
24.10.2008, 09:24
Moin,

ich bin mal gerade daran das HTTPS zu verstehen (oder eher nicht :confused:)

Ich habe nun mal im DS Manager unter "Webdienste > Optionen HTTP-Dienst" die Checkbox "HTTPS-Verbindung aktivieren" aktiviert.

Wenn ich jetzt am Browser "http://server:5000" eingebe komme ich ja immer noch ungesichert auf den DS Manager.

Wenn ich am Browser "http://server:5001" eingebe kommt nix. Ist ja auch logisch - zu mindest für mich. Da ja der Port 5001 ein https Port ist.

Wenn ich am Browser "https://server:5001" eingebe kommt die Wahrnung, das das Zerrtifikat unsicher sei. Da habe ich hier Forum gelesen das es sich um ein Synology Zertifikat handelt und Das diese "Fehlermeldung" normal sei. Das der user das Zertifikat ruhig laden könne.

Aber was mich irgendwie doch irritiert ist, das obwohl im DS Manager "HTTPS" aktiviert wurde ich trotzdem mit "http://server:5000" den DS MAnager bedienen kann. Müsste den nicht der Port 5000 automatisch nicht mehr ereichbar sein??.
Denn was bringt es mir wenn jeder "Dödel" zb von aussen mittels DynDNS auf meine DS zugreifen kann.

Oder habe ich hier was falsch verstanden???
Bringt mich bitte auf den richtigen Weg :cool::rolleyes:;)

mr. winterbottom

Lion1984
24.10.2008, 09:38
Hallo.

nur weil du https aktiviert hast, schaltest du ja den normalen HTTP Webservice nicht ab --> beide Seiten bleiben erreichbar (laufen ja durch den Syno Apache).


Wenn ich am Browser "http://server:5001" eingebe kommt nix. Ist ja auch logisch - zu mindest für mich. Da ja der Port 5001 ein https Port ist.
Naja :) Der Syno Apache horcht für https am Port 5001, der Standartport ist, glaub ich, 443. Es gibt keine "reinen" http oder https Ports, es kommt immer drauf an wie du den Apache einstellst bzw. auf welche Ports er horcht -> Der syno Apache horcht eben auf 5001. (ich z.B. habe mir das umgestellt, meiner horcht nicht mehr auf 5001).

Ich denke das was du suchst ist wohl "Die Internetverwaltung automatisch zu einem sicheren Kanal umleiten", dann kommst du nur per https drauf. bzw. wenn du ein router hast kannst du ja auch dort die Ports sperren, dann kommt auch keiner drauf.

mr. winterbottom
24.10.2008, 09:45
Also, muss ich wenn ich z.B. die Photostation nach aussen freigeben will den Port 5001 am Router freigeben. So den am DS Manager der Port 5001 geschaltet wurde.

mr. winterbottom

jahlives
24.10.2008, 11:25
Also, muss ich wenn ich z.B. die Photostation nach aussen freigeben will den Port 5001 am Router freigeben. So den am DS Manager der Port 5001 geschaltet wurde.

mr. winterbottom
Photostation nutzt afaik den User Apache und der läuft per Default auf Port 80. Wenn du nur https Verbindungen auf den DS-Manager zulassen willst, musst du die Portweiterleitung auf Port 5000 aus deinem Router schmeissen

Suth
14.01.2009, 14:08
Hi Leute,

ich habe genau das umgekehrte Problem ...

ich habe https aktiviert auf meiner DS207 ... so ... jetzt komm ich über überhaupt keinen port mehr über den browser drauf ... nur noch wenn ich zum beispiel unter "Ausführen" die die IP eingebe: "\\DS-IP"

ich kann also garnichts mehr managen ... über welchen port komm ich denn jetzt bitteschön noch drauf ??

ich habe schon alles probiert:

htt://IP
htt://IP:5000
htt://IP:5001
htt://IP:7000
htt://IP:7001

und das ganze mit https
und "https:IP:80"

und über ssh komm ich auch drauf ... gibts da vllt ne möglichkeit über ssh des https auszuschalten ?

eins geht doch noch ... mit http://Servername:5000/ kommt was ... aba leider steht da dann was vom webwasher und "Could not connect to Server"

rstle
14.01.2009, 16:58
Also wenn ich nicht ganz schief liege, nutzt Photostation von Haus aus Port 443.
Das habe ich im Router freigegeben und das wars für Photo - und nur Photo - mit https://dyndns/photo

veipaaa
14.01.2009, 18:39
Hmm,

für die Webstation und für die Photostation reicht eigentlich die Weiterleitung des Ports 80.

Der Aufruf lautet dann aber auch nur http://......dyndns.../photo

rstle
14.01.2009, 18:46
Es geht aber wohl um https. Port 80 = Scheunentor ;)
Für die Filestation noch 8081 https://dyndns:8081 und schon ist man halbwegs sicher und kommt nur auf Photo und FS. Also bleibt das komplette Anmeldefenster des DS versteckt. Muß man nicht machen, aber bringt schon ein wenig Sicherheit und ist problemlos eingerichtet. Wer natürlich unbedingt fernkonfigurieren will, muß die Türen weiter aufmachen :D

veipaaa
14.01.2009, 19:31
Moment,

wenn ich doch nur Port80 weiterleite, komme ich doch garnicht an die Konfiguration.
Verstehe ich da jetzt was falsch?

_TokTok_
14.01.2009, 21:20
Moment,

wenn ich doch nur Port80 weiterleite, komme ich doch garnicht an die Konfiguration.
Verstehe ich da jetzt was falsch?

Völlig richtig. DSM ist nur über Port 5000 erreichbar

Trolli
15.01.2009, 12:11
Also:

Standardmäßig ist die Synology Station zunächst mal ohne HTTPS konfiguriert:
http://Station -> Port 80 (HTTP) -> genutzt von Photo Station, Web Station
http://Station:5000 -> Port 5000 (HTTP) -> genutzt von Disk Station Manager

Wird jetzt die Option "HTTPS-Verbindung aktivieren" im Disk Station Manager genutzt, so hat man zusätzlich Zugriff über die HTTPS-Ports:
https://Station -> Port 443 (HTTPS) -> Photo Station, Web Station
https://Station:5001 -> Port 5001 (HTTPS) -> Disk Station Manager

Aktiviert man dann noch die Option "Die Internetverwaltung automatisch zu einem sicheren Kanal umleiten", so wird eine Anfrage auf Port 5000 nach Port 5001 umgeleitet, also:
http://Station:5000 -> https://Station:5001
Der Port 5000 ist damit nicht mehr direkt ansprechbar.

Trolli

Fraggle
16.03.2012, 14:45
Klasse Erklärung.
Ich hoffe, es ist ok, wenn ich hier frage:
Ich habe sowohl https aktiviert also auch die Umleitung gesetzt.
Portweiterleitung im Router habe ich für 443 auch gesetzt (TCP Mode).
Allerdings kann ich dann dennoch nicht per https auf die Photostation zugreifen. Ändere ich die Portweiterleitung im Router auf Port 80, also http, dann klappt es mit derselben Adresse (in der Adresse natürlich https für 443 und für Port 80 http eingegeben). Es werden bei mir nie Port 80 und 443 zeitgleich weitergleitet.

Beispiele (https aktiviert)
Funktioniert http://wan-Ip/benutzername/photo wenn Port 80 im Router weitergeleitet.
Funktioniert nicht https://wan-Ip/benutzername/photo wenn Port 43 im Router weitergeleitet.

Was könnte ich noch vergessen haben?

Edit: DSM 4.0 wird verwendet auf DS712+