PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Fernzugriff Privat / Firma Manager Port 80



Miwok
21.10.2008, 19:56
Tach zusammen


Ich kann von auswäerts ( Freunde ) , ohne Probleme auf den Manager zugreifen.

Aber sobald es über eine Firma eingelogt wird, geht nur das http://meineDYDNS:photo


Was ich hier alles schon gelesen habe:

1. DynDNS am Router konfigurieren, nicht am Synology

2. virtueller Server umleiten öffentlich 80 Privat 5000


anscheinend werden Firma, irgendwie über ein sogenanntes Proxyserver port gefiltert.

dan habe ich ein Toll gefunden, hat fast ein Tag gedauert, und folgende Ports sind offen:

http://www.4shared.com/file/65428988/289ba479/PortScan10B.html

139
445
798
5250
8888
42510


naja, in der neuen Firmware kann man ja Webdienste die Ports zusätzlich eingeben,

habe es mal mit 5250 und 8888 versucht:

öffentlich 80 Privat 5250

öffentlich 80 Privat 8888

Ergebnis:

hatte ein FTP zugriff.... / photo geht immer ????

Da gibt es doch sicherlich eine Hinter Tür zum öffnen, so das ich den Manager mit Port anpingen kann?

Ich habe den durchblick verloren....

P.S Auf den Router http://meineDYDNS:8080 kann ich auch von Gäschäft zugreifen.

So jetzt sind die Profis gefragt

Thanks

itari
21.10.2008, 21:17
Ich versteh wahrscheinlich was Falsches, aber du beschreibst es nicht genau genug:

Du hast also kein Problem, wenn die DS bei dir Zuhause steht und du bei Freunden über deren PC dich auf deine DS anmeldest.

Aber du hast ein Problem, wenn du die DS in deiner Firma ausstellst und von zu Hause aus probierst, dann kommst immer nur auf die Photo Station.


Aber sobald es [die DS] über eine Firma eingelogt [ins Netz anmeldet wird via DynDNS] wird

Und was ist nun dein Problem? Dass du nicht auf den Disk Station Manager kommst? Richtig?

Aber wahrscheinlich versteh ich dein Problem falsch und du kannst mir sicherlich sagen, wie es denn nun wirklich ist? Auf welche Ports du zur Hause bei deiner DS zugreifts (80,81,5000,5001) usw. Wie dein Router zur Hause konfiguriert ist. Ob du DDNS via DS (Ez-Internet) oder via Router machst? Es fehlt immer so viel an Informationen ... Vor allem, was du eigentlich erreichen willst?

itari

jahlives
21.10.2008, 21:43
Wenn ich dich richtig verstanden habe, dann willst du von der Firma aus auf deine (zu Hause) DS zugreifen und es klappt ned? Dann wird der Port vom Proxy der Firma geblocked. Dann würde ich dir empfehlen https zu benutzen. Ausgehende Verbindungen werden sicherlich nicht geblocked und auf deinem Router richtest du eine Portweiterleitung von Port 443 auf Port 5001 mit der IP Adresse der DS ein. Im Manager der Diskstation solltest du dann auch unter Webdienste die Option wählen, dass alle Zugriffe auf den Manager auf SSL (https) umgeleitet werden sollen.

Gruss

tobi

p.s. es ginge auch den DS-Manager über Port 80 anzusprechen, aber dazu bedarf es Änderungen an den Config Files des Servers

TobiasM
21.10.2008, 22:00
ich denke, das Problem ist , das man zwar von Freunden auf die DS kommt.Vom Arbeitsplatz klappt das aber nicht. Dazu ist zu sagen, das es schon einen Sinn haben wird, das in der Firma nicht alles erlaubt ist. Das umgehen des Sicherheitsjkonzeptes KANN zu Arbeitsrechtliche Maßnahmen führen, daher würde ich mir das gut überlegen.
Ich vermute mal, das der Proxy fest im Browser eingetragen ist, daher kannst du nur über den Proxy gehen. Und ob der Proxy andere Ports zulässt, hängt vom Browser ab.
Wenn der Proxy z.B. den massiven Einsatz von JScript unterbindet, dann wirst kein Glück haben, weil der DSM2 ja AJAX nutzt.
Denn ich fürchte es liegt wirklich an der Proxy/Firewall, weniger an dein Portforwarding.
Und ich bin der Meinung, das du deinen Admin auf der Arbeit schlicht fragst.

Gruss
Tobias

Miwok
21.10.2008, 22:16
Hardwarez:

Cablecom Modem an Switch angeschlossen.

1 Router an Switch angeschlosssen bezieht IP xxx.xxx.xxx.74
2 Router an Switch angeschlossen bezieht IP xxx.xxx.xxx.88

warum 2 Router? damit meine Interne Hardwarez, nicht 24 Stunden von der aussenwelt ausgesetzt sind, Häckers usw.

der 2 Router wird 24 Stunden mit den Synology im Betrieb genommen.

Der 207+ ist fest bei mir zu Hause ( Privat )

In einem Tread hast Du geschrieben, das man die DYDNS am Router eingeben soll, habe ich auch befolgt.

Da ich ja 2 Router habe, kann ich es über Wirless, von aussen, via DYNDS zugreifen. Ich kann probemlos zugreifen, auch meine Freunde Privat.

Wenn ich aber im Geschäft bin, kann ich nur auf den Photo zugreifen, der FTP und Manager geht nicht, wurde auch hier schon einmal durchgesprochen.

man soll im Router virtueller Server umleiten öffentlich 80 Privat 5000

geht auch nicht. Ich habe auch hier gelesen, das die Firmen ein sogenante Proxy Server haben, und die Ports geblockt sind. Ein ProxyServer Scan gemacht, siehe Abbildung oben.

Ich hoffe somit es besser erklärt zu haben, ich weiss, viel schreibfehler und mein ausruckweise ist schwierig zu verstehen :D

Miwok
21.10.2008, 22:24
Kaum habe ich fertig geschrieben, da sind ja schon 2 Antworten...

hier seit schneller als dä Wind :D

ich werde mal TobiasM Tipp versuchen DANKE an alle


Wenn ich dich richtig verstanden habe, dann willst du von der Firma aus auf deine (zu Hause) DS zugreifen und es klappt ned? Dann wird der Port vom Proxy der Firma geblocked. Dann würde ich dir empfehlen https zu benutzen. Ausgehende Verbindungen werden sicherlich nicht geblocked und auf deinem Router richtest du eine Portweiterleitung von Port 443 auf Port 5001 mit der IP Adresse der DS ein. Im Manager der Diskstation solltest du dann auch unter Webdienste die Option wählen, dass alle Zugriffe auf den Manager auf SSL (https) umgeleitet werden sollen.

Gruss

tobi

p.s. es ginge auch den DS-Manager über Port 80 anzusprechen, aber dazu bedarf es Änderungen an den Config Files des Servers

Miwok
22.10.2008, 20:37
Guten Abend zusammen

Ich habe über die Mittagzeit versucht auf meinen Nas zuzugreifen.

Irgenwie fahre ich ich im Karussel, einmal kann ich den auf den Manager zugreifen, aber nicht auf Photos oder umgekehrt...

https://meineDYNDNS.ath.cx/ kann ich auf den Manager zugreifen....


http://meineDYNDNS.ath.cx/

Hallo! Herzlich Willkommen bei Synology Web Station!
Der Web Station Service ist aktiviert. Sie können jetzt Ihre eigene Website auf Disk Station erstellen. Folgen Sie diesen Schritten, um Ihre Website Online aufzubauen und zu veröffentlichen.
1. Melden Sie sich im Web Manager an und gehen Sie zur Seite "Rechte > freigegebene Ordner". Weisen Sie Benutzerrechte für den Zugriff auf den freigegebenen Webordner zu.
2. (Erstellen Sie Webseiten und) Laden Sie Ihre Seiten auf den freigegebenen Webordner hoch.
3. Stellen Sie sicher, dass die Startseite Ihrer Website mit "index.php", "index.htm", oder "index.html" benannt ist.
4. Geben Sie http://servername/ in das Adressenfeld des Browsers ein, um Ihre Website anzusehen.

Wie veröffentliche ich meine Website?

Um Ihre Website zu veröffentlichen und Menschen über das Internet zur Verfügung zu stellen, müssen Sie Ihre Disk Station so einstellen, dass sie externe IPs benutzen.
1. Um sich auf dem System Management-UI anzumelden, geben Sie in Ihren Browser bitte http://servername:5000/ ein.
2. Melden sie sich im Web Manager Ihres Disk Station an.
3. Um Disk Station im Internet zu verankern, können Sie wie folgt vorgehen:

Eine externe IP. Gehen Sie zur Seite "System > Netzwerk", um die Netzwerkeinstellungen des Servers zu bearbeiten, wenn Sie von Ihrem Netzwerk-Serviceanbieter eine spezielle externe IP Adresse erhalten.
Die PPPoE Einstellungen. Gehen Sie zur Seite "System > PPPoE", um die PPPoE-Verbindung zu aktivieren.
4. Wenn Sie ein registriertes DDNS Konto nutzen möchten, gehen Sie zur Seite "Netzwerk-Services > Ez-Internet", um den DDNS Service zu aktivieren.
5. Fertig!
Jetzt können Menschen im Internet Ihre Website durchsuchen, indem sie in ihren Browser http://serverIP/ oder http://DDNS_hostname/ eingeben. Für weitere Details zum Zugriff auf Disk Station über das Internet klicken Sie bitte hier.



http://meineDYNDNS.ath.cx/photo/ kann ich auf Photo zugreifen

https://meineDYNDNS.ath.cx/photo/

Es tut uns Leid, die von Ihnen gesuchte Seite konnte nicht gefunden werden.

--------------------------------------------------------------------------------

© 2008 Synology Inc.



http://meineDYNDNS.ath.cx:8888/photo/


Gateway Timeout
The following error occurred:
[code=GATEWAY_TIMEOUT] A gateway timeout occurred. The server is unreachable. Retry the request.



--------------------------------------------------------------------------------
Please contact the administrator.

************************************************** ********

am besten bin ich gefahren:

Virtueller Server:

Öffentlich Protokoll 80 Privat 8888 IP von Synologi
Optionen HTTP-Dienst Zusätzlichen HTTP-Port hinzufügen 8888
:
Öffentlich Protokoll 443 Privat 5001 IP von Synologi

für den 7000 & 7001 was muss da für ein öffentliche Port rein?

jahlives
22.10.2008, 20:47
am besten bin ich gefahren:

Virtueller Server:

Öffentlich Protokoll 80 Privat 8888 IP von Synologi
Optionen HTTP-Dienst Zusätzlichen HTTP-Port hinzufügen 8888
:
Öffentlich Protokoll 443 Privat 5001 IP von Synologi

für den 7000 & 7001 was muss da für ein öffentliche Port rein?
Was läuft denn bei dir auf Port 7000 und 7001? Grundsätzlich kann der externe Port frei gewählt werden. Er sollte sich jedoch oberhalb von Port 1024 befinden, weil sich darunter die definierten Ports bestimmter Applikationen befinden.
Aber was läuft denn bei dir auf Port 8888? Der Port 5001 gehört ja zum DS-Manager. Irgendwie habe ich das Gefühl, dass du das zu kompliziert machst...

Miwok
22.10.2008, 21:03
Was läuft denn bei dir auf Port 7000 und 7001? Grundsätzlich kann der externe Port frei gewählt werden. Er sollte sich jedoch oberhalb von Port 1024 befinden, weil sich darunter die definierten Ports bestimmter Applikationen befinden.
Aber was läuft denn bei dir auf Port 8888? Der Port 5001 gehört ja zum DS-Manager. Irgendwie habe ich das Gefühl, dass du das zu kompliziert machst...

auf dem Port 7000 und 7001 sollten die File Station aktievieren.

wenn ich den Öffentlich Protokoll 80 Privat 50000
Öffentlich Protokoll 443 Privat 50001 konfig.

dan funzt nur das photo...


wenn ich den Öffentlich Protokoll 80 Privat 8888
ÖffentlichProtokoll 443 Privat 50001 konfig.

dan funzt photo und manager :) wobei ich im Webdienst Zusätzlichen HTTP-Port hinzufügen 8888 eingertragen habe ich habe es auch mit 42510 versucht
negativ.

warum ich auf diese ports komme: habe eine Proxyserverscan gemacht, offen waren:

139
445
798
5250
8888
42510

P.S Ich kann aber es ärst in der Mittagszeit Testen :rolleyes:

Der Router kann ja auch Tausend sachen ----

ftp://ftp.dlink.de/dir/dir-655/documentation/DIR-655_reva_man_de_Manual_1.10.pdf

jahlives
22.10.2008, 21:25
Irgendwie sind das zu viele Ports. Wenn du Port 80 auf Port 80 intern und IP der DS "leitest" dann sollte der User Webserver und damit auch die Photostation erreichbar sein. Und Port 443 auf 5001 ist die beste Lösung weil die Proxies https ausgehend garantiert erlauben. Ich erreiche sowohl meinen DS-Manager (root Apache) als auch alle Stations (File,Photo und Audio unter user Apache). Und wenn irgendeine Firewall/Proxy Port 80 oder 443 blockiert dann ist nicht viel los mit Internet. Und wir haben in der Firma einen ziemlich konservativen Proxyserver ;)

Gruss

tobi

Miwok
23.10.2008, 05:47
guten morgen jahlives

ich werde es nochmals vesuchen, das alles im Virtueller Server nicht im
24 -- Port Weiterleitungs-Regeln?

Danke

gruzz

Miwok

Miwok
23.10.2008, 21:49
hat leider nicht geklappt, aber morgen ist ja nochmals mittagszeit ;)

ich habe vergessen im manager Webdienste HTTPS-Verbindung zu aktivieren.

Die Internetverwaltung automatisch zu einem sicheren Kanal umleiten. da muss ja er hacken nicht aktiviert werden?

und auch nicht:

Zusätzlichen HTTP-Port hinzufügen
:
Zusätzlich zur Standardportnummer 80 können Sie noch einen weiteren Port zur Verwendung von Photo Station 3 und Web Station hinzufügen.
Geben Sie die Portnummer ein:


bin ja an gespannt :rolleyes:

jahlives
23.10.2008, 22:06
Also wenn du die Internetverwaltung aus dem Internet erreichbar machen willst, dann solltest du sie schon auf https umleiten --> damit lauscht sie an Port 5001 und nimmt nur verschlüsselte Verbindungen an.