PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Probleme Zugriff über dynds auf Photostation



wolf04
14.09.2008, 10:43
Moin,

Ich hab mich bei dynds.org angemeldet und meine Daten von dort in Router und DS (unter EZ-Internet)eingetragen habe. Dann hab ich die Firewall im router so konfiguriert, dass Port 80 von außen erreichbar ist. Laut http://www.canyouseeme.org/ ist der Port 80 auch erreichbar.
In der DS ist Photostation aktiviert, PPPoE habe ich nicht aktiviert (muss ich das?)

Nun zu meinem Problem:
Gebe ich http://host.dyndns.org ein werde ich zur Konfigurationsseite von meinem router geleitet und nach meinen Zugansdaten gefragt.


Gebe ich http://host.dyndns.org/photo/ ein kommt die Meldung: The requested URL '/photo' was not found on the RomPager server.

Ich hab jetzt seit gestern dran geprokelt, musste nachdem der router nicht mehr erreichbar war diesen sogar reseten und bin nun mit meinem Latein am Ende. Dabei will ich doch nur ein paar Fotos für einen Kollegen verfügbar machen..... Hilfe!!!

Bislang habe ich auch noch keine der externen Zugriffsfunktionen der DS genutzt (intern im LAN funzt alles prima) bin da also absoluter rookie. Auf jeden Fall will ich vermeiden, dass irgendwelche Leute problemlos auf meinem router oder der DS rumspielen können.
Vielleicht kann mir ja jemand helfen.
Ich hab die DS 207+ und einen Arcor Zyxel WLAN 200

itari
14.09.2008, 11:27
Im Router muss man nicht die Firewall konfigurieren, sondern das Address-Translation-Mapping (sogenannte 'virtuellen' Server) einstellen. Dort gibt man an, dass wenn jemand auf deinen Router zugreift (deine DynDNS ist ja die Adresse des Routers), dass dieser dann die Datenpakete weiterleitet an deine DS.

itari

wolf04
14.09.2008, 11:52
hört sich logisch an aber wenn die Firewall doch Port 80 blockiert dann kommt doch garnichts durch, oder?

Ich habe jetzt im Router unter "NAT - SUA/NAT Server Set editieren"
den Port 80 eingestellt und die interne IP der DS.

Leider ist das Ergebnis dasselbe wie oben beschrieben.
Ich hab das Gefühl dass ich irgendwas falsch mache oder vergessen habe einzustellen.

wolf04
15.09.2008, 16:41
So, nach langem Suchen habe ich zumindest die richtigen Einstellungen für meinen Router für die Portweiterleitung und die Firewall getätigt und auch die IP wird durch diesen bei dynds vernünftig aktualisiert. Leider komme ich immer noch nicht auf meine Photos. Die Fehlermeldungen wenn ichs über den dynds namen oder auch die aktuelle externe IP des routers versuche sind immer noch:

Object Not Found
The requested URL '/photo' was not found on the RomPager server.

und wenn ich nur den dynds namen eingebe fragt er mich immer noch nach den Benutzerdaten meines Routers. Von einem anderen Computer (Arbeit) bekomme ich nur ein Timeout.
Hat jemand noch eine Idee wie ich den Mist zum laufen kriegen kann?
Als erweiterte Netzwerkfestplatte ist mir die DS nähmlich doch etwas zu teuer.....
LG
wolf04

Trolli
15.09.2008, 17:58
Kann es sein, dass das Webinterface Deines Routers auf Port 80 liegt? Wenn es so ist, kann man das bestimmt umstellen bzw. den externen Zugriff auf den Router sperren (ist eh eine Sicherheitslücke).

wolf04
15.09.2008, 18:59
Das kann sein....
Ich habe nun mal im Menü Fernverwaltung den Webport auf 81 gelegt. Wenn ich nun Versuche mit meinem dynds Name auf die DS zuzugreifen kommt folgende Meldung:
Verbindung fehlgeschlagen

Firefox kann keine Verbindung zu dem Server unter wolf04.dyndns.org aufbauen.


Obwohl die Website gültig erscheint, konnte keine Verbindung aufgebaut werden.

* Könnte die Website temporär nicht verfügbar sein? Versuchen Sie es später nochmals.
* Können Sie auch andere Websites nicht aufrufen? Überprüfen Sie die Netzwerk-Konfiguration des Computers.
* Wird Ihr Computer oder Netzwerk durch eine Firewall oder einen Proxy geschützt? Falsche Einstellungen können den Web-Zugriff stören.

Ich werde hier noch narrisch. Jetzt prokle ich da schon seit 4 Tagen rum und außer Ärger und ein wenig mehr Verständnis von IPs etc. hat sich noch keinerlei Erfolg eingestellt....
Ich überlege echt, ob ich mir nicht einen anderen Router zulege in der Hoffnung, dass es dann funktioniert. Kann jemand einen empfehlen, der am Besten Gigabit LAN kann??
LG
wolf04

konas02
15.09.2008, 19:54
Hallo wolf04,

also ich war soeben auf Deiner Station.
Mit http://wolf04.dyndns.org/photo kam ich auf Deine Photostation.

hier eins Deiner Bilder:
407
:)

wolf04
15.09.2008, 20:04
Cool!!!!
Dann scheint nur mein Router das intern nicht zu wollen. Ich werde es morgen auf Arbeit nochmal probieren.
Danke dir!!!

wolf04

P.S.: Kannst du sonst noch irgendwo drauf, oder ist da nur der eine Bilderordner zu sehen?

konas02
16.09.2008, 06:48
Ich kann nur den einen, öffentliche Ordner sehen.

:)

wolf04
16.09.2008, 08:03
Vielen Dank an alle, die mir geholfen haben. Das ist ein tolles Forum mit einer super community. Ich freue mich schon darauf, wenn ich mehr Erfahrung habe, auch Newbies helfen zu können
wolf04

Andreas1969
06.11.2008, 11:30
@wolf04

Hallo,

ich möchte gerne auf dein Angebot zurückkommen einem Newbie zu helfen...

Ich habe auch ein Zyxel Arcor WLAN 200 Router/Modem und eine DS-108j und würde gerne die richtige Konfiguration bei der DS und dem Zyxel einstellen, um auch extern auf die Photostation 3 zugreifen zu können. Nach tagelangem probieren habe ich es noch nicht hinbekommen. Ich habe auch ein account bei dhndns.org, welche Ports muß ich im Router einstellen (NAT?), Firewall beim Router, bzw. XP (SP2) ändern, bzw. in der DS (Ez-Internet). Wäre für Hilfe sehr dankbar :-)

Gruß Andreas

jahlives
06.11.2008, 11:41
Der Router braucht eine Portforwarding Regel (heisst meist virtueller Server) für Port 80 extern auf Port 80 intern und die IP der DS


Dann scheint nur mein Router das intern nicht zu wollen. Ich werde es morgen auf Arbeit nochmal probieren.
Danke dir!!!

das ist v.a. bei billigeren Routern so, dass Verbindungen auf den externen Hostnamen (dyndns-Adresse) von intern ned sauber laufen. Das Problem hierbei ist, dass ein TCP Paket erstellt wird (nach NAT-Übersetzung), das die gleiche IP für Sender und Empfänger hat. Wenn die WAN Schnittstelle des Routers nicht rafft, dass ein solches Paket direkt wieder an die LAN-Schnittstelle muss, sondern das Paket an den Gateway des ISP schickt, dann kann dies zu den genannten Problemen führen. Es kann auch passieren, dass sich solche Router bei einem solchen Paket in einer Endlosschleife aufhängen.
Tip: Solche Zugriffe sollte man wirklich von aussen testen. Sprich von einer Kiste, die ausserhalb deines LANs steht

wolf04
06.11.2008, 19:02
das kann ich nur so bestätigen. Mit dem Zyxel ging das auch nicht intern.
Ich werde jetzt trotzdem auf das aktuelle Modell umsteigen da ich u.a. Probs bei der Einbindung meines Ipod ins WLAN hab
Von meinen "alten" Zyxel Einstellungen hab ich aber noch Screenshots. Bei Bedarf einfach mal via PM fragen.
LG
wolf04

Andreas1969
10.11.2008, 11:36
So, jetzt habe ich es hinbekommen auf meine Photostation 3 extern zugreifen zu können.

Hier die Einstellungen:

NAT-Einstellungen (SUE) Port 80 auf die '192.168.1.xx' (IP-Nr.der DS) umleiten

und

Firewalleinstellungen (Regeln) des Routers den Button 'WAN to LAN' aktivieren

Das hat jetzt zwar zur Folge, daß die 'DSL LED' des Routers ständig orange leuchtet, aber das scheint ja normal zu sein...

Gruß Andreas