PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Backup hängt



AleksCee
08.10.2012, 21:57
Hallo @All,

da mir das letzten Sonntag aufgefallen ist und ein Bekannter heute auch von dem Problem berichtet, will ich Euch darüber mal informieren.

Und zwar habe ich Sonntags einen Backup-Task der über die Syno interne Backup-Funktion (Backup/Restore) die mysql-Datenbanken und die Config sichert. Der Job dauert normal keine 5 Sekunden, daher war ich Sonntag morgen schon sehr verwundert, als ich von dem Job um 9h noch keine Mail hatte, das er fertig ist. Immerhin startet er ja um 6h! :-)

Nach etwas rum suchen bin ich schnell darauf gestoßen, dass das Backup auf die Datei:

/tmp/do_file_archive_upgrade.chk

wartet..... diese Datei wurde geschrieben von einem Prozess der "synoarchiveupgrade" heißt und seit dem letzten Update gestartet wurde. Was er macht habe ich noch nicht heraus bekommen, vom Namen her könnte man vermuten das er ZIP- oder TAR-Files bearbeitet. Was er damit allerdings vor hat - keine Ahnung....

Wie auch immer.... weil der Prozess "synoarchiveupgrade" noch da war (bei dem Bekannten sogar fast seit einer Woche und auch nach einem Reboot) werden die Backup-Jobs (nicht die TimeBackups) wohl behindert.

Da ich wissen wollte ob der Prozess noch was tut habe ich alle seine Kinder mit "lsof" und "strace" untersucht.... der letzte Fork von dem Prozess wartete auf den davor und der davor auf den ersten... also strace auf den ersten Prozess und erst passierte nichts.... nach 5 Sekunden lief er auf einmal weiter und weitere 5 Sekunden später kam ein "strace detached" - hmmm komisch... ich wieder nach dem Prozess geguckt - da war er weg... also irgendwie scheine ich ihn durch das "nagucken" wieder geweckt zu haben... kurz nachdem der Prozess weg war war auch die Datei /tmp/do_file_archive_upgrade.chk weg..... und keine 10 Sekunden später war die Mail "das Backup ist abgeschlossen" angekommen. :-)))

Bei dem Bekannten hatten wir leider die unixtools via ipkg (lsof und strace) nicht drauf... daher haben wir versucht den Prozess mit einem kill -3 zu reanimieren... das hat leider nichts gebracht... Also haben wir der den Prozess gekillt und danach die Datei "do_file_archive_upgrade.chk" gelöscht.... dann liefen bei ihm auch die Backups weiter......

Wie gesagt - keine Ahnung was das Teil tut, wieso der hängt.... aber falls Ihr Euch auch über ein Backup wundert, was seit dem letzten Update nicht mehr tut.... vielleicht hilft es ja.... und falls jemand weiß, was diese komischen Programme tun: synoarchivetool, synoarchiveupgrade
bin ich natürlich auch intressiert :-)

Gruß, Alex

zandhaas
09.10.2012, 09:31
Danke,

Bij mir fuctionier das backup wieder.

Bin jetz mal gespant was Synology antworted auf meinem support anfrage.

Peter

zandhaas
09.10.2012, 11:51
Nacjh einem reboot is die datei "/tmp/do_file_archive_upgrade.chk" wieder da!!!!

Also bis Synology eine Lösung hat soll man nach jedem reboot die datei löschen.

andlsbuch
13.10.2012, 14:42
Vielen Dank für den Tipp!

Hatte das selbe Problem, und jetzt funzt es wieder einwandfrei!!

Basalt
14.10.2012, 14:22
For your information, by coincidence I found this:
After I de-installed Mail Server and Mail Station, I rebooted my Syno. 15 minutes later the "synoarchiveupgrade" was ready and "/tmp/do_file_archive_upgrade.chk" automatically removed. Also remained okay after installing Mail Server and Mail Station again.
Logging in /var/log/messages pointed to some problems with Dovecote files (or queues ?).
I reported myfindings to Synology.

BR,
Erik.