PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Kein Zugang wegen Zertifikatwarnung



blacklc2
10.09.2008, 10:43
Hallo,

Ich nutze den DS-106 und habe versehentlich das Umleiten über den sicheren Kanal aktiviert. Nun werde ich immer direkt auf 192.168.2.10:5001 umgeleitet und bekomme die Fehlermeldung: "uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown.
The certificate is not valid for any server names.
"
Mein Problem ist nun das ich nicht mehr in das Webfrontend komme die Einstellung rückgängig zu machen. Kann mir jemd. einen Tipp geben was ich tun soll?

Vielen Dank

--- Hinweis: Es handelt sich um ein neues Problem, das ich zwecks Übersichtlichkeit in einen neuen Thread verschoben habe. ---

itari
10.09.2008, 10:53
Falls man mit dem Telnet auf die DS kommt, kann man die Datei /etc/synoinfo.conf direkt ändern:

ohne HTTPS so:

runHTTPS="no"
redirectHTTPS="no"

oder halt mit HTTPS so:

runHTTPS="yes"
redirectHTTPS="yes"

itari

Trolli
10.09.2008, 10:55
Was für einen Browser benutzt Du denn? Normalerweise sollte man die Zertifikatwarnung auch einfach ignorieren können...

blacklc2
10.09.2008, 11:20
Hi,

Danke erstmal für die Hilfe.

Ich hab es mit dem Firefox 3.0.1 und dem IE 7 versucht.
Ich bekomme keine Schaltfläche angezeigt welche mir ermöglicht ohne Zertifikat zur Weboberfläche zu springen.

Telnet konnte ich gerade noch nicht testen, da das ja unter Vista ausgeschaltet ist und ich erst suchen musste wie man es aktiviert.

->Done

Leider kann ich mich per telnet nicht mit dem DS-106 verbinden.
"Verbindungsaufbau zu 192.168.2.10...Es konnte keine Verbindung mit dem Host hergestellt werden, auf Port 23: Verbinden fehlgeschlagen"

jahlives
10.09.2008, 11:25
Ich hab es mit dem Firefox 3.0.1 und dem IE 7 versucht.

Bei mir FF3 kommt diese Meldung auch. Aber ganz unten auf der Fehlerseite steht was wie "Ausnahme definieren". Ein Klick darauf ermöglicht es das Cert herunterzuladen und zu installieren. Dann klappt es auch mit dem Zugriff

Trolli
10.09.2008, 11:26
...und beim IE7 muss man eigentlich nur auf "Laden fortsetzen" klicken:

jahlives
10.09.2008, 11:28
"Verbindungsaufbau zu 192.168.2.10...Es konnte keine Verbindung mit dem Host hergestellt werden, auf Port 23: Verbinden fehlgeschlagen"

Dann läuft Telent nicht auf der DS. Wohl auch kein SSH? Dann musst du den Cert Fehler loswerden, sonst geht nix mehr (und eine Neuinstallation wäre doch etwas gar arg :D

blacklc2
10.09.2008, 11:37
Aber ganz unten auf der Fehlerseite steht was wie "Ausnahme definieren". Ein Klick darauf ermöglicht es das Cert herunterzuladen und zu installieren. Dann klappt es auch mit dem Zugriff

Vielen Dank. Die Lösung des Problems war reine Banalität. Das Zertifikat ließ sich mit wenigen Klicks im FF3 sofort laden und die Seite anzeigen. Ich habe die engl. Version des FF und wohl irgendwie übersehen das man da Ausnahmen festlegen kann.

Danke nochmal. tolles Forum. Auch wenn mein Problem ehr minderwertig war. :D

jemue
19.01.2009, 11:25
Leider komme ich an der Stelle des Zertifikates ebenfalls nicht weiter.
Der IE 7.0 möchte gern das Zertifikat (wie bereist beschrieben).
Ich kann zwar "das" Zertifikat laden, doch es wird sichtlich nicht installiert. Es wird zwar "https" angezeigt, aber der Maulzustand des IE verändert sich nicht.

Hat evtl. doch jemand eine Lösung zum fehlenden Zertifikat - Danke?

Trolli
19.01.2009, 15:43
Das Zertifikat feht nicht, es ist lediglich nicht auf die korrekte DNS ausgestellt. Im IE kann man nicht wie beim Firefox weiter oben beschrieben eine dauerhafte Ausnahme hinzufügen. Es wird also jedes Mal die Zertifikatwarnung erscheinen. Das bekommt man nur durch ein selbsterstelltes Zertifikat in den Griff: http://www.synology-wiki.de/index.php/Generierung_eines_eigenen_SSL-Zertifikats

Trolli

jemue
19.01.2009, 17:00
Danke für die Antwort.
Da muss ich wohl noch viel Hausaufgaben machen, um mich auch hier einzuarbeiten.
Den Link hatte ich schon einmal beim Wickel - werd mich sicher dazu noch einmal melden. ;)