PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : DSM 4.0-2228 freigegeben



nachon
15.05.2012, 06:40
Hat noch niemand einen Thread dazu erstellt?

Wundert mich etwas. :D

Ich habs gerade runtergaladen und installiere es. Die Änderungen fallen eher gering aus:

Change log:


Photo Station, Audio Station, Surveillance Station and Download Station packages have been updated. Please refer to these packages’ release notes for details.
Enhanced the stability of file based iSCSI LUN over 1TB.
Fixed an issue that caused the incorrect aspect ratio in video playback in Photo Station.


Viel Spaß und Erfolg.

Gruß vom nachon

amarthius
15.05.2012, 07:33
Installiert und bisher keine Probleme :)

swiffer
15.05.2012, 08:13
lads auch gerade runter, schön das kleine Fehler anscheinend recht schnell durch neue Releases gefixt werden, schade das immernoch kein CloudStation Update dabei war, aber es wird schon noch kommen...

rauppe31
15.05.2012, 10:33
Hallo

Mein Mirror lädt gerade die Dateien herunter.
DAS DOWNLOADVERZEICHNIS BEFINDET SICH HIER (http://mirror.naefmarco.ch/index.php?dir=Synology/DSM4.0/2228/)

Natürlich helfe ich auch beim Torrent-Projekt (http://www.synology-forum.de/showthread.html?29615-Synology-DSM-Torrent-Mirror-torrent.10trum.de) mit beim Seeden.

Tommes
15.05.2012, 19:09
Hi!

Hab es auch grad aufgespielt. Läuft ! Ärgerlich nur, das die CloudStation immer noch im Beta-Stadium hängt.
EDIT:Bei mir lief nach dem Update IPKG nicht mehr. Sollte das bei euch aus so sein (vorher bitte überprüfen), muss man evtl. den SymLink neu setzen und die .profile anpassen. Ich schreibs nochmal hier rein, damit nicht wieder die Sucherrei losgeht.

Also, SymLink neu erstellen...


ln -s /volume1/@optware /opt

...und in der /root/.profile wieder den PATH auskommentiert...


#PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin


Gruß Tommes!

DiSa
15.05.2012, 19:51
Vielen Dank für den Hinweis!

Ich habe gerade auch das Update durchgeführt, soweit ohne Probleme. Ich hatte vor dem Update allerdings extra eine Kopie von der .profile angelegt, nach dem Update war diese leider ebenfalls gelöscht :(. Ist das normal? Meine ssh-Keys im .ssh-Verzeichnis waren noch vorhanden.

goetz
15.05.2012, 20:05
Hallo,
@Tommes
mein /opt Link ist erhalten geblieben, schau mal nach ob Du jetzt nicht auch noch ein /opt/opt hast.

@DiSa
wo hast Du das denn hin gesichert? Einfach auf /volume1/public einen Ordner upgrade_sicher erstellen und darein sichern.

Gruß Götz

Tommes
15.05.2012, 20:24
@Tommes
mein /opt Link ist erhalten geblieben, schau mal nach ob Du jetzt nicht auch noch ein /opt/opt hast.


Hallo Goetz!
Ich teste vorher immer mit dem AdminTool, ob der SymLink "opt->/volume1/@optware" noch vorhanden ist. Des weiteren prüfe ich im AdminTool unter "System/IPKG", ob irgendwelche Pakete installiert sind. In der Regel steht dann da eine 0, wenn IPKG das Update nicht überlebt hat. Zu guter letzt geb ich in der Konsole einfach ein "ipkg update" ein. Wenn auch das fehl schlägt, lege ich den SymLink neu an und änder die .profile!

Diese Vorgehensweise ist vielleicht etwas umständlich, aber da ich nicht der Linux-Crack bin, lass ich halt immer etwas vorsicht walten.

Und um auf deine Frage zurück zu kommen. Nein, ich habe kein /opt/opt! Trotzdem, guter Hinweis. Denn ich habe das oben geschrieben, da ich davon ausgegangen bin, das IPKG ein Update in der Regel nichgt überlebt. (Jedenfalls nicht den SymLink) Sollte vielleicht noch drauf hinweisen, das das nur notwendig ist, wenn IPKG nicht läuft!

Gruß Tommes!

EDIT: Hab meinen Beitrag unter #5 abgeändert!

DiSa
15.05.2012, 20:24
Ich hatte ins gleiche Verzeichnis gesichert, d.h. .profile.bak. Mittlerweile habe ich festgestellt, dass wohl das ganze Verzeichnis /root gelöscht und neu angelegt wird. Aber warum ist dann mein /root/.ssh - Verzeichnis mit den Keys noch vorhanden?

goetz
15.05.2012, 20:29
Hallo,
vor dem platt machen der Systempartition werden einige spezielle Teile gesichert und nach dem Upgrade zurück geschrieben.
Aus /etc/upgrade.sh
BackupDirList="/etc /usr/syno/etc /var /usr/syno/synoman/webman/3rdparty /usr/local /root/.ssh"

Gruß Götz

DiSa
15.05.2012, 20:33
Vielen Dank! Jetzt weiss ich ja, wo ich meine Dateien hinsichern muss und welche Verzeichnisse ich besser meide ... ;)

rolco
17.05.2012, 08:24
ich habe ein anderes Problem seit dem Update, der Assistant findet die Diskstation nicht mehr. Über den Browser mit der IP komme ich aber ganz normal rein.Im Assistant kann ich auch im Fotouplader nach Eingabe der IP
normal hochladen.Habe in mehrmals gelöscht und neu aufgespielt, keine Besserung.hat noch jemand dieses Problem.
Im Windows Explorer wird die Diskstation angezeigt.
Windows7,DS 111

pofoklempner
17.05.2012, 14:52
Hallo,

Update auf DSM4.0-2228 ohne Probleme. Man sollte den Synology Assistenten nicht vergessen, von dem gibt es auch schon einige neue Versionen seit DSM 4.0.

Gruß Pofoklempner

rolco
17.05.2012, 15:35
Habe den aktuellen Assistant geladen

swiffer
17.05.2012, 15:39
weiß nicht ob es euch auch interessiert, es gibt ein Beta Update für die CloudStation, hab im Unterforum hier bereits ein passendes Thema erstellt.

Annika Hansen
18.05.2012, 11:26
Kaum hatte ich das Upgrade meiner beiden Diskstations auf DSM 4.0-2219 abgeschlossen, da war schon das nächste Release verfügbar. Also schnell die Releasenotes gecheckt, und da einer der Bugfixes für mich relevant scheint, beide Diskstations auf DSM 4.0-2228 "geupgraded" (schönes Denglisch *g*).

Funktional habe ich bisher keine Probleme feststellen können, allerdings ist mir aufgefallen, dass die CPU-Auslastung im "normalen Betriebszustand" konstant so um die 25% liegt. Mit "normalen Betriebszustand" meine ich, dass keine Indizierungen, Kopieraktionen o.ä. aktiv sind - Die Diskstations sind einfach nur eingeschaltet (Uptime jeweils ca. 21h30m). Im Ressourcenmonitor sieht das so aus:

8657

und auch mit top ist auch kein Ressourcen-"Dieb" zu erkennen:

8658

Hat jemand anderes dieses Phänomen auch beobachtet? :eek:

Annika Hansen
18.05.2012, 11:47
Kommando zurück: Ich habe das Problem identifiziert und auch gleich abgestellt. :cool:

Das war/ist der DS-Assistant (4.0-2216) auf meinem Win7-PC, der auf beiden Diskstations diese Load erzeugt. Und zwar dann, wenn man sich im Reiter "Ressourcen-Monitor" mit den Diskstations verbindet. Kaum habe ich den DS-Assistant beendet, geht die Load auf erwartete, normale Werte zurück. Mannomann... :eek:

Also: Kein Problem mit DSM 4.0-2228! Puuhhh...

stargate2k
22.05.2012, 18:03
Hi,

bei mir lief das Update auch ohne Probleme durch, den SymLink neu erstellen und die .profile auskommentieren musste ich aber auch noch machen zwecks ipkg..

Der Cloudstation-Client konnte sich nach dem Update nicht mehr connecten, mit der neusten Version geht es jetzt aber wieder..

Noch ne andere Frage, wie lange dauert bei euch nen neustart der DS ? Bei mir dauert der mehrere Minuten ist das normal ? war aber bei mir schon immer so lange.. hat also jetzt nichts mit dem Update hier zutun...

Wie ich auf der Startseite gelesen habe gibt es bald ein 4.1 Event, hat dazu einer schon Infos was da neues kommt ? Die Syno-Jungs sind echt fleisig was updates angeht so soll es sein... Auch kommen immer mehr Pakete ins Paketcenter...
Weiß einer wieso gerade Pyhton als Paket erschienen ist ? Wenn sie Python zulassen dann könnten sie eigentlich auch IPKG offiziell untersützen.

mfg stargate

FRoemer
23.05.2012, 17:04
Hallo!

Ich habe auch ein Update auf 4.0-2219 gemacht und nun kann ich weder ipkg benutzen (brauche ich um PERL Libs zu laden) noch mit per SSH als Root anmelden (brauche ich für den SymLink, oder?)!

Was mache ich falsch?

Nun läuft ein Update auf 4.0-2228 ... schlimmer wird's nimmer ;-)

Tommes
23.05.2012, 17:39
Hi!
Also das Problem mit IPKG könntest du hiermit (http://www.synology-forum.de/showthread.html?29614-DSM-4.0-2228-freigegeben&p=243625&viewfull=1#post243625) lösen. Warum du nicht mehr auf die Konsole kommst, weiß ich aber nicht. Ist SSH bzw. Telnet in der DSM aktiviert?


Gruß Tommes!

FRoemer
23.05.2012, 18:11
Hallo!

SSH ist gestartet komme auch mit dem Admin-User drauf... aber beim setzen von SymLink bekomme ich einen Access denied. Früher habe ich einfach den Root benutzt, damit konnte ich so Kleinigkeiten machen. Damit kann ich mich aber nun nicht mehr anmelden...

Gruß
Frank

Puppetmaster
23.05.2012, 18:15
Hallo!

SSH ist gestartet komme auch mit dem Admin-User drauf... aber beim setzen von SymLink bekomme ich einen Access denied. Früher habe ich einfach den Root benutzt, damit konnte ich so Kleinigkeiten machen. Damit kann ich mich aber nun nicht mehr anmelden...


Hast du Root auch kleingeschrieben? 'root' ??
Ne Kleinigkeit, kann aber einen großen Unterschied machen. :)

Bongobing
27.05.2012, 09:04
Hallo,

habe auch die Version 2228 drauf und muß leider sagen das ich weniger begeister bin. Seit dieser Version ist DLNA nur noch mit stottern möglich mein Samsung TV muss ständig nachladen, war voher nie ein Problem. Ich habe nun eben ein drop der DB gemacht hoffentlich hilft das sonst muss ich mal schauen das ich die DS211j wieder downgrade. Ich könnte mich selbst in den A**** beissen das ich ein update gemacht habe obwohl alles super lief :-(

borg2k
27.05.2012, 15:18
Also bei meiner DS-412+ bereitet DLNA keine Probleme am Samsung TV.

FRoemer
28.05.2012, 06:52
Hallo!

Habe auf die 2228 "geupdated" und nun kann ich mich wieder als root anmelden und IPKG zum laufen bringen. Mit dem SymLink und dem Auskommentieren vom Path läuft mein IPKG auch wieder und somit die Haustechnik ;-).

Danke

LouR
01.06.2012, 11:48
Ich meine meine DS212+ lief bis zum Update problemlos. Danach hatte ich mit WebDAV nur noch Probleme. Zugriff via iCal (Mac) und Android (CalDav-Sync) funktionierte weiterhin problemlos. Der Zugriff via https://diskstation:5006/calendar/user/ führt mich zwar noch bis zur Abfrage des Benutzers aber danach wird abglehnt (Forbidden 403). Leider führte die Suche im Netz zu keiner Lösung - bin versucht das Ding irgendwie wieder downzugraden. Datenverlust ist egal...

Hat das sonst noch jemand bemerkt?

wolfgang
01.07.2012, 11:14
Hallo alle miteinander,

seit Version 2228 gehen meine Syno's wieder mal nicht schlafen... (mehrere verschiedene im Einsatz z.B.: DS209+, DS209, DS210+ mit HDD von Samsung, WD, Seagate)
Keine Pakete installiert, kein Mediaserver oder ähnliches und definitiv auch kein Media-Index Dienst am laufen, auch bei abgezogenem LAN Kabel kein Unterschied. Ich nutze ausschließlich die SMB Fileservice-Funktionen.
Vor dem update hat hibernation hervorragend funktioniert und ist ja leider nicht das erste mal, dass es damit Probleme gibt.

Hat noch jemand ähnliche Probleme?

Benares
01.07.2012, 11:36
Also prinzipiell funktioniert es bei mir. Es hat allerdings nach dem Update und dem Abschluss der Indizierung noch einige Tage gedauert, keine Ahnung wieso.
Wie lange ist das Update her?

Ich hab danach sogar schrittweise einige Pakete aktiviert, und es funktioniert immer noch.

Gruß Benares

wolfgang
01.07.2012, 11:43
Hallo Benares,

upgrade ist schon über eine Woche her, Systeme auch mal komplett abgeschaltet und neu gestartet. Das seltsame ist, dass es nicht immer die gleichen sind die nicht schlafen gehen. Jede meiner Syno's hat immer mal wieder dieses Verhalten, mal schlafen sie, mal wieder für mehrere Tage nicht. Ich werd noch ganz irre...
Vielleicht setze ich die Systeme mal neu auf, allerdings dauert dann der Restore wieder mehrere Tage und das wollte ich eigentlich vermeiden.

Aber Danke für deine Antwort

Gruß Wolfgang

cyberdude
02.07.2012, 12:37
Hallo Wolfgang,

gleiches Problem bei mir. Laut Protokoll werden die Dienste usw. um die voreingestellte Zeit beendet, aber die Diskstation fährt nicht vollständig herunter.
Es gibt aber auch wieder Tage, da klappt alles so, wie es sein soll... :rolleyes:
Erst hatte ich die Vermutung, daß evtl. noch offene Daten zum angemeldeten PC dafür verantworlich sein sollten, aber das hat in der Vergangenheit ja auch nicht gestört (da kam dann nur am PC eine Fehlermeldung, daß der Pfad nicht mehr gefunden werden konnte.).
Zeitlich ist dieses Verhalten aber mE mit dem Update der Firmware verbunden.

Markus