PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Browser meldet "Certificate Error" beim Aufruf der Management Oberfläche



Eismaus
02.07.2008, 21:02
Hallo,

auch auf die Gefahr hin, das ich mit meinen Fragen anfange zu nerven, ich bräuchte nochmal hilfe.

Ich habe meine DS-108j als Photostation laufen, auch die Verbindung ins Internet klappt problemlos (Fritz!box 7050).

Wenn ich jetzt lokal die Management Oberfläche aufrufe, https://diskstation:5001/ kommt bei mir erstmal eine Fehlermeldung:


Certificate Error:Navigation blocked

There is a problem with this website's security certificate.


The security certificate presented by this website was not issued by a trusted certificate authority.
The security certificate presented by this website was issued for a different website's address.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.
We recommend that you close this webpage and do not continue to this website.
Click here to close this webpage.
Continue to this website (not recommended).
More information


If you arrived at this page by clicking a link, check the website address in the address bar to be sure that it is the address you were expecting.
When going to a website with an address such as https://example.com, try adding the 'www' to the address, https://www.example.com.
If you choose to ignore this error and continue, do not enter private information into the website.

For more information, see "Certificate Errors" in Internet Explorer Help.

Wenn ich auf "Continue to this website" klicke läd er die Management Oberfläche und ich kann ganz normal arbeiten.

Befor ich die PhotoStation aktiviert und fürs Internet freigegeben habe, kam der Fehler nicht. Oder er ist mir absolut entgangen.
Daher vermute ich mal, das bei mir noch Einstellungen nicht stimmen.

Hat jemand eine Idee, an welcher Stelle ich ansetzten muß?

Vielen Dank für die Hilfe,
Eismaus

Trolli
02.07.2008, 21:35
Der Zertifikatfehler kommt immer dann, wenn die Verbindung zur DS über eine HTTPS-Verbindung aufgebaut wird. Das liegt daran, dass das Zertifikat der Synology-Station nicht auf die eigene DyndDNS-Adresse ausgestellt ist, sondern nur allgemein auf 'www.synology.com'. Das entspricht allerdings nicht der eingegebenen Internetadresse und deswegen kommt der Zertifikatfehler. Verhindern kann man das nur, indem man sich selbst ein eigenes Zertifikat generiert und dieses auf dem zugreifenden Rechner installiert. Eine Anleitung dazu gibts hier (auf Englisch): http://www.synology.com/wiki/index.php/How_to_generate_custom_SSL_certificates

Trolli

Eismaus
02.07.2008, 21:51
Ok, Zertifikat erstellen. Ich werde mir den Link morgen nochmal mal in ruhe durchlesen.

Aber eine Frage habe ich trotzdem jetzt schon.
Wenn ich mich lokal in meinem Netzwerk befinde, dann gehe ich doch garnicht über die DyndDNS-Adresse.. *verwirrung*

Sollte es nicht ein Unterschied sein, ob ich https://diskstation:5001/ oder https://meineAdresse.dyndns.org:5001/ eingebe?

Zumal ich den Zugriff auf die Mangement Console garnicht fürs Internet freigegeben habe.

Trotzdem schon mal dank!
Eismaus

Trolli
02.07.2008, 22:05
Wenn die eingegebene Adresse nicht mit dem Zertfikat übereinstimmt, kommt die Zertifikatwarnung. Im Falle des Standard-Zertifikats, das auf www.synology.com (http://www.synology.com) ausgestellt ist, wird die Warnung immer erscheinen. Wenn Du dir nun ein Zertifikat auf meineAdresse.dyndns.org (http://meineAdresse.dyndns.org) ausstellst, wirst Du trotzdem noch eine Warnung erhalten, wenn Du lokal über https://diskstation:5001 auf Deine DS zugreifst.

Zur Lösung dieser Problematik kannst Du entweder auch lokal über https://meineAdresse.dyndns.org zugreifen (wenn Dein Router das versteht), oder Du könntest im lokalen Netzwerk über den nicht verschlüsselten Port 5000 auf die DS zugreifen (http://diskstation:5000). Wenn dieser Port 5000 nicht am Router weitergeleitet wird, ist auch dann ein Zugriff über unverschlüsseltes HTTP aus dem Internet nicht möglich.

Die Zertifikatwarnung hat übrigens keinerlei Einfluss auf die Sicherheit der Verbindung. Die Verschlüsselung ist über das Standard-Zertifikat genauso gegeben.

Trolli

wennessen
17.08.2008, 09:32
Ich bin noch nicht lange Besitzer meiner Cubestation, und habe natürlich wie jeder auch die Zertifikatsmeldungen. Ich kenne Zertifikate und PKIs schon seit langem und das ist auch nicht das Problem. Wenn man aber der Anleitung der Erstellung zum eigenen Zertifikat folgt hat man das Problem, das man an den entsprechenden Stellen an die man die neu erstellten Zertifikate kopieren muss keinerlei Schreibrechte hat. SUDO oder su und zum root wechseln klappt nicht. Jemand Erfahrung ?

itari
17.08.2008, 09:38
Ich bin noch nicht lange Besitzer meiner Cubestation, und habe natürlich wie jeder auch die Zertifikatsmeldungen. Ich kenne Zertifikate und PKIs schon seit langem und das ist auch nicht das Problem. Wenn man aber der Anleitung der Erstellung zum eigenen Zertifikat folgt hat man das Problem, das man an den entsprechenden Stellen an die man die neu erstellten Zertifikate kopieren muss keinerlei Schreibrechte hat. SUDO oder su und zum root wechseln klappt nicht. Jemand Erfahrung ?

Melde dich doch als Benutzer 'root' mit dem telnet an - Kennwort ist das, was du dem Benutzer 'admin' verpasst hast. Dann dürften die Schreibrechte kein Problem mehr sein.

sudo müsste man mit dem ipkg nachinstallieren. Warum bei dir su nicht geht, versteht ich nicht.

itari

wennessen
17.08.2008, 09:57
Hm. Peinlich. Ich hatte gedacht das schon probiert zu haben und habe in Erinnerung das es nicht geklappt hatte und angenommen, das Synology den Root-Zugriff via SSH nicht erlaubt... Aber bestens. Danke.