PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : MTU dauerhaft anders einstellen? (DS207)



elton_NRW
09.04.2008, 08:19
Hallo zusammen,

da ich via VPN (IPSec) auf meine DS zugreife, habe ich das Problem der Fragmentierung von Paketen (MTU 1500 ist zu groß, da IPSec-Overhead dazukommt). Und das senkt die Performance (verfügbare Bandbreite), da die VPN-Gateways dann die Pakete aufteilen müssen und mehrmals IPSec-Header etc. dazukommen.

Mittels Telnet und ifconfig eth0 mtu 1400 kann ich die MTU ja auf 1400 setzen (als Beispiel), allerdings ist diese Einstellung nach einem Neustart natürlich wieder weg.

Weiss jemand von Euch, wie ich die MTU-Einstellung dauerhaft einstellen kann, so dass diese beim Start geändert wird auf einen anderen Wert als 1500?

Vielen Dank für Eure Mühen
Elton

cccc
02.01.2010, 21:04
Hallo zusammen,

da ich via VPN (IPSec) auf meine DS zugreife, habe ich das Problem der Fragmentierung von Paketen (MTU 1500 ist zu groß, da IPSec-Overhead dazukommt). Und das senkt die Performance (verfügbare Bandbreite), da die VPN-Gateways dann die Pakete aufteilen müssen und mehrmals IPSec-Header etc. dazukommen.

Mittels Telnet und ifconfig eth0 mtu 1400 kann ich die MTU ja auf 1400 setzen (als Beispiel), allerdings ist diese Einstellung nach einem Neustart natürlich wieder weg.

Weiss jemand von Euch, wie ich die MTU-Einstellung dauerhaft einstellen kann, so dass diese beim Start geändert wird auf einen anderen Wert als 1500?

Vielen Dank für Eure Mühen
Elton

über Web Interface (Synology Disk Station Manager) -> Network

coolhot
02.01.2010, 21:37
Im DSM stehen keine Werte kleiner 1500 zur Auswahl. Daher müsstest du den ifconfig-Befehl in das Startscript (/etc/rc.local) aufnehmen oder selbst eins anlegen (z.B. /usr/local/etc/rc.d/S99mtu.sh). Beispiel dafür findest du hier (http://www.synology-forum.de/showthread.html?t=7157).

cccc
02.01.2010, 22:50
Im DSM stehen keine Werte kleiner 1500 zur Auswahl. Daher müsstest du den ifconfig-Befehl in das Startscript (/etc/rc.local) aufnehmen oder selbst eins anlegen (z.B. /usr/local/etc/rc.d/S99mtu.sh). Beispiel dafür findest du hier (http://www.synology-forum.de/showthread.html?t=7157).

Sorry, ich habe im Posting einfach übersehen, dass MTU kleiner als 1500 ist.
Meinst Du vielleicht in Deinem Link statt /usr/local/etc/rc.d/S99mtu.sh /usr/local/etc/rc.d/S99mount.sh, oder auch was übersehen? ;)

Auf meiner DS 209+ II Box konnte ich MTU size problemlos folgendermassen ändern:

# cp /etc/synoinfo.conf /etc/synoinfo.conf_save
# vi /etc/synoinfo.conf und folgende Werte anpassen:

supportMTU="no"
eth0_mtu="1492"

anschliessend die Box einfach restarten und mit dem ifconfig eth0 kontrollieren:

station> ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:11:32:05:53:32
inet addr:192.168.2.13 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:271 errors:0 dropped:0 overruns:0 frame:0
TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:27897 (27.2 KiB) TX bytes:54615 (53.3 KiB)
Interrupt:18 Memory:c0004000-0

gruss
cccc

itari
03.01.2010, 11:36
Dran denken, dass die MTU-Werte nicht unbedingt 1:1 von den Kartentreiber übernommen werden, sondern nur so 'ungefähr' die Größe darstellen. Ich kann mich erinnern, dass '1492' oft das Gleiche bedeutet wie '1500' ...

Itari

cccc
03.01.2010, 11:50
Dran denken, dass die MTU-Werte nicht unbedingt 1:1 von den Kartentreiber übernommen werden, sondern nur so 'ungefähr' die Größe darstellen. Ich kann mich erinnern, dass '1492' oft das Gleiche bedeutet wie '1500' ...

Itari

Nicht ganz!
MTU steht für Maximum Transmission Unit und beschreibt die maximale Grösse der Nutzdaten die in einem Datenpacket übertragen werden können.
Ein Ethernetframe hat eine maximale Grösse von 1518 Byte. Davon beansprucht der Header 14 Byte und die Prüfsumme (Frame Check Sequence, FCS) weitere 4 Byte. Somit verbleiben genau 1500 Byte für Nutzdaten. Die MTU für Ethernet beträgt also 1500 Byte.
Beim Internetzugang via DSL kommt auf der Verbindung zum Internetprovider häufig das Protokoll PPPoE zum Einsatz. PPPoE beansprucht in jedem Frame 8 Byte zur Übertragung von Verbindungsinformationen. Die MTU reduziert sich daher bei der Verwendung von PPPoE auf 1492 Byte. ;)
Durch den Einsatz weiterer Protokolle (z.B. L2TP) bei einigen Providern, kann sich die MTU noch weiter verringern. Den genauen Wert sollten man bei seinem Provider erfragen.
z.B. über meinen ipsec tunnel kommt nur 1370 ohne Fragmentierung durch:

C:\Documents and Settings\User>ping -f -l 1370 10.10.1.13

Pinging 10.10.1.13 with 1370 bytes of data:

Reply from 10.10.1.13: bytes=1370 time=62ms TTL=62
Reply from 10.10.1.13: bytes=1370 time=42ms TTL=62
Reply from 10.10.1.13: bytes=1370 time=42ms TTL=62
Reply from 10.10.1.13: bytes=1370 time=44ms TTL=62

Ping statistics for 10.10.1.13:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 42ms, Maximum = 62ms, Average = 47ms

C:\Documents and Settings\User>ping -f -l 1375 10.10.1.13

Pinging 10.10.1.13 with 1375 bytes of data:

Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.

Ping statistics for 10.10.1.13:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


http://www.dslreports.com/faq/695

cccc
03.01.2010, 12:07
Ich habe in wiki gepostet:

http://www.synology-wiki.de/index.php/MTU_size_kleiner_als_1500_dauerhaft_%C3%A4ndern

coolhot
03.01.2010, 21:59
Meinst Du vielleicht in Deinem Link statt /usr/local/etc/rc.d/S99mtu.sh /usr/local/etc/rc.d/S99mount.sh, oder auch was übersehen?

Wie die Datei in dem Pfad heisst ist fast egal, sie muss nur dem Muster S<Nr.><Text>.sh folgen

Auf meiner DS 209+ II Box konnte ich MTU size problemlos folgendermassen ändern:

# cp /etc/synoinfo.conf /etc/synoinfo.conf_save
# vi /etc/synoinfo.conf und folgende Werte anpassen:

supportMTU="no"
eth0_mtu="1492"

Ok, den Weg kannte ich nicht. :-)


Wenn das den Reboot überlebt ist´s natürlich noch eleganter.

Muss man nach einer Änderung der MTU eigentlich neu starten damit es wirksam wird? Es wäre ja interessant je nach Verbindungsart ad-hoc die MTU einzustellen.

cccc
03.01.2010, 23:05
Muss man nach einer Änderung der MTU eigentlich neu starten damit es wirksam wird?

Natürlich muss man nicht neu starten, via telnet oder ssh reicht vollkomen ;)

# /etc/rc.network restart

BTW elton_NRW wollte, dass nach dem Start hardcoded wird, ich wollte ihn nur überzeugen, dass auch so bleibt.

coolhot
03.01.2010, 23:10
Danke für den Hinweis. Ok Network restart langt auch.

cccc
03.01.2010, 23:12
Bitte schön.

Desperado
24.01.2010, 01:26
Hallo,

ich betreibe eine DS209 und habe mit CCCC's Anleitung versucht die MTU auf 1492 zu ändern. Im etc/synoinfo.conf stehen auch nun die neuen Werte (supportMTU=no ; eth0_mtu=1492).

Prüfe ich nach dem Speichern des Files mit "ifconfig eth0" die Konfiguration ist die MTU immernoch auf 1500. Auch nach einem Neustart der DS209 bleibt der Wert auf 1500. (Wie gesagt obwohl in der conf 1492 steht)

Woran kann das liegen?

LG
Desperado

cccc
28.01.2010, 13:02
Hallo,

ich betreibe eine DS209 und habe mit CCCC's Anleitung versucht die MTU auf 1492 zu ändern. Im etc/synoinfo.conf stehen auch nun die neuen Werte (supportMTU=no ; eth0_mtu=1492).

Prüfe ich nach dem Speichern des Files mit "ifconfig eth0" die Konfiguration ist die MTU immernoch auf 1500. Auch nach einem Neustart der DS209 bleibt der Wert auf 1500. (Wie gesagt obwohl in der conf 1492 steht)

Woran kann das liegen?

LG
Desperado

Hast Du das neuste Firmware installiert?
Kannst Du bitte Dein ganzes /etc/synoinfo.conf posten?

Desperado
28.01.2010, 18:54
Hallo CCCC,

ich habe die neuste Firmware installiert (noch vor kurzem).

Meine Firmware:

Modellname:
DS209
Aktuelle Firmwareversion:
DSM 2.2-0959
Firmware datum:
2009/11/13

Meine synoinfo.conf sieht folgendermaßen aus:



unique="synology_88f6281_209"
company_title="Synology"

# system options
timezone="Amsterdam"
language="def"
maillang="ger"
codepage="ger"
defquota="5"
defshare=""
defgroup="users"
defright="writeable"
eventsmtp=""
eventmail1=""
eventmail2=""
eventauth="yes"
eventuser=""
eventpass=""
configured="yes"
admin_port="5000"
secure_admin_port="5001"
pswdprotect="no"
supportweb="yes"
supportphoto="yes"
support_download="yes"
supportmysql="yes"
supportquota="yes"
supportitunes="yes"
supportddns="yes"
supportfilestation="yes"
supportssl="yes"
supportssh="yes"
supportHTTPS="yes"
supportNFS="yes"

# service options
runsamba="yes"
runapple="yes"
runftpd="yes"
ftpport="21"
ftp_trans_ext_ip="no"
ftpflowcontrol="no"
ftpmaxuploadrate="0"
ftpmaxdownloadrate="0"
ftpanonymouslogin="no"
diskcache="on"
standbytimer="15"
standby_force="yes"
enableguest="no"
usbbkp="yes"
usbcopy="yes"
netbkp="yes"
runnetbkp="no"
runmysql="no"
runfilestation="no"
runaudiostation="no"
supportmediaservice="yes"
runmediaservice="no"
codepage_mediaservice="utf8"
language_mediaservice="enu"
supportups="yes"
ddns_update="no"
ddns_select=""
portmap_admin="no"
portmap_ftp="no"
portmap_http="no"
portmap_http_add="no"
portmap_netbkp="no"
portmap_netbkp_encrypt="no"

# service limitations
maxaccounts="1024"
maxgroups="128"
maxshares="256"
maxservices="128"
maxdisks="2"
maxprinters="2"
maxlogsize="64"

# UI options (limitations)
company="synology"
supplang="enu,cht,chs,krn,ger,fre,ita,spn,jpn,dan,nor,sve,nl d,rus,plk,ptb,ptg,hun,trk,csy"
product="Disk Station"
manager="Synology Disk Station"
vender="Synology Inc."
mailfrom="Synology Disk Station"
updateurl="http://www.synology.com/"
win98autodisconnect="yes"

wins="none"
AppleTalk="eth0"
default_ip="dhcp"
default_mask=""
default_gateway="192.168.1.1"

hostname="DiskStation"
ntpdate_period="daily"
ntpdate_server="time.windows.com"
ntpdate_server_backup=""
run_ntpdate="yes"

sdkversion="no"
allowanonymous="yes"

httpport="80"
defaultfs="ext3"
addport="no"
albumdefpublic="yes"
phpregisterglobal="no"
supportuart2="yes"
runafp="no"
oplock_disabled="no"
upnpmodelurl=""
upnpmodelname="DS209"
upnpmanufacturerurl="http://www.synology.com/"
runupnp="no"
upnpfriendlyname="Disk Station Device"
upnpdevicetype="DiskStation"
upnpmodeldescription="Disk Station UPnP Device"
supportsystemperature="yes"
support_audio="yes"
supportMTU="no"
support_fan_adjust_dual_mode="yes"
supportsurveillance="yes"
supportdcacheui="yes"
synobios="ds209"
supportstartupd="yes"
supportdomain="yes"
enableRCPower="yes"
supportfanctrl="yes"
support_auto_poweron="yes"
supportraid="yes"
support_synopkg="yes"
supportrcpower="yes"
support_mtd_serial="yes"
surveillance_camera_max="5"
fantime="1"
supportsmart="yes"
shutdownafterfanfail="5"
supportvideostation="yes"
eth0_mtu="1492"
fanspeed="low"

# Fixed items
codepage_apple="1850"
usb_standbytimer="20"
runweb="no"
runphoto="no"
download_enabled="no"
download_order="request"
download_when="00:00-00:00"
download_ul_rate="0"
download_dl_rate="0"
download_start_port="0"
download_end_port="0"
download_port_map_enabled="no"
download_seeding_interval="0"
download_seeding_ratio="0"
download_enable_dht="no"
download_dhtport="6881"
download_btencrypt="disable"
download_btmaxpeers="100"
download_enable_amule="no"
download_amule_ul_rate="0"
download_amule_dl_rate="0"
download_amule_tcp_port="4662"
download_amule_udp_port="4672"
download_amule_max_conn="500"
download_amule_auto_connect="0"
download_maxtasks="1"
download_nzb_server=""
download_nzb_port="119"
download_nzb_auth="no"
download_nzb_user=""
download_nzb_password=""
download_nzb_numconn="2"
download_ftpmax_enable="no"
download_ftpmax="3"
runitunes="no"
runsurveillance="no"
usbcopyfolder=""
auto_poweron_enable1="no"
auto_poweron_date1=""
ftpanonymouschroot="no"
ftpanonymousroot=""
ftpipautodeny="no"
ftplowport="0"
ftphighport="0"
ftponlyssl="no"
ftpsupportutf8="no"
ftpmaxconnperip="0"
ftpxferlog="no"
ftpUserChroot="no"
runssh="yes"
eventport="25"
eventusessl="yes"

# Fixed items
php_cache_size="32"
php_cache_enabled="yes"
smstemplate="https://api.clickatell.com/http/sendmsg?user=@@USER@@&password=@@PASS@@&api_id=3148203&to=@@PHONE@@&text=@@TEXT@@"
smsport="80"
ss_cms="yes"
eventtest="off"
max_iscsitrgs="10"
smssepchar="+"
smstest="no"
smspass=""
smsneedinterval="no"
smsssl="yes"
supportntfswrite="yes"
ss_sync_event_player="yes"
smsphone1=""
smsphone2=""
support_iscsi_target="yes"
smsuser=""
smsserver="clickatell"
smsinterval="1"

# Fixed items
sendthumb_mediaservice="no"
ss_vs="yes"
download_amule_enable_obfuscation="1"
download_amule_outgoing_obfuscation="1"
download_amule_only_obfuscation="0"
download_amule_auto_update_server="0"
download_email_notification="0"
download_rapidshare_user=""
download_rapidshare_password=""



Wenn ich "ifconfig eth0" abfrage bekomme ich folgendes:



eth0 Link encap:Ethernet HWaddr 00:XX:XX:XX:XX:XX
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1589414 errors:0 dropped:0 overruns:0 frame:0
TX packets:1851833 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:1270878593 (1.1 GiB) TX bytes:2070822695 (1.9 GiB)
Interrupt:11

cccc
28.01.2010, 21:54
Du kannst Synology Server neu installieren:

http://www.synology.com/support/faq_show.php?lang=deu&q_id=348

und /etc/synoinfo.conf nochmals anpassen.

BTW Bei der Neuinstallation werden die auf dem Synology Server gespeicherten Daten nicht gelöscht.

Desperado
29.01.2010, 15:40
Ich habe die Station neuinstalliert. Dann die MTU wieder in der conf geändert.

"ifconfig eth0" zeigt mir trotzdem nachwievor folgendes:



eth0 Link encap:Ethernet HWaddr 00:11:32:05:57:D4
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING ALLMULTI MULTICAST MTU:1500 Metric:1
RX packets:1077 errors:0 dropped:0 overruns:0 frame:0
TX packets:1286 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:151215 (147.6 KiB) TX bytes:348347 (340.1 KiB)
Interrupt:11



Kann es nicht sein, dass sich der verantwortliche MTU-Wert in einer anderen conf befindet?

btw: Ich habe auch mal den Netzwerkdienst neugestartet...ohne Erfolg.

cccc
29.01.2010, 16:03
Waren bei der Neuinstallation ALLE Einstellungen zurückgesetzt worden?

Was geschieht wenn Du manuell versuchst?

# ifconfig eth0 mtu 1492

Desperado
29.01.2010, 18:12
Ja, mit dem Reset waren alle Einstellungen zurückgesetzt worden. Auch alle Benutzer, Gemeinsame Ordner, zusätzlich installierte Pakete sind weg.

Ich habe es mal mit dem manuellen Befehl versucht. Dabei bekomme ich ein "Segment fault" in der Konsole zurück. Danach habe ich minutenlang gewartet (10-15min) aber die Box kam nicht mehr zurück. Habe dann Stecker ziehen müssen.

Letztendlich hat sich ander der MTU nichts geändert. Immernoch 1500...

cccc
29.01.2010, 18:36
Ja, mit dem Reset waren alle Einstellungen zurückgesetzt worden. Auch alle Benutzer, Gemeinsame Ordner, zusätzlich installierte Pakete sind weg.

Ich habe es mal mit dem manuellen Befehl versucht. Dabei bekomme ich ein "Segment fault" in der Konsole zurück. Danach habe ich minutenlang gewartet (10-15min) aber die Box kam nicht mehr zurück. Habe dann Stecker ziehen müssen.

Letztendlich hat sich ander der MTU nichts geändert. Immernoch 1500...

Das ist gar nicht gut!
Vielleicht Netzwerkport von synology box defekt, beschädigt ist oder unterstützt keine untere MTU Werte.

Meine DS209+II unterstützt problemlos MTU von 1490, aber z.B bei 1460 hängt sich ebenfalls auf.

Wenn Du von der command line MTU nicht manuell ändern kannst, dann kann Dein System beim Restart den Wert von /etc/synoinfo.conf auch nicht nehmen und nimmt einfach default von 1500.

Was geschiet wenn Du über web interface MTU z.B auf 2000 änderst?
Ist MTU nach dem Restart immer noch 2000?

Bist Du über hub, switch, router mit der synology box verbunden?
Du kannst versuchen austauschen bzw. neues switch besorgen oder testweise die synology box direkt mit dem computer verbinden.

BTW Warum eigentlich möchtest Du MTU ändern?

Desperado
29.01.2010, 22:31
Ich habe die Station auch mal direkt an meinen PC gehängt und den MTU mal auf 2000 gesetzt. Danach zeigt mir die Shell auf den MTU 2000 an. Danach nochmal auf 1492 versucht, Ergebnis: 1500

Hab jetzt mehrmals einen reset-Durchgeführt. Das Ergbnis bleibt das Gleiche. Alle Clients hier im Netzwerk hängen am Router, sowie auch die DS209. Aber das Hauptproblem weshalb ich überhaupt die MTU ändern möchte habe ich HIER (http://www.synology-forum.de/showthread.html?t=10441) mal erklärt. Dieses Problem trat auch vorher schon auf, als ich die FritzBox als Router genutzt habe.

Ich denke es ist ein Problem der MTU. Die zu großen MTU-Werte bringen das QoS wohl durcheinander. Mein Router (ein WRT54GL mit Tomato-Firmware) unterstützt jedoch das manuelle einstellen der MTU. Diese steht im Moment auf 1492. Heißt also das er die MTU's der DS209 nicht verarbeiten kann oder Probleme damit hat.
Ich könnte nun mal versuchen im Router die MTU auf 1500 zu erhöhen...
Dann müssten sowohl die kleinen DSL-Pakete (1492) und die Ethernet-Pakete von der DiskStation (1500) akzeptiert werden. Wenns funktioniert können diese dann auch vom QoS verarbeitet werden.

Ich hoffe nur, dass dann meine DSL-Verbindung noch fehlerfrei funktioniert wenn ich die MTU auf 1500 erhöhe im Router.

We will see...