PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Login Fenster zum Webinterface verändern



andysmith
21.02.2010, 12:18
Gibt es eine Möglichkeit das Login Fenster so abzuändern, das es nur die Userform gibt in welcher ich mich dann als admin mit dem Usernamen admin anmelden kann, ohne erst in dem ziemlich verwirrenden Std. Login Fenster den Voreingestellten Systemadmin abzuändern?
In Summe also nur zwei Textfenster (Name, Password) sonst nix.

Danke für Hilfe und Info

itari
21.02.2010, 14:07
Gibt es eine Möglichkeit das Login Fenster so abzuändern, das es nur die Userform gibt in welcher ich mich dann als admin mit dem Usernamen admin anmelden kann, ohne erst in dem ziemlich verwirrenden Std. Login Fenster den Voreingestellten Systemadmin abzuändern?
In Summe also nur zwei Textfenster (Name, Password) sonst nix.

Danke für Hilfe und Info

Dazu hatte ich mal vor langer Zeit was geschrieben ...

Itari

Hannibal7777
21.02.2010, 14:48
Glaube der Link http://www.synology-forum.de/showthread.html?t=8468 hier sollte dir weiterhelfen.

Hannibal

andysmith
21.02.2010, 20:07
Glaube der Link http://www.synology-forum.de/showthread.html?t=8468 hier sollte dir weiterhelfen.

Hannibal

THX diese Info hat mir geholfen!!

thedude
21.02.2010, 20:22
Happy hacking. :D

gruss
dude

itari
22.02.2010, 08:54
Ich habe irgendwie eine Erinnerung als gäbe es eine Lösung mit einer Option (search-string) in der URL. Kann das jemand mal verifizieren? Als Aufruf z.B. so ungefähr:


https://IP_der_DS:5001/index.cgi?login_type=user

Der Beitrag für den Login-Mod gab es hier: http://www.synology-forum.de/showthread.html?t=2310

Itari

andysmith
22.02.2010, 20:45
Ich habe irgendwie eine Erinnerung als gäbe es eine Lösung mit einer Option (search-string) in der URL. Kann das jemand mal verifizieren? Als Aufruf z.B. so ungefähr:


https://IP_der_DS:5001/index.cgi?login_type=user

Der Beitrag für den Login-Mod gab es hier: http://www.synology-forum.de/showthread.html?t=2310

Itari

auch wenn ich die Verschlüsselung noch nicht aktiviert habe und nur den normalen Login testen konnte ...., aber nein. Das Problem konnte ich gestern auch nicht lösen, da der Login auf verwunderliche Weise schon nicht mehr funktioniert, wenn ich nur den Adminteil entferne ohne etwas am Radio Type etc. zu ändern

der relevante Teil ist:


<div id="div_tab_login" class="login_message_div">
<form name="login_form" method="post" action="" onsubmit="return SendLogin();">
<table width="320" border="0" cellpadding="4" align="center">
<tr>
<td>
<span class="login_message_title">{STRING:choose_login_account}{STRING:colon}</span>
</td>
</tr>
<tr>
<td>
<input type="radio" onClick="loginSetFocus(this.value)" name="login_type" value="admin" checked>
<span class="login_message">{STRING:login_account_admin}</span>
</td>
</tr>
<tr>
<td>
<input type="radio" onClick="loginSetFocus(this.value)" name="login_type" value="user" maxlength="256">
<span class="login_message">{STRING:login_account_other}</span>
&nbsp;
<input name="username" type="text" value="" onfocus="onClickUserName();" size="16" class="login_text_field" maxlength="256">
</td>
</tr>
<tr>
<td>
<span class="login_message_title">{STRING:login_enter_password}{STRING:colon}</span>
</td>
</tr>
<tr>
<td nowrap>
<input name="password" type="password" size="20" class="login_text_field" maxlength="256">
&nbsp;<input type="submit" value="{STRING:login}" class="login_button">
</td>
</tr>
</table>
</form>
</div>

wenn ich dort folgendes entferne sieht zwar alles fast so aus wie es soll, aber der Login streikt


<tr>
<td>
<input type="radio" onClick="loginSetFocus(this.value)" name="login_type" value="admin" checked>
<span class="login_message">{STRING:login_account_admin}</span>
</td>
</tr>
<tr>

jahlives
22.02.2010, 20:56
Das funzt wahrscheinlich ned, weil dem verarbeitenden Loginscript die POST Variable login_type mit Wert admin fehlt. Ersetz der radio input duch einen versteckten input type="hidden" name="login_type" value="admin" Das müsste klappen...