PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Fehler: "Sie haben sich bei einem anderen Computer angemeldet." (Reloaded)



Vulcan_TBB
26.01.2010, 11:11
Hallo Community!

Wie auch andere (http://www.synology-forum.de/showthread.html?t=4113&highlight=anderen+Computer+angemeldet) kämpfe ich mit dem Problem, das mich die Disk-Station bzw. der Synology Disk Station Manager beim einloggen mit der Meldung "Sie haben sich bei einem anderen Computer angemeldet." abweist.

http://home.fonline.de/fo0637/temp/anderem_computer.png

Der Zugriff auf die Diskstation erfolgt von aussen mittels Dyndns-Service und Portforwarding auf die Disk-Station.

Nach einiger Zeit bin ich auf den Grund gekommen, warum die Disk-Station so reagiert. Ich bin viel außer Haus beim Kunden unterwegs. Dieser Kunde verwendet in seinem Intranat-Internet Gateway einen Proxyserver mit Lastverteilung. Dieser Proxy-Cluster besteht aus 5 Maschinen, welche Internetseitig alle unterschiedliche IPs verwenden.
Das bedeutet, das auf eine geöffnete und bereits durch User/Passwort authorisierte Session mal mit der einen, dann mit der anderen IP zugegriffen wird. Mit welcher, lässt sich jedoch nicht vorhersagen. Das kann u.U. bedeuten, das die Session einige Minuten erhalten bleibt, man manchmal jedoch schon nach 2 Sekunden gekickt wird. Gegenbeweis: Wenn ich mich von unserer Geschäftsstelle aus (stinknormaler Router) auf die Disk-Station einlogge, klappt alles wunderbar. Die Problematik lässt sich jederzeit reproduzieren und verhält sich auf allen getesteten Browsern (IE6/7, FF3.5) identisch.
Achja: Zuhause werkelt eine DS-109j. Der Fehler taucht mit dem DSM V2.1 als auch mit der aktuell laufenden Version 2.2. auf. Auf der Synology-Seite gab es mal einen Testzugang für die Version 2.2. (Link nicht mehr gefunden) - dort hatte ich genau das gleiche Problem. Blacklisted IPs habe ich natürlich auch gecheckt (ist bei mir allerdings deaktiviert)

Im Normalfall ist dieses Feature eine nette Sache - doch hier geht diese Art des Session-Management (Bindung an eine IP) voll in die Hose.
Leider habe ich im DSM V2.2 keine Möglichkeit gefunden, die Bindung einer Session an die IP auzuknipsen - oder vielleicht auf Session-Management mit Hash umzustellen.

Gibt es seitens Synology vielleicht Bestrebungen, sowas zu integrieren?
Gibt es interimsweise vielleicht einen "Hack"?

Besten Dank für eure Hilfe!
Stefan

itari
26.01.2010, 12:45
Wende dich mit diesem Problem an den Synology-Support. Die sollen dazu eine Lösung entwickeln. Das Forum hier ist ja ein reines Community-Forum, da schaut niemand von Synology hinein.

Itari

Vulcan_TBB
26.01.2010, 15:05
Habe ich gerade mal getan. Bin mal gespannt, wie es weitergeht.
Ich werde hier wieder berichten, falls sich was tut.

Gruß,
Stefan

Vulcan_TBB
29.01.2010, 09:35
Hallo Leute,

Wie itari empfohlen hatte, habe ich mich direkt an den Synology-Support gewendet.

Hier die Antwort:

Dear Stefan,

Thanks for your message.

This feature will be an option implemented in network solution of DSM 2.3.
It may prevent from duplicated signed in when IP changes on proxy-server with load-balancing.

Thanks again for bringing this issue to our attention.

Best Regards

Übersetzung:

Lieber Stefan,

Danke für deine Nachricht.

Das Feature (Deaktivieren des Session-Binding an eine IP) wird eine Option sein, die in der Netzwerklösung des DSM 2.3 eingebaut wird.
Es wird generell verhindern, das man doppelt eingeloggt ist wenn sich die IP eines Load-Balancing-Server ändert.

Danke noch mal, das Du uns an diese Sache erinnert hast.

Beste Grüße

Will sagen: damit sollte das Problem dann behoben sein! :)

Schönen Gruß,
Stefan

rottenbacher
03.05.2010, 07:50
Hallo zusammen,

ich bin Neuling und habe heute das gleiche Problem. Habe den DSM 2.3 abgesucht aber die besagte Option mit der man das IP-Binding ausschalten kann nicht gefunden.

Gibt es das im DSM 2.3 wie angekündigt und wenn ja, wo ist das versteckt.

Gruß Klaus

Vulcan_TBB
03.05.2010, 09:04
Ich habe mir die 2.3 bisher nur runtergelanden, aber noch nicht aufgespielt.
Sobald ich sie drauf habe, werde ich mal nachsehen. Im changelog habe ich bisher allerdings auch nix gefunden...

rottenbacher
06.05.2010, 08:52
Hier die Antwort vom support:

Thanks for your message.

May I please know whether you had enabled Session Security in Option setting of Diskstation? (See attachment) When this option enabled, will the problem remain or not?

Thanks again for your message and your interest in Synology. Feel free to contact us for any further assistance.

Wie funktioniert das? Oben auf der Startseite das Management auswählen.
Dann auf das icon des Schraubenschlüssels klicken.
Jetzt den Haken bei der unten stehenden Option aktivieren.


Sitzungssicherheit
:
Aktivieren Sie diese Option, um eine bessere Kompatibilität der Browser hinter einem Proxy-Server zu erreichen; allerdings wird die Sicherheitsstufe herabgesetzt.
:
Browserkompatibilität durch Verzicht auf IP-Prüfung verbessern

itari
06.05.2010, 09:03
Ich hab mal ein Bildchen gemacht

Itari

Osno11
12.12.2010, 17:27
Hallo,

ich finde das im aktuellen DSM nicht (Bild von Itari)... kann jemand aushelfen???

Osno11
12.12.2010, 17:29
hab's...
Oben auf den Pfeil -> Optionen (oben rechts) ... und dann auf Sitzungssicherheit.

Vulcan_TBB
13.12.2010, 10:15
Nachdem ich nun auch den DSM 3.0 drauf habe und die Funktion "Browserkompatibilität durch Verzicht auf IP-Prüfung" an habe, gibt es keinerlei Problem mehr. :)

simply
10.04.2011, 07:21
hiho, ich weiss das thema hier isch schon älter, aber leider habe ich das dieses Problem auch .. :-/

Ich hab das neue DSM 3.1-1605 drauf..

vorher gings immer tadellos, leider ist mir meine HD abgekackt und habe nun alle daten verlohren.
nun habe ich eine neue gekauft und eingebaut und das restliche auch neu gemacht, aber ohne erfolg.

Matthieu
10.04.2011, 09:25
Haken setzen bei: Bedienfeld->DSM-Einstellungen->Sicherheit->Browserkompatibilität durch Verzicht ...

MfG Matthieu