PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : IPKG auf DS209+



riedo
17.04.2009, 09:13
Hallo Zusammen

Ich habe da ein Problem mit der Instalation von IPKG, die ja man schlussendlich braucht um openssh oder dergleichen zu instalieren. Ich habe die ""Anleitung" aus http://www.synology-forum.de/showthread.html?t=6457&highlight=ipkg+update durchgeführt und erhielt bei der Eingabe von /opt/bin/ipkg update folgende fehlermeldung:
/opt/bin/ipkg: /opt/bin/ipkg: 1: Syntax error: word unexpected (expecting ")")

Was ist da schief gelaufen? Kann jemand helfen? Möchte schlussendlich sftp und scp möglich machen. Danke für eure Hilfe.

itari
17.04.2009, 09:19
Ganz sicher hier dieses gemacht???


wget http://ipkg.nslu2-linux.org/feeds/optware/cs08q1armel/cross/unstable/ipkg-opt_0.99.163-10_arm.ipk

So wie es aussieht, hast da ein nicht mit dem Prozessor kompatibles ipkg-Programm aufgerufen.

Itari

riedo
17.04.2009, 09:27
Hallo Itari

Das mit dem wget war stellt momentan sowieso ein Problem dar. Also habe ich die Datei ipkg-opt_0.99.163-10_arm.ipk nicht via DS heruntergeladen aber dann auf die DS kopiert. Und zwar in \volume1\pubic Ordner.

mit weget scheint der Download nicht zu funktionieren - geht rgendwie viel zu lange. Die DS gibt dann auch ein connection time out aus.

Trolli
17.04.2009, 10:46
Die + Serie benutzt einen anderen Prozessor als die ohne +. Deshalb kann das so nicht funktionieren.

Trolli

riedo
17.04.2009, 10:50
Scheint plausibel. Aber wie kann ich dann meinen DS sftp fähig machen? Dazu muss ja das IPKG drauf. Oder?

Trolli
17.04.2009, 10:58
Ja. Das ist halt das Problem mit den neuen Prozessoren. Du musst dich wohl noch ein wenig gedulden, bis auch für den Prozessor der + Serie ein IPKG verfügbar ist...

Trolli

riedo
17.04.2009, 11:01
Ok, aber damit ich alles richtig verstanden habe: Ich muss tatsächich IPKG installiert haben um sftp freischalten zu können oder?

Besten Dank für die Hilfe.

Trolli
17.04.2009, 11:07
Ja. Aber ich hab glaube ich nicht alles richtig geschrieben. Die 209+ ist doch gar kein neuer Disk Station Typ. Es sollte eigentlich mit dieser Datei funktionieren: http://ipkg.nslu2-linux.org/feeds/optware/syno-e500/cross/unstable/syno-e500-bootstrap_1.2-5_powerpc.xsh

Nachzulesen hier: http://www.synology-wiki.de/index.php/IPKG

Trolli

riedo
17.04.2009, 11:26
Genau. Das habe ich am Anfang gemacht. Gut, probiere es hier nochmal und schreibe die Schritte die mache. Eventuell ist da der Wurm drin:

Die besprochene Datei befindet sich im \public ordner
Wie geschrieben verwende ich dann den Befehl: sh syno-e500-bootstrap_1.2-5_powerpc.xsh
Bis jetzt alles ok. Dann steht in der Ausgabe:
Backup your configurtaion settings, then type:
rm - rf /volume1/@optware
rm -rf /usr/lib/ipkg
This remove all existing optware packages.

"Problem": wo finde ich die config settings, wenn ich das im Terminal mache. In der GUI könnte man dies ja auch machen. Dasselbe?

Weiter: You must *reboot* and then restart the bootstrap script. Wie mache ich das genau. Sory für die Umstände.

Dann müsste eigebtlich dann das ipkg update funktionieren.

Trolli
17.04.2009, 11:49
Am Anfang hast Du das nach Deinen Angaben mit dem IPKG-Package für die neue DS-209 gemacht. Die hat wie gesagt einen anderen Prozessor und funktioniert deshalb nicht.

Problem dabei ist, dass Du natürlich dabei schon ein (nicht funktionsfähiges) IPKG auf Deine DS installiert hast. Deshalb sollst Du - wie in der Ausgabe steht - die beiden Befehle ausführen, um die alte IPKG-Installation zu entfernen. Ein Backup ist hierbei nicht notwendig, da Du ja dort noch keine Konfigurationen hast.

Und den anschließenden Reboot (Neustart) bekommst Du doch bestimmt hin, oder?

Trolli

riedo
17.04.2009, 12:04
Alles gemacht, neu gebootet, dann im /pblic verzeichnis ipkg update eingegeben und wieder feher bekommen:

-ash: ipkg: not found

Das ganze Prozedere hatte ich schon ganz am Anfang ausprobiert. Mit dem Rebot sollte es auch den restart the bootstrap script durchführen oder? Wenn nicht, was soll man da tun. Denn eigentlich sollte nun alles funktionieren.

Trolli
17.04.2009, 12:50
Nein. Du löscht mit den angegebenen Befehlen die entsprechenden Ordner, bootest dann neu, und installierst dann IPKG wie hier beschrieben: [/URL][url]http://www.synology-wiki.de/index.php/IPKG#Installation (http://www.synology-wiki.de/index.php/IPKG)
Natürlich mit der richtigen Datei für Deinen Prozessor...

Trolli

riedo
17.04.2009, 13:06
Hallo Trolli

Hat nun alles funktioniert. Super! Dankeschön. Nur scheine ich nur noch Probleme beim Herunterladen von Dateien zu haben. wget und update haben da zu lange um Dateien zu downloaden. Weist du gerade wo man den proxy angeben kann?

Trolli
17.04.2009, 13:11
Nein, da bin ich im Moment überfragt. Hatte bisher noch keine Probleme mit den Downloads über wget.

riedo
17.04.2009, 13:13
Trotzdem besten Dank. hast mir riesig geholfen!!!:)