PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : DiskStation> ipkg update -> ipkg: not found



Nelix
24.03.2010, 22:00
Hallo zusammen!

HAbe ein Problem bei der IPKG-Installation. Das "IPKG update" funktioniert nicht. Siehe unten:

**********************************
DiskStation> cd public
DiskStation> ls
DiskStation> wget http://nslu2-linux.dyoung-mirror.net/feeds/optware/syno-x07/cross/unstable/syno-x07-bootstrap_1.2-7_arm.xsh
--21:56:18-- http://nslu2-linux.dyoung-mirror.net/feeds/optware/syno-x07/cross/unstable/syno-x07-bootstrap_1.2-7_arm.xsh
=> `syno-x07-bootstrap_1.2-7_arm.xsh'
Resolving nslu2-linux.dyoung-mirror.net... 208.113.203.106
Connecting to nslu2-linux.dyoung-mirror.net|208.113.203.106|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 250,358 (244K) [text/plain]

100%[====================================>] 250,358 150.75K/s

21:56:20 (150.38 KB/s) - `syno-x07-bootstrap_1.2-7_arm.xsh' saved [250358/250358]

DiskStation> sh syno-x07-bootstrap_1.2-7_arm.xsh
Optware Bootstrap for syno-x07.
Extracting archive... please wait
bootstrap/
bootstrap/bootstrap.sh
bootstrap/ipkg-opt.ipk
bootstrap/ipkg.sh
bootstrap/optware-bootstrap.ipk
bootstrap/wget.ipk
1226+1 records in
1226+1 records out
Creating temporary ipkg repository...
Installing optware-bootstrap package...
Unpacking optware-bootstrap.ipk...Done.
Configuring optware-bootstrap.ipk...Setting up ipkg arch-file
Modifying /etc/rc.local
Done.
Installing ipkg...
Unpacking ipkg-opt.ipk...Done.
Configuring ipkg-opt.ipk...Done.
Removing temporary ipkg repository...
Installing wget...
bootstrap.sh: bootstrap.sh: 45: /opt/bin/ipkg: not found


BusyBox v1.1.0 (2010.03.04-03:32+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

DiskStation> ipkg update
/bin/sh: ipkg: not found
****************************************

Was stimmt nicht bzw. was muss ich machen?

Vielen Dank im Voraus.

Nelix

jahlives
24.03.2010, 22:04
Neugestartet hast du mal? Warst du auch sicher als root angemeldet?

Nelix
24.03.2010, 22:23
Ja, habe gerade mal neu gestartet. Hat nichts gebracht.
War/bin als root per Putty angemeldet.

DiskStation> cd /volume1
DiskStation> ls
@optware aquota.group homes music public
@tmp aquota.user lost+found photo
DiskStation> cd public
DiskStation> ipkg update
-ash: ipkg: not found
DiskStation> cd /public
-ash: cd: can't cd to /public
DiskStation> ls
bootstrap syno-x07-bootstrap_1.2-7_arm.xsh
DiskStation> ipkg update
-ash: ipkg: not found
DiskStation> cd /bootstrap
-ash: cd: can't cd to /bootstrap
DiskStation> cd bootstrap
DiskStation> ls
bootstrap.sh ipkg.sh wget.ipk
ipkg-opt.ipk optware-bootstrap.ipk
DiskStation> ipkg
-ash: ipkg: not found
DiskStation> ipkg update
-ash: ipkg: not found
DiskStation>

jahlives
24.03.2010, 22:39
Kannst du mal ein


echo $PATH
machen?

Nelix
24.03.2010, 22:40
Hallo!

Hat sich erledigt.

Hatte den gleichen Fehler gemacht wie hier: http://www.synology-forum.de/showthread.html?t=10904&highlight=ipkg

Falsche Datei. Hat dann aber geklappt so wie im Link beschrieben.

Trotzdem Danke für die Hilfe!

Nelix